summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-08-19 18:26:05 +0000
committerFabian Groffen <grobian@gentoo.org>2007-08-19 18:26:05 +0000
commit89e552b11822faf4ec64076bbc98877707acc3e6 (patch)
tree92fc6f4110745b020a584da8d7b7d8c90f81c0ef
parenteclasses live in the main prefix tree now (diff)
downloadprefix-89e552b11822faf4ec64076bbc98877707acc3e6.tar.gz
prefix-89e552b11822faf4ec64076bbc98877707acc3e6.tar.bz2
prefix-89e552b11822faf4ec64076bbc98877707acc3e6.zip
Moved to main prefix tree
svn path=/prefix-overlay/; revision=326
-rw-r--r--gnustep-base/gnustep-back-art/Manifest3
-rw-r--r--gnustep-base/gnustep-back-art/files/config-gnustep-back-art.sh6
-rw-r--r--gnustep-base/gnustep-back-art/gnustep-back-art-0.12.0.ebuild71
3 files changed, 0 insertions, 80 deletions
diff --git a/gnustep-base/gnustep-back-art/Manifest b/gnustep-base/gnustep-back-art/Manifest
deleted file mode 100644
index fb0529d..0000000
--- a/gnustep-base/gnustep-back-art/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX config-gnustep-back-art.sh 224 RMD160 eb46fdaec47b1a5c893b1d6b3cdfcd357e2fffa3 SHA1 ecc68c4c37d1de58eac20a4fd8c67835f8d0bdd2 SHA256 00f7bffda66b80e733415459216bcc6e93105cc0fa65410004a56d7f6e9ef5f3
-DIST gnustep-back-0.12.0.tar.gz 853996 RMD160 ad19420127bb0e2e5f7dc9c3cf9974ea06255565 SHA1 859aef314eb9ef5cbedad9dc53a818542baa17ec SHA256 59b000aa069e2a50398b31296ce5d663f98fc8d131bfd8f3d10e29b0a5379a45
-EBUILD gnustep-back-art-0.12.0.ebuild 1548 RMD160 0893dc6c07b5fccc13bf8093a99301076e692822 SHA1 9686dbb6b44a98936bbb4a96cc79710cb6405146 SHA256 c9f2f880a6a4aea3b428cc8f7901a8a034874dad1bf9e205b2b720edc21af3fe
diff --git a/gnustep-base/gnustep-back-art/files/config-gnustep-back-art.sh b/gnustep-base/gnustep-back-art/files/config-gnustep-back-art.sh
deleted file mode 100644
index 03a700e..0000000
--- a/gnustep-base/gnustep-back-art/files/config-gnustep-back-art.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/usr/bin/env bash
-echo "Setting default fonts..."
-defaults write NSGlobalDomain NSFont DejaVuSans
-defaults write NSGlobalDomain NSBoldFont DejaVuSans-Bold
-defaults write NSGlobalDomain NSUserFixedPitchFont DejaVuSansMono
-
diff --git a/gnustep-base/gnustep-back-art/gnustep-back-art-0.12.0.ebuild b/gnustep-base/gnustep-back-art/gnustep-back-art-0.12.0.ebuild
deleted file mode 100644
index 4737937..0000000
--- a/gnustep-base/gnustep-back-art/gnustep-back-art-0.12.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="prefix"
-
-inherit gnustep-base
-
-S=${WORKDIR}/gnustep-back-${PV}
-
-DESCRIPTION="libart_lgpl back-end component for the GNUstep GUI Library"
-
-HOMEPAGE="http://www.gnustep.org"
-SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
-KEYWORDS="~amd64 ~x86 ~x86-solaris"
-SLOT="0"
-LICENSE="LGPL-2.1"
-
-IUSE="opengl xim"
-
-DEPEND="${GNUSTEP_CORE_DEPEND}
- ~gnustep-base/gnustep-gui-${PV}
- opengl? ( virtual/opengl virtual/glu )
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXt
- x11-libs/libXft
- x11-libs/libXrender
- dev-libs/expat
- media-libs/fontconfig
- >=media-libs/freetype-2.1.9
- >=media-libs/libart_lgpl-2.3
- gnustep-base/mknfonts
- media-fonts/dejavu
- !virtual/gnustep-back"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- egnustep_env
-
- use opengl && myconf="--enable-glx"
- myconf="$myconf `use_enable xim`"
- myconf="$myconf --enable-server=x11"
- myconf="$myconf --enable-graphics=art"
- econf $myconf || die "configure failed"
-
- egnustep_make
-
- # Create font lists for DejaVu
- einfo "Generating nfonts support files"
- cd Fonts
- mknfonts $(fc-list : file|grep -v '\.gz'|cut -d: -f1)
- # Trim whitepsaces
- for fdir in *\ */; do
- mv "$fdir" `echo $fdir | tr -d [:space:]`
- done
-}
-
-src_install() {
- egnustep_env
-
- gnustep-base_src_install
-
- mkdir -p "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
- cp -pPR Fonts/*.nfont "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
-}
-