summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-08-13 18:57:58 +0000
committerFabian Groffen <grobian@gentoo.org>2007-08-13 18:57:58 +0000
commitad46785071c1756eb71dda16f2acc3f17d5885e9 (patch)
tree4db07567eed54121371f2692adaafd480ef3eadc
parentadd gnustep-apps/fontmanager (diff)
downloadprefix-ad46785071c1756eb71dda16f2acc3f17d5885e9.tar.gz
prefix-ad46785071c1756eb71dda16f2acc3f17d5885e9.tar.bz2
prefix-ad46785071c1756eb71dda16f2acc3f17d5885e9.zip
add gnustep-apps/gnumail
(Portage 2.2.00.7595-prefix/SVN/Linux 2.6.20-1.2925.fc6 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+) svn path=/prefix-overlay/; revision=282
-rw-r--r--gnustep-apps/gnumail/Manifest3
-rw-r--r--gnustep-apps/gnumail/files/gnumail-1.2.0_pre3-index.patch37
-rw-r--r--gnustep-apps/gnumail/gnumail-1.2.0_pre3.ebuild91
3 files changed, 131 insertions, 0 deletions
diff --git a/gnustep-apps/gnumail/Manifest b/gnustep-apps/gnumail/Manifest
new file mode 100644
index 0000000..294a86c
--- /dev/null
+++ b/gnustep-apps/gnumail/Manifest
@@ -0,0 +1,3 @@
+AUX gnumail-1.2.0_pre3-index.patch 1276 RMD160 61db1f6235e038aec440908692c6c633f576ba0b SHA1 c46b39e86904548130885d4cbd86207e563ef816 SHA256 1836fb38201c30fa52d9b96cb14447844a426e56d2ef8c5af90ebec0c5cf9473
+DIST GNUMail-1.2.0pre3.tar.gz 1327521 RMD160 5d8ff5d6d520f586eca5eb194ed2bafa3e718d0c SHA1 a03e8cc6281c5c050a6fee204d1057be17d69a36 SHA256 29127a65f35208a461436853b41de81f46db7d735958b40e06776805114d7b37
+EBUILD gnumail-1.2.0_pre3.ebuild 1631 RMD160 738a0acbc3462d4c2c4ef74696adbe8b8f536f07 SHA1 8a0bea04a1b7188ab266df67c8d93996e9f9db09 SHA256 9bf4fdafbca24a4d8e21b251982fe7c416f12ffb5b21626bd7b93a3c24392174
diff --git a/gnustep-apps/gnumail/files/gnumail-1.2.0_pre3-index.patch b/gnustep-apps/gnumail/files/gnumail-1.2.0_pre3-index.patch
new file mode 100644
index 0000000..384911c
--- /dev/null
+++ b/gnustep-apps/gnumail/files/gnumail-1.2.0_pre3-index.patch
@@ -0,0 +1,37 @@
+--- Framework/GNUMail/MailWindowController.m.orig 2007-06-22 17:21:42.000000000 +0200
++++ Framework/GNUMail/MailWindowController.m 2007-06-22 17:23:39.000000000 +0200
+@@ -2372,14 +2372,8 @@
+
+ // We set any vertical mouse motion has being dragging
+ [dataView setVerticalMotionCanBeginDrag: NO];
+-
+- // FIXME: Should we really make that work under OS X and MingW?
+- // Find the right * y ratio
+-#if !defined(MACOSX) && !defined(__MINGW32__)
+- // We set the table row height, depending on the current font
+- aSize = [[NSFont seenMessageFont] maximumAdvancement];
+- [dataView setRowHeight: aSize.height];
+-#endif
++
++ [dataView setRowHeight: [[NSFont seenMessageFont] defaultLineHeightForFont]];
+
+ // We load the right set of columns
+ [self _reloadTableColumns: self];
+@@ -2854,16 +2848,7 @@
+ //
+ - (void) _fontValuesHaveChanged
+ {
+- // FIXME: Should we really make that work under OS X?
+- // Find the right * y ratio
+-#ifndef MACOSX
+- NSSize aSize;
+-
+- // We set the table row height, depending on the current font
+- aSize = [[NSFont seenMessageFont] maximumAdvancement];
+- [dataView setRowHeight: aSize.height];
+-#endif
+-
++ [dataView setRowHeight: [[NSFont seenMessageFont] defaultLineHeightForFont]];
+ [self _showMessage: self];
+ }
+
diff --git a/gnustep-apps/gnumail/gnumail-1.2.0_pre3.ebuild b/gnustep-apps/gnumail/gnumail-1.2.0_pre3.ebuild
new file mode 100644
index 0000000..aebbd65
--- /dev/null
+++ b/gnustep-apps/gnumail/gnumail-1.2.0_pre3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="prefix"
+
+inherit gnustep-2
+
+MY_PN=${PN/gnum/GNUM}
+
+S=${WORKDIR}/${MY_PN}
+
+DESCRIPTION="A fully featured mail application for GNUstep"
+HOMEPAGE="http://www.collaboration-world.com/gnumail/"
+SRC_URI="http://www.collaboration-world.com/gnumail.data/releases/Stable/${MY_PN}-${PV/_/}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="crypt emoticon xface"
+DEPEND="=gnustep-libs/pantomime-${PV}
+ >=gnustep-base/gnustep-gui-0.11.0
+ gnustep-apps/addresses"
+RDEPEND="crypt? ( app-crypt/gnupg )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-index.patch
+ sed -i -e \
+ 's|$(GNUSTEP_INSTALLATION_DIR)/Library|$(DESTDIR)$(GNUSTEP_SYSTEM_LIBRARY)|' \
+ Bundles/*/GNUmakefile || die "gnustep-make-2 sed failed"
+}
+
+src_compile() {
+ egnustep_env
+ egnustep_make
+
+ cd Bundles/Clock
+ egnustep_make
+ cd ${S}
+
+ if use xface ; then
+ cd Bundles/Face
+ egnustep_make
+ cd ${S}
+ fi
+
+ if use crypt ; then
+ cd Bundles/PGP
+ egnustep_make
+ cd ${S}
+ fi
+
+ if use emoticon ; then
+ cd Bundles/Emoticon
+ egnustep_make
+ cd ${S}
+ fi
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ cd Bundles/Clock
+ egnustep_install || die
+ cd ${S}
+
+ if use xface ; then
+ cd Bundles/Face
+ egnustep_install || die
+ cd ${S}
+ fi
+ if use crypt ; then
+ cd Bundles/PGP
+ egnustep_install || die
+ cd ${S}
+ fi
+ if use emoticon ; then
+ cd Bundles/Emoticon
+ egnustep_install || die
+ cd ${S}
+ fi
+
+ dodoc ${S}/Documentation/*
+
+ # FIX ?
+ rm -rf ${D}$(egnustep_install_domain)/Applications/GNUMail.app/Resources/Resources
+}