aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2012-08-28 01:34:10 +0200
committerMagnus Granberg <zorry@gentoo.org>2012-08-28 01:34:10 +0200
commit62a9d4c24e788232d2d8cb667d89a19c89af9328 (patch)
treec8deb30baa52eb4fb14d120f2fee2c845856539e
parentupdate the testsuite patches rename files (diff)
downloadhardened-gccpatchset-62a9d4c24e788232d2d8cb667d89a19c89af9328.tar.gz
hardened-gccpatchset-62a9d4c24e788232d2d8cb667d89a19c89af9328.tar.bz2
hardened-gccpatchset-62a9d4c24e788232d2d8cb667d89a19c89af9328.zip
add changelog to upstream patches
-rw-r--r--upstream/Changelog.txt105
-rw-r--r--upstream/config.in.patch5
-rw-r--r--upstream/gcc_doc.patch7
-rw-r--r--upstream/testsuite-hardening-format.patch4
-rw-r--r--upstream/testsuite-hardening-printf-types.patch2
5 files changed, 112 insertions, 11 deletions
diff --git a/upstream/Changelog.txt b/upstream/Changelog.txt
new file mode 100644
index 0000000..d8e4764
--- /dev/null
+++ b/upstream/Changelog.txt
@@ -0,0 +1,105 @@
+2012-08-24 Magnus Granberg <zorry@gentoo.org
+
+ * configure.ac Add new configure options espf.
+ * Makefile.in Add -fno-stack-protector when
+ needed for espf.
+ gcc/
+ * configure.ac Add new configure options espf.
+ * Makefile.in Add -fno-PIE when needed for
+ espf.
+ * config.in Add ENABLE_ESPF,
+ ENABLE_ESPF_FORTIFY, ENABLE_ESPF_PIE and
+ ENABLE_ESPF_SSP.
+ * config/linux.h Define ESPF_GCC_PIE_SPEC,
+ ESPF_GCC_SSP_SPEC, ESPF_CPP_UNIQUE_OPTIONS_SPEC,
+ ESPF_DRIVER_SELF_SPECS and ESPF_EXTRA_SPECS.
+ * config/i386/linux.h Define DRIVER_SELF_SPECS.
+ * config/i386/linux64.h Likewise.
+ * config/i386/gnu-user.h Add ESPF_EXTRA_SPECS to
+ SUBTARGET_EXTRA_SPECS when needed.
+ * config/i386/i386.h Likewise.
+ * gcc.c Add espf_cpp_unique_options
+ to cpp_unique_options when needed.
+ * c-family/c-common.c Enable warn_format when espf is
+ enable.
+ * c-family/c-format.c Enable warn_format_security when
+ needed by espf.
+ libgcc/
+ * libgcc/Makefile.in Add -fno-PIE when needed for
+ espf.
+
+2012-08-26 Magnus Granberg <zorry@gentoo.org>
+ Kees Cook <kees@ubuntu.com>
+
+ gcc/doc/
+ * invoke.texi Add notes to -Wformat,
+ -Wformat-security, -O2, -fstack-protector, -fPIE and
+ -pie for espf.
+ * install.texi Add new configure options
+
+2012-08-26 Magnus Granberg <zorry@gentoo.org>
+ Kees Cook <kees@ubuntu.com>
+
+ gcc/testsuite
+ * gcc.dg/charset/builtin2.c Add
+ -Wno-format when effective_target is espf.
+ * gcc.dg/format/format.exp Likewise.
+ * gcc.dg/pr30473.c Likewise.
+ * gcc.dg/pr38902.c Likewise.
+ * gcc.dg/ipa/ipa-sra-1.c Likewise.
+ * gcc.dg/torture/tls/tls-test.c Likewise.
+ * g++.dg/abi/pragma-pack1.C Likewise.
+ * g++.dg/cpp0x/constexpr-tuple.C Likewise.
+ * lib/target-supports.exp Add
+ check_effective_target_espf.
+ * gcc.c-torture/execute/memset-1.x New file
+ * gcc.c-torture/execute/vprintf-chk-1.x Likewise.
+ * gcc.c-torture/execute/vfprintf-chk-1.x Likewise.
+ * gcc.dg/stack-usage-1.c Add -fno-stack-protector
+ when effective_target is espf.
+ * gcc.dg/superblock.c Likewise.
+ * gcc.dg/20021014-1.c Add -fno-PIE when
+ effective_target is espf.
+ * gcc.dg/nest.c Likewise.
+ * gcc.dg/nested-func-4.c Likewise.
+ * gcc.dg/pr32450.c Likewise.
+ * gcc.dg/pr43643.c Likewise.
+ * g++.dg/other/anon5.C Likewise.
+ * g++.old-deja/g++.law/profile1.C Likewise.
+ * gcc.dg/tree-ssa/ssa-store-ccp-3.c Skip the test.
+
+2012-08-27 Magnus Granberg <zorry@gentoo.org>
+ Kees Cook <kees@ubuntu.com>
+
+ gcc/testsuite/
+ PR 39537
+ * g++.dg/ext/align1.C Remove printf
+ * g++.old-deja/g++.law/operators28.C Fix format-string/type.
+ * gcc.dg/torture/matrix-2.c Likewise.
+ * gcc.dg/packed-vla.c Likewise.
+ * g++.dg/opt/alias2.C Likewise.
+ * g++.old-deja/g++.abi/vbase1.C Likewise.
+ * g++.old-deja/g++.brendan/template8.C Likewise.
+ * g++.old-deja/g++.eh/ptr1.C Likewise.
+ * g++.old-deja/g++.jason/access23.C Likewise.
+ * g++.old-deja/g++.law/cvt8.C Likewise.
+ * g++.old-deja/g++.mike/net35.C Likewise.
+ * g++.old-deja/g++.mike/offset1.C Likewise.
+ * g++.old-deja/g++.mike/p12306.C Likewise.
+ * g++.old-deja/g++.mike/p3579.C Likewise.
+ * g++.old-deja/g++.mike/p3708a.C Likewise.
+ * g++.old-deja/g++.mike/p3708b.C Likewise.
+ * g++.old-deja/g++.mike/p3708.C Likewise.
+ * g++.old-deja/g++.mike/p646.C Likewise.
+ * g++.old-deja/g++.mike/p710.C Likewise.
+ * g++.old-deja/g++.mike/p789a.C Likewise.
+ * g++.old-deja/g++.mike/pmf2.C Likewise.
+ * g++.old-deja/g++.mike/temp.C Likewise.
+ * g++.old-deja/g++.other/temporary1.C Likewise.
+ * g++.old-deja/g++.other/virtual8.C Likewise.
+ * g++.old-deja/g++.pt/memtemp23.C Likewise.
+ * g++.old-deja/g++.pt/memtemp24.C Likewise.
+ * g++.old-deja/g++.pt/memtemp25.C Likewise.
+ * g++.old-deja/g++.pt/memtemp26.C Likewise.
+ * g++.old-deja/g++.pt/t39.C Likewise.
+ * g++.old-deja/g++.robertl/eb17.C Likewise.
diff --git a/upstream/config.in.patch b/upstream/config.in.patch
index 7bd846e..7c1f849 100644
--- a/upstream/config.in.patch
+++ b/upstream/config.in.patch
@@ -1,8 +1,3 @@
-2012-04-08 Magnus Granberg <zorry@gentoo.org>
-
- * gcc/config.in Add ENABLE_ESPF, ENABLE_ESPF_FORTIFY,
- ENABLE_ESPF_PIE and ENABLE_ESPF_SSP
-
--- a/gcc/config.in 2011-04-24 00:36:52.000000000 +0200
+++ b/gcc/config.in 2011-06-24 14:17:05.166236726 +0200
@@ -77,6 +77,29 @@
diff --git a/upstream/gcc_doc.patch b/upstream/gcc_doc.patch
index fc39347..3aa53ad 100644
--- a/upstream/gcc_doc.patch
+++ b/upstream/gcc_doc.patch
@@ -79,7 +79,7 @@
Do not use jump tables for switch statements even where it would be
--- a/gcc/doc/install.texi 2012-03-02 10:37:30.000000000 +0100
+++ b/gcc/doc/install.texi 2012-07-23 18:05:14.160784593 +0200
-@@ -1392,6 +1392,17 @@ do a @samp{make -C gcc gnatlib_and_tools
+@@ -1392,6 +1392,18 @@ do a @samp{make -C gcc gnatlib_and_tools
Specify that the run-time libraries for stack smashing protection
should not be built.
@@ -91,8 +91,9 @@
+@option{-fPIE} and @option{-pie} by default. if the support is there. If you
+use @samp{ssp} it will turn on @option{-fstack-protection} by default if the
+support is there. If you use @samp{pie} it will turn on @option{-fPIE} and
-+@option{-pie} by default if the support is there. We only support
-+i?86*-*-linux*, x86_32*-*-linux* and x86_64*-*-linux* as target for now.
++@option{-pie} by default if the support is there. If you use @samp{no} it will
++not turn on any options. We only support i?86*-*-linux*, x86_32*-*-linux*
++and x86_64*-*-linux* as target for now.
+
@item --disable-libquadmath
Specify that the GCC quad-precision math library should not be built.
diff --git a/upstream/testsuite-hardening-format.patch b/upstream/testsuite-hardening-format.patch
index 3b9583d..0d14c10 100644
--- a/upstream/testsuite-hardening-format.patch
+++ b/upstream/testsuite-hardening-format.patch
@@ -59,8 +59,8 @@
struct bovid
{
--- a/gcc/testsuite/gcc.dg/torture/tls/tls-test.c 2011-06-22 19:27:07.000000000 +0200
-+++ b/gcc/testsuite/gcc.dg/torture/tls/tls-test.c 2012-07-31 14:40:00.411552986 +0200
-@@ -1,7 +1,8 @@
++++ b/gcc/testsuite/gcc.dg/torture/tls/tls-test.c 2012-08-21 23:51:33.205398132 +0200
+@@ -2,6 +2,7 @@
/* { dg-require-effective-target tls } */
/* { dg-require-effective-target pthread } */
/* { dg-options "-pthread" } */
diff --git a/upstream/testsuite-hardening-printf-types.patch b/upstream/testsuite-hardening-printf-types.patch
index 4fa6b5d..8ca807e 100644
--- a/upstream/testsuite-hardening-printf-types.patch
+++ b/upstream/testsuite-hardening-printf-types.patch
@@ -519,7 +519,7 @@
int c[16];
};
---- agcc/testsuite/g++.old-deja/g++.pt/memtemp24.C
+--- a/gcc/testsuite/g++.old-deja/g++.pt/memtemp24.C
+++ b/gcc/testsuite/g++.old-deja/g++.pt/memtemp24.C
@@ -13,7 +13,7 @@