aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sugar <dsugar@tresys.com>2017-08-30 16:22:40 +0000
committerLuis Ressel <aranea@aixah.de>2017-09-09 00:39:27 +0200
commit0955e1fa30f964b1fa79d90a1a3d12aa6f7608f2 (patch)
tree68543fc1e60b728105918b57178f292e4be75929 /support
parentModule version bump for fixes from Nicolas Iooss. (diff)
downloadhardened-refpolicy-0955e1fa30f964b1fa79d90a1a3d12aa6f7608f2.tar.gz
hardened-refpolicy-0955e1fa30f964b1fa79d90a1a3d12aa6f7608f2.tar.bz2
hardened-refpolicy-0955e1fa30f964b1fa79d90a1a3d12aa6f7608f2.zip
Strip spaces from NAME
Strip trailing space(s) from 'NAME' being read from /etc/selinux/config as a trailing space in that name will cause a weird error during the make process for modules built out of tree. This is seen on current RedHat machines which have space in the 'SELINUXTYPE' variable.
Diffstat (limited to 'support')
-rw-r--r--support/Makefile.devel2
1 files changed, 1 insertions, 1 deletions
diff --git a/support/Makefile.devel b/support/Makefile.devel
index a0e8c2a2..d531dd88 100644
--- a/support/Makefile.devel
+++ b/support/Makefile.devel
@@ -8,7 +8,7 @@ EINFO ?= echo
PYTHON ?= python
CUT ?= cut
-NAME ?= $(shell $(AWK) -F= '/^SELINUXTYPE/{ print $$2 }' /etc/selinux/config)
+NAME ?= $(strip $(shell $(AWK) -F= '/^SELINUXTYPE/{ print $$2 }' /etc/selinux/config))
SHAREDIR ?= /usr/share/selinux
HEADERDIR ?= $(SHAREDIR)/$(NAME)/include