aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile15
-rwxr-xr-xdist.sh7
-rwxr-xr-xfetch.sh4
3 files changed, 15 insertions, 11 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a27933b
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,15 @@
+# can be replaced with `wget -q -O -` if you want
+HTTPCAT = curl
+
+fetch:
+ $(HTTPCAT) http://pci-ids.ucw.cz/v2.2/pci.ids.bz2 | bzcat > pci.ids
+ $(HTTPCAT) http://www.linux-usb.org/usb.ids.bz2 | bzcat > usb.ids
+
+PV ?= $(shell date +%Y%m%d)
+P = hwids-$(PV)
+
+dist: $(P).tar.xz
+
+$(P).tar.xz:
+ git tag $(P)
+ git archive --prefix=$(P)/ $(P) | xz -9e > $(P).tar.xz
diff --git a/dist.sh b/dist.sh
deleted file mode 100755
index c39289b..0000000
--- a/dist.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-PV=${1:-$(date +%Y%m%d)}
-P=hwids-${PV}
-
-git tag ${P}
-git archive --prefix=${P}/ ${P} | xz -9e > ${P}.tar.xz
diff --git a/fetch.sh b/fetch.sh
deleted file mode 100755
index 6846191..0000000
--- a/fetch.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-curl http://pci-ids.ucw.cz/v2.2/pci.ids.bz2 | bzcat > pci.ids
-curl http://www.linux-usb.org/usb.ids.bz2 | bzcat > usb.ids