aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-09-24 00:06:16 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-09-24 00:06:16 +0000
commitbdcc6e9d37fb6e20b5ee5cf459b8b1da839cb29d (patch)
treea70ec376e578d838000583e6555ce606157527c2
parenti no longer think this was a good idea (diff)
downloadjava-config-bdcc6e9d37fb6e20b5ee5cf459b8b1da839cb29d.tar.gz
java-config-bdcc6e9d37fb6e20b5ee5cf459b8b1da839cb29d.tar.bz2
java-config-bdcc6e9d37fb6e20b5ee5cf459b8b1da839cb29d.zip
2.0.5
svn path=/java-config-ng/branches/axxo/; revision=879
-rw-r--r--MANIFEST.in1
-rw-r--r--config/compilers.conf5
-rw-r--r--setup.py5
3 files changed, 9 insertions, 2 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index b05e32e..a21e10a 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -2,4 +2,5 @@ recursive-include man/ *
recursive-include config/ *
include src/env
include src/*.bash
+include src/eselect/*.eselect
diff --git a/config/compilers.conf b/config/compilers.conf
new file mode 100644
index 0000000..60af373
--- /dev/null
+++ b/config/compilers.conf
@@ -0,0 +1,5 @@
+# If the ebuild supports it
+# it will check the COMPILERS var front to back and
+use the fist compiler that is installed
+
+COMPILERS="ecj jikes javac"
diff --git a/setup.py b/setup.py
index a5fed17..cf2acaa 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ import os
setup (
name = 'java-config',
- version = '2.0.3',
+ version = '2.0.5',
description = 'java enviroment configuration tool',
long_description = \
"""
@@ -23,7 +23,8 @@ setup (
('man/man1', ['man/java-config.1']),
('share/java-config/config', ['config/jdk-defaults.conf']),
('share/java-config/launcher', ['src/launcher.bash']),
- ('/etc/java-config/', ['config/jdk.conf','config/symlink-tools']),
+ ('share/eselect/modules', ['src/eselect/java.eselect']),
+ ('/etc/java-config/', ['config/jdk.conf','config/symlink-tools','config/compilers.conf']),
('/etc/java-config/vms', ['src/env']),
('/etc/env.d/',['config/20java-config']),
]