aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--AUTHORS8
-rwxr-xr-xdepend-java-query9
-rwxr-xr-xjava-config14
-rw-r--r--setup.py3
-rw-r--r--src/EnvFileParser.py12
-rw-r--r--src/EnvironmentManager.py14
-rw-r--r--src/Errors.py14
-rw-r--r--src/OutputFormatter.py12
-rw-r--r--src/Package.py12
-rw-r--r--src/PreferenceManager.py12
-rw-r--r--src/PrefsFileParser.py2
-rw-r--r--src/VM.py12
-rw-r--r--src/__init__.py2
-rw-r--r--src/versionator.py8
14 files changed, 27 insertions, 107 deletions
diff --git a/AUTHORS b/AUTHORS
new file mode 100644
index 0000000..0b73f2d
--- /dev/null
+++ b/AUTHORS
@@ -0,0 +1,8 @@
+Author: Saleem Abdulrasool <compnerd@gentoo.org>
+Author: Thomas Matthijs <axxo@gentoo.org>
+Maintainer: Gentoo Java Herd <java@gentoo.org>
+Java Subsystem Configuration Utility for Gentoo Linux
+
+Based on the collective works of the following:
+Karl Trygve Kalleberg <karltk@gentoo.org>
+Jason A Mobarak <aether@gentoo.org>
diff --git a/depend-java-query b/depend-java-query
index bf426c6..2a5e559 100755
--- a/depend-java-query
+++ b/depend-java-query
@@ -1,16 +1,11 @@
#!/usr/bin/python -E
# -*- coding: UTF-8 -*-
-# Copyright 2004 Gentoo Foundation
+# Copyright 2004-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-# Maintainer: Gentoo Java Herd <java@gentoo.org>
-# Java Subsystem Configuration Utility for Gentoo Linux
-
-__version__ = '$Revision: 2.0$'[11:-1]
-
+from java_config import __version__
from java_config.OutputFormatter import OutputFormatter
from java_config.EnvironmentManager import EnvironmentManager
from java_config.Errors import *
diff --git a/java-config b/java-config
index 98ada8c..53a1164 100755
--- a/java-config
+++ b/java-config
@@ -1,16 +1,11 @@
#!/usr/bin/python -E
# -*- coding: UTF-8 -*-
-# Copyright 2004 Gentoo Foundation
+# Copyright 2004-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-# Maintainer: Gentoo Java Herd <java@gentoo.org>
-# Java Subsystem Configuration Utility for Gentoo Linux
-
-__version__ = '$Revision: 2.0$'[11:-1]
-
+from java_config import version
from java_config.OutputFormatter import OutputFormatter
from java_config.EnvironmentManager import EnvironmentManager
from java_config.Errors import *
@@ -24,9 +19,8 @@ from string import join
from optparse import OptionParser, make_option
-
def version(option, opt, value, parser):
- printer._print("%H%BJava Configuration Utility %GVersion " + str(__version__))
+ printer._print("%H%BJava Configuration Utility %GVersion " + str(version))
raise SystemExit()
def nocolor(option, opt, value, parser):
@@ -245,7 +239,7 @@ if __name__ == '__main__':
manager = EnvironmentManager()
usage = "java-config [options]\n\n"
- usage += "Java Configuration Utility Version " + str(__version__) + "\n"
+ usage += "Java Configuration Utility Version " + str(version) + "\n"
usage += "Copyright 2004-2005 Gentoo Foundation\n"
usage += "Distributed under the terms of the GNU General Public License v2\n"
usage += "Please contact the Gentoo Java Herd <java@gentoo.org> with problems."
diff --git a/setup.py b/setup.py
index 831975d..7b5aa80 100644
--- a/setup.py
+++ b/setup.py
@@ -2,10 +2,11 @@
from distutils.core import setup
import os
+import java_config
setup (
name = 'java-config',
- version = '2.0.0',
+ version = java_config.version,
description = 'java enviroment configuration tool',
long_description = \
"""
diff --git a/src/EnvFileParser.py b/src/EnvFileParser.py
index 0ebac77..8b93fdf 100644
--- a/src/EnvFileParser.py
+++ b/src/EnvFileParser.py
@@ -1,19 +1,9 @@
# -*- coding: UTF-8 -*-
-# Copyright 2004 Gentoo Foundation
+# Copyright 2004-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-# Maintainer: Gentoo Java Herd <java@gentoo.org>
-# Java Subsystem Configuration Utility for Gentoo Linux
-
-# ChangeLog
-# Saleem A. <compnerd@gentoo.org>
-# December 30, 2004 - Initial Rewrite
-# - Based on the collective works of the following:
-# {karltk,axxo,aether}@gentoo.org
-
from Errors import *
import os
diff --git a/src/EnvironmentManager.py b/src/EnvironmentManager.py
index 32c0d6c..9fde4a8 100644
--- a/src/EnvironmentManager.py
+++ b/src/EnvironmentManager.py
@@ -1,21 +1,9 @@
# -*- coding: UTF-8 -*-
-# Copyright 2004 Gentoo Foundation
+# Copyright 2004-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-# Maintainer: Gentoo Java Herd <java@gentoo.org>
-# Java Subsystem Configuration Utility for Gentoo Linux
-
-# ChangeLog
-# Saleem A. <compnerd@gentoo.org>
-# December 30, 2004 - Initial Rewrite
-# - Based on the collective works of the following:
-# {karltk,axxo,aether}@gentoo.org
-
-__version__ = '$Revision: 2.0$'[11:-1]
-
import VM,Package
import os,glob,re
diff --git a/src/Errors.py b/src/Errors.py
index acf7523..d92b291 100644
--- a/src/Errors.py
+++ b/src/Errors.py
@@ -1,21 +1,9 @@
# -*- coding: UTF-8 -*-
-# Copyright 2004 Gentoo Foundation
+# Copyright 2004-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-# Maintainer: Gentoo Java Herd <java@gentoo.org>
-# Java Subsystem Configuration Utility for Gentoo Linux
-
-# ChangeLog
-# Saleem A. <compnerd@gentoo.org>
-# December 30, 2004 - Initial Rewrite
-# - Based on the collective works of the following:
-# {karltk,axxo,aether}@gentoo.org
-# April 20, 2005 - Modified Error classes
-# - Moved to Errors.py
-
class EnvironmentUndefinedError(Exception):
"""
Environment Variable is undefined!
diff --git a/src/OutputFormatter.py b/src/OutputFormatter.py
index 65d5fb8..d083095 100644
--- a/src/OutputFormatter.py
+++ b/src/OutputFormatter.py
@@ -1,19 +1,9 @@
# -*- coding: UTF-8 -*-
-# Copyright 2004 Gentoo Foundation
+# Copyright 2004-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-# Maintainer: Gentoo Java Herd <java@gentoo.org>
-# Java Subsystem Configuration Utility for Gentoo Linux
-
-# ChangeLog
-# Saleem A. <compnerd@gentoo.org>
-# December 30, 2004 - Initial Rewrite
-# - Based on the collective works of the following:
-# {karltk,axxo,aether}@gentoo.org
-
import os,sys
class OutputFormatter:
diff --git a/src/Package.py b/src/Package.py
index 2978ee4..770f0df 100644
--- a/src/Package.py
+++ b/src/Package.py
@@ -1,19 +1,9 @@
# -*- coding: UTF-8 -*-
-# Copyright 2004 Gentoo Foundation
+# Copyright 2004-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-# Maintainer: Gentoo Java Herd <java@gentoo.org>
-# Java Subsystem Configuration Utility for Gentoo Linux
-
-# ChangeLog
-# Saleem A. <compnerd@gentoo.org>
-# December 30, 2004 - Initial Rewrite
-# - Based on the collective works of the following:
-# {karltk,axxo,aether}@gentoo.org
-
import EnvFileParser
class Package:
diff --git a/src/PreferenceManager.py b/src/PreferenceManager.py
index f61e9c4..d60cc50 100644
--- a/src/PreferenceManager.py
+++ b/src/PreferenceManager.py
@@ -1,17 +1,9 @@
# -*- coding: UTF-8 -*-
-# Copyright 2004 Gentoo Foundation
+# Copyright 2004-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-# Maintainer: Gentoo Java Herd <java@gentoo.org>
-# Java Subsystem Configuration Utility for Gentoo Linux
-
-# ChangeLog
-# Saleem A. <compnerd@gentoo.org>
-# April 19, 2005 - Initial Write
-
import VM,Errors
from java_config.versionator import *
from java_config.PrefsFileParser import *
@@ -55,3 +47,5 @@ class PreferenceManager:
#print "1.3: " + str(man.get_vm("1.3"))
#print "1.4: " + str(man.get_vm("1.4"))
#print "1.5: " + str(man.get_vm("1.5"))
+
+# vim:set expandtab tabstop=3 shiftwidth=3 softtabstop=3:
diff --git a/src/PrefsFileParser.py b/src/PrefsFileParser.py
index b6e4697..e173317 100644
--- a/src/PrefsFileParser.py
+++ b/src/PrefsFileParser.py
@@ -4,8 +4,6 @@
# Distributed under the terms of he GNU General Public License v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-
from Errors import *
import os
diff --git a/src/VM.py b/src/VM.py
index 7d80b78..c3ad99b 100644
--- a/src/VM.py
+++ b/src/VM.py
@@ -1,20 +1,10 @@
#!/usr/bin/env python
# -*- coding: UTF-8 -*-
-# Copyright 2004 Gentoo Foundation
+# Copyright 2004-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-# Maintainer: Gentoo Java Herd <java@gentoo.org>
-# Java Subsystem Configuration Utility for Gentoo Linux
-
-# ChangeLog
-# Saleem A. <compnerd@gentoo.org>
-# December 30, 2004 - Initial Rewrite
-# - Based on the collective works of the following:
-# {karltk,axxo,aether}@gentoo.org
-
import EnvFileParser
import os
diff --git a/src/__init__.py b/src/__init__.py
index bf16755..055035c 100644
--- a/src/__init__.py
+++ b/src/__init__.py
@@ -1,3 +1,5 @@
'''
java-config support files
'''
+
+__version__ = "2.0.0"
diff --git a/src/versionator.py b/src/versionator.py
index 0aeae7a..39e402b 100644
--- a/src/versionator.py
+++ b/src/versionator.py
@@ -4,14 +4,6 @@
# Distributed under the terms of the GNU General Public license v2
# $Header: $
-# Author: Saleem Abdulrasool <compnerd@gentoo.org>
-# Maintainer: Gentoo Java Herd <java@gentoo.org>
-# Python based utilities
-
-# ChangeLog
-# Saleem A. <compnerd@gentoo.org>
-# March 31, 2005 - Initial Write
-
import re
from string import upper
from java_config.PreferenceManager import *