aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2007-04-21 09:54:51 +0000
committerSerkan Kaba <serkan@gentoo.org>2007-04-21 09:54:51 +0000
commitad468ae86c93f0a3494f066e0a24bb68b71967a1 (patch)
treedecec93787a23be1b0461696e21eb1978529be12 /dev-java/smoothmetal
parentNew version of swingx and lots of cleanup (diff)
downloadjava-ad468ae86c93f0a3494f066e0a24bb68b71967a1.tar.gz
java-ad468ae86c93f0a3494f066e0a24bb68b71967a1.tar.bz2
java-ad468ae86c93f0a3494f066e0a24bb68b71967a1.zip
smoothmetal L&F added
svn path=/java-overlay/; revision=4311
Diffstat (limited to 'dev-java/smoothmetal')
-rw-r--r--dev-java/smoothmetal/ChangeLog7
-rw-r--r--dev-java/smoothmetal/Manifest4
-rw-r--r--dev-java/smoothmetal/files/digest-smoothmetal-1.13
-rw-r--r--dev-java/smoothmetal/metadata.xml5
-rw-r--r--dev-java/smoothmetal/smoothmetal-1.1.ebuild34
5 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/smoothmetal/ChangeLog b/dev-java/smoothmetal/ChangeLog
new file mode 100644
index 00000000..1e8be6a8
--- /dev/null
+++ b/dev-java/smoothmetal/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-java/smoothmetal
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 21 Apr 2007; <serkan_kaba@yahoo.com> ChangeLog:
+ Initial commit.
+
diff --git a/dev-java/smoothmetal/Manifest b/dev-java/smoothmetal/Manifest
new file mode 100644
index 00000000..738d9e7c
--- /dev/null
+++ b/dev-java/smoothmetal/Manifest
@@ -0,0 +1,4 @@
+DIST smoothmetal-1.1.zip 771816 RMD160 651e2668f62461c98ea1b7641272e576f97397bc SHA1 67cd80e8b032e66f6bf6910b2c8610c2ce2eebdf SHA256 287484dba6cf87b67272ff7c2167b66455739b909be52cc589d7f1a8e6f55cb6
+EBUILD smoothmetal-1.1.ebuild 729 RMD160 6444a3c5b095c8f5fa9b046ad37a935f1f93ef57 SHA1 c958b975f6456a44db38ca3de18de8135b043c60 SHA256 a47ce9739bf1f52aa87fab94ff2fec63af40a38f5ede01dc2e16de7e0b212cb5
+MISC ChangeLog 190 RMD160 5c51c91670cff0a1c56d167562cd126a85c6e426 SHA1 743441f238d363c4b7a860b4278369bc671a703a SHA256 15f114e9887bb91c9a0da5280b3bf04d659300be2a08721e7a44a384bb89bf1b
+MISC metadata.xml 157 RMD160 ab0b3741457dee7531f59c4da0f0e9e8399af084 SHA1 c37a6b9922aef61b5b3387655bccb6e3b16e0e26 SHA256 295d02c5805b0257938eb80314b371daac94b8d6ea85629a902de7a824adc0c9
diff --git a/dev-java/smoothmetal/files/digest-smoothmetal-1.1 b/dev-java/smoothmetal/files/digest-smoothmetal-1.1
new file mode 100644
index 00000000..b3257ecf
--- /dev/null
+++ b/dev-java/smoothmetal/files/digest-smoothmetal-1.1
@@ -0,0 +1,3 @@
+MD5 3b5110c2c67712d6341957fc9afcce71 smoothmetal-1.1.zip 771816
+RMD160 651e2668f62461c98ea1b7641272e576f97397bc smoothmetal-1.1.zip 771816
+SHA256 287484dba6cf87b67272ff7c2167b66455739b909be52cc589d7f1a8e6f55cb6 smoothmetal-1.1.zip 771816
diff --git a/dev-java/smoothmetal/metadata.xml b/dev-java/smoothmetal/metadata.xml
new file mode 100644
index 00000000..838c00a4
--- /dev/null
+++ b/dev-java/smoothmetal/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/smoothmetal/smoothmetal-1.1.ebuild b/dev-java/smoothmetal/smoothmetal-1.1.ebuild
new file mode 100644
index 00000000..975328e0
--- /dev/null
+++ b/dev-java/smoothmetal/smoothmetal-1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A wrapper for some of Sun's Java Look and Feels to enable anti-aliasing."
+HOMEPAGE="http://smoothmetal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc source"
+EANT_BUILD_TARGET="dist"
+S=${WORKDIR}
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ source? (app-arch/zip)"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm -rf dist
+ rm -rf docs
+}
+
+src_install() {
+ java-pkg_dojar dist/smoothmetal.jar
+ use doc && java-pkg_dohtml -r docs/api
+ use source && java-pkg_dosrc src/*
+}