aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-08 23:58:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-08 23:59:38 +0200
commit39934118276242f82b7d94da11228235b63cbd63 (patch)
treef0e5ed25f6ee7eee43b6ea6d54f0365797d6daad
parentdev-util/kdevelop-clang-tidy: RDEPEND on sys-devel/clang (diff)
downloadkde-39934118276242f82b7d94da11228235b63cbd63.tar.gz
kde-39934118276242f82b7d94da11228235b63cbd63.tar.bz2
kde-39934118276242f82b7d94da11228235b63cbd63.zip
dev-util/kdevelop-clang-tidy: 0.1.0 version bump
Package-Manager: Portage-2.3.45, Repoman-2.3.10
-rw-r--r--dev-util/kdevelop-clang-tidy/Manifest1
-rw-r--r--dev-util/kdevelop-clang-tidy/kdevelop-clang-tidy-0.1.0.ebuild45
-rw-r--r--dev-util/kdevelop-clang-tidy/kdevelop-clang-tidy-9999.ebuild2
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-util/kdevelop-clang-tidy/Manifest b/dev-util/kdevelop-clang-tidy/Manifest
new file mode 100644
index 0000000000..7460d83946
--- /dev/null
+++ b/dev-util/kdevelop-clang-tidy/Manifest
@@ -0,0 +1 @@
+DIST kdev-clang-tidy-0.1.0.tar.xz 36180 BLAKE2B efb1a4a5af07c196e164600ba755cc4bfeb34e9cd0077ba6a6caeae2c7f626f4040b0813cb1c7f1c4b0170c20c9fa006e002dea7d8da3b423560724f52b36640 SHA512 68d9781b9b8835aa9b56ac95e7565d009855e776d82cf8662aa75eb12351c8f929104bd33c66648b4f455495b50a9bebf9fb7df4349dfaf8ebc4452da5fdab74
diff --git a/dev-util/kdevelop-clang-tidy/kdevelop-clang-tidy-0.1.0.ebuild b/dev-util/kdevelop-clang-tidy/kdevelop-clang-tidy-0.1.0.ebuild
new file mode 100644
index 0000000000..bd6054b456
--- /dev/null
+++ b/dev-util/kdevelop-clang-tidy/kdevelop-clang-tidy-0.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDEBASE="kdevelop"
+KDE_TEST="forceoptional"
+KMNAME="kdev-clang-tidy"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN/kdevelop/kdev}/${PV}/src/${P/kdevelop/kdev}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="KDevelop plugin for clang-tidy static analysis support"
+LICENSE="GPL-2+"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ >=dev-util/kdevelop-5.2.3:5
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-devel/clang:*
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # drop when upstream depends on >=kdevelop-5.2.2
+ punt_bogus_dep KF5 ItemModels
+}
diff --git a/dev-util/kdevelop-clang-tidy/kdevelop-clang-tidy-9999.ebuild b/dev-util/kdevelop-clang-tidy/kdevelop-clang-tidy-9999.ebuild
index e5ec7ac267..bd6054b456 100644
--- a/dev-util/kdevelop-clang-tidy/kdevelop-clang-tidy-9999.ebuild
+++ b/dev-util/kdevelop-clang-tidy/kdevelop-clang-tidy-9999.ebuild
@@ -10,7 +10,7 @@ VIRTUALX_REQUIRED="test"
inherit kde5
if [[ ${KDE_BUILD_TYPE} = release ]]; then
- SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ SRC_URI="mirror://kde/stable/${PN/kdevelop/kdev}/${PV}/src/${P/kdevelop/kdev}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi