aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-18 11:02:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-18 11:02:59 +0200
commita5ccaf3a255ec63fee6e7b621f022ecc16a03fb6 (patch)
treed1ad9ca2a59dbecdec7c7bbbae60293d6ab087ea /app-text
parentapp-text/kbibtex: Fix SRC_URI (diff)
downloadkde-a5ccaf3a255ec63fee6e7b621f022ecc16a03fb6.tar.gz
kde-a5ccaf3a255ec63fee6e7b621f022ecc16a03fb6.tar.bz2
kde-a5ccaf3a255ec63fee6e7b621f022ecc16a03fb6.zip
app-text/kbibtex: Fix HOMEPAGE, add pkg_postinst info
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kbibtex/kbibtex-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-text/kbibtex/kbibtex-9999.ebuild b/app-text/kbibtex/kbibtex-9999.ebuild
index 0cefb40342..2fda117464 100644
--- a/app-text/kbibtex/kbibtex-9999.ebuild
+++ b/app-text/kbibtex/kbibtex-9999.ebuild
@@ -8,7 +8,7 @@ KDE_TEST="true"
inherit kde5
DESCRIPTION="BibTeX editor to edit bibliographies used with LaTeX"
-HOMEPAGE="http://home.gna.org/kbibtex/"
+HOMEPAGE="https://userbase.kde.org/KBibTeX"
if [[ ${KDE_BUILD_TYPE} != live ]]; then
SRC_URI="mirror://kde/stable/KBibTeX/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
@@ -77,3 +77,11 @@ src_configure() {
kde5_src_configure
}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/okular:${SLOT}" ; then
+ elog "For PDF or PostScript document preview support, please install kde-apps/okular:${SLOT}"
+ fi
+}