aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-05-10 13:52:57 +0200
committerJohannes Huber <johu@gentoo.org>2014-05-10 13:52:57 +0200
commitb5469b66b04f2d542faaf0f10f0713ee797e2406 (patch)
treece74875842f815ca29b2c0d2bda52d1c3ec8f58e /app-text
parent[profiles/package.mask] Improve kde-4.13.1 (diff)
downloadkde-b5469b66b04f2d542faaf0f10f0713ee797e2406.tar.gz
kde-b5469b66b04f2d542faaf0f10f0713ee797e2406.tar.bz2
kde-b5469b66b04f2d542faaf0f10f0713ee797e2406.zip
[app-text/poppler] Import from qt overlay for maintenance
Package-Manager: portage-2.2.10
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/metadata.xml17
-rw-r--r--app-text/poppler/poppler-9999.ebuild98
2 files changed, 115 insertions, 0 deletions
diff --git a/app-text/poppler/metadata.xml b/app-text/poppler/metadata.xml
new file mode 100644
index 0000000000..75a57170fa
--- /dev/null
+++ b/app-text/poppler/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<herd>printing</herd>
+<maintainer>
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+</maintainer>
+<use>
+ <flag name='abiword'>Enable support for <pkg>app-office/abiword</pkg> output. Requires <pkg>dev-libs/libxml2</pkg>.</flag>
+ <flag name='exceptions'>Enable exceptions throwing.</flag>
+ <flag name='introspection'>Enable GObject introspection.</flag>
+ <flag name='utils'>Install command-line PDF converters and various utilities.</flag>
+ <flag name='xpdf-headers'></flag>
+</use>
+</pkgmetadata>
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
new file mode 100644
index 0000000000..ba2094e90a
--- /dev/null
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.22.5.ebuild,v 1.2 2013/07/12 20:34:24 dilfridge Exp $
+
+EAPI=5
+
+inherit cmake-utils toolchain-funcs git-2
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="http://poppler.freedesktop.org/"
+EGIT_REPO_URI="git://git.freedesktop.org/git/poppler/poppler"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+SLOT="0/43"
+IUSE="cairo cjk curl cxx debug doc +introspection +jpeg jpeg2k +lcms png qt4 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-1.32.1 )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ png? ( media-libs/libpng:0= )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-libs/poppler
+ !dev-libs/poppler-glib
+ !dev-libs/poppler-qt3
+ !dev-libs/poppler-qt4
+ !app-text/poppler-utils
+ cjk? ( >=app-text/poppler-data-0.4.4 )
+"
+
+DOCS=(AUTHORS NEWS README README-XPDF TODO)
+
+src_configure() {
+ # this is needed for multilib, see bug 459394
+ local ft_libdir ft_includedir
+ ft_libdir="$($(tc-getPKG_CONFIG) freetype2 --variable=libdir)"
+ ft_includedir="$($(tc-getPKG_CONFIG) freetype2 --variable=includedir)"
+ export FREETYPE_DIR="${ft_libdir}:${ft_includedir%/include}"
+ einfo "Detected FreeType at ${FREETYPE_DIR}"
+
+ mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ -DENABLE_XPDF_HEADERS=ON
+ $(cmake-utils_use_enable curl LIBCURL)
+ $(cmake-utils_use_enable cxx CPP)
+ $(cmake-utils_use_enable jpeg2k LIBOPENJPEG)
+ $(cmake-utils_use_enable utils)
+ $(cmake-utils_use_with cairo)
+ $(cmake-utils_use_with introspection GObjectIntrospection)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with qt4)
+ $(cmake-utils_use_with tiff)
+ )
+ if use lcms; then
+ mycmakeargs+=(-DENABLE_CMS=lcms2)
+ else
+ mycmakeargs+=(-DENABLE_CMS=)
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use cairo && use doc; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}