aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-02 17:36:32 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-02 17:39:36 +0100
commitfa20441bd6e38dec2ca35fcca36ea30864802dfa (patch)
tree04fda22bfd90fabffc47a60b1c691f5177816b4a /dev-libs/qcoro/qcoro-9999.ebuild
parentkde-plasma/libkscreen: Raise p-w-p minimum to 9999 (diff)
downloadkde-fa20441bd6e38dec2ca35fcca36ea30864802dfa.tar.gz
kde-fa20441bd6e38dec2ca35fcca36ea30864802dfa.tar.bz2
kde-fa20441bd6e38dec2ca35fcca36ea30864802dfa.zip
dev-libs/qcoro: new package, add 9999
Bug: https://bugs.gentoo.org/918994 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/qcoro/qcoro-9999.ebuild')
-rw-r--r--dev-libs/qcoro/qcoro-9999.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/qcoro/qcoro-9999.ebuild b/dev-libs/qcoro/qcoro-9999.ebuild
new file mode 100644
index 0000000000..787c61337a
--- /dev/null
+++ b/dev-libs/qcoro/qcoro-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/danvratil/${PN}"
+else
+ SRC_URI="https://github.com/danvratil/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="C++ Coroutine Library for Qt5"
+HOMEPAGE="https://qcoro.dvratil.cz/ https://github.com/danvratil/qcoro"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="dbus examples +network qml test testlib websockets"
+
+REQUIRED_USE="examples? ( network ) test? ( testlib )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtbase:6[dbus?,network?]
+ qml? ( dev-qt/qtdeclarative:6= )
+ testlib? ( dev-qt/qtbase:6[test] )
+ websockets? ( dev-qt/qtwebsockets:6 )
+"
+DEPEND="${RDEPEND}
+ examples? ( dev-qt/qtbase:6[concurrent,network,widgets] )
+ test? ( dev-qt/qtbase:6[concurrent,test] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_VERSION=6
+ -DQCORO_BUILD_EXAMPLES=$(usex examples)
+ -DQCORO_WITH_QTDBUS=$(usex dbus)
+ -DQCORO_WITH_QTNETWORK=$(usex network)
+ -DQCORO_WITH_QML=$(usex qml)
+ -DQCORO_WITH_QTQUICK=$(usex qml)
+ -DQCORO_WITH_QTTEST=$(usex testlib)
+ -DBUILD_TESTING=$(usex test)
+ -DQCORO_WITH_QTWEBSOCKETS=$(usex websockets)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ if use examples; then
+ docinto examples
+ dodoc -r examples/*
+ fi
+ cmake_src_install
+}