aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/choqok/choqok-9999.ebuild')
-rw-r--r--net-im/choqok/choqok-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/net-im/choqok/choqok-9999.ebuild b/net-im/choqok/choqok-9999.ebuild
index b997b56198..412cb7b238 100644
--- a/net-im/choqok/choqok-9999.ebuild
+++ b/net-im/choqok/choqok-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_HANDBOOK="forceoptional"
-KFMIN=5.106.0
-QTMIN=5.15.9
+KFMIN=5.115.0
+QTMIN=5.15.12
inherit ecm kde.org
DESCRIPTION="Free/Open Source micro-blogging client by KDE"
@@ -18,7 +18,7 @@ fi
LICENSE="GPL-2+"
SLOT="5"
-IUSE="attica share telepathy"
+IUSE="attica share"
DEPEND="
>=app-crypt/qca-2.3.0:2[qt5(+)]
@@ -47,7 +47,6 @@ DEPEND="
>=kde-frameworks/sonnet-${KFMIN}:5
attica? ( >=kde-frameworks/attica-${KFMIN}:5 )
share? ( >=kde-frameworks/purpose-${KFMIN}:5 )
- telepathy? ( >=net-libs/telepathy-qt-0.9.8 )
"
RDEPEND="${DEPEND}"
@@ -55,10 +54,10 @@ DOCS=( AUTHORS README changelog )
src_configure() {
local mycmakeargs=(
- $(cmake_use_find_package attica KF5Attica)
-DCMAKE_DISABLE_FIND_PACKAGE_KF5WebKit=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_TelepathyQt5=ON
+ $(cmake_use_find_package attica KF5Attica)
$(cmake_use_find_package share KF5Purpose)
- $(cmake_use_find_package telepathy TelepathyQt5)
)
ecm_src_configure