aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index d57316c..8a815eb 100755
--- a/setup.py
+++ b/setup.py
@@ -26,6 +26,10 @@ SELECTABLE = {
use_defaults = ' '.join(list(SELECTABLE))
+SYNC_PLUGINS = {
+ 'sync-plugin-portage': 'layman.laymanator',
+}
+
# get the USE from the environment, default to all selectable modules
# split them so we don't get substring matches
USE = os.environ.get("USE", use_defaults).split()
@@ -40,6 +44,9 @@ for mod in sorted(SELECTABLE):
if mod in USE:
modules.append('layman.overlays.modules.%s' % SELECTABLE[mod])
+for plugin in sorted(SYNC_PLUGINS):
+ if plugin in USE:
+ modules.append(SYNC_PLUGIN)
setup(name = 'layman',
version = VERSION,