aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2011-05-05 14:53:14 +0800
committerMu Qiao <qiaomuf@gentoo.org>2011-05-08 20:55:51 +0800
commit7f6c20a9ef87ec5377f0d7758f7cdce20da11831 (patch)
tree852ca2a7fc9378608d25ed7a6ebe1c0b1fdd9630 /configure.ac
parentCore: return 0 if boost::lexical_cast<int> fails (diff)
downloadlibbash-7f6c20a9ef87ec5377f0d7758f7cdce20da11831.tar.gz
libbash-7f6c20a9ef87ec5377f0d7758f7cdce20da11831.tar.bz2
libbash-7f6c20a9ef87ec5377f0d7758f7cdce20da11831.zip
Utils: reimplement instruo with libbash
With the help of instruo from Paludis, we can setup variables to bash env needed for metadata generation. In the meanwhile, we can compare the original instruo utility with our implementation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b710a97..3563013 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,8 @@ AC_ARG_ENABLE([developer],
[AS_HELP_STRING([--enable-developer],[enables various QA checks])])
AM_CONDITIONAL([DEVELOPER_MODE],[test "x$enable_developer" = xyes])
+PKG_CHECK_MODULES([PALUDIS], [paludis])
+
AS_IF([test "x$enable_developer" = xyes],[boost_version="1.46.1"],[boost_version="1.43.0"])
AX_BOOST_BASE([$boost_version],[:],
[AC_MSG_ERROR([Needed boost not found])])