aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2011-06-14 16:21:34 +0800
committerPetteri Räty <petsku@petteriraty.eu>2011-06-19 22:13:39 +0300
commitae0cabbc1a5a36ac35b05710fb51f1098cf301e3 (patch)
treea0d28c3334a759e4ccbd42527a0a2c0df77e7430 /scripts
parentParser: support -a and -o in built-in test (diff)
downloadlibbash-ae0cabbc1a5a36ac35b05710fb51f1098cf301e3.tar.gz
libbash-ae0cabbc1a5a36ac35b05710fb51f1098cf301e3.tar.bz2
libbash-ae0cabbc1a5a36ac35b05710fb51f1098cf301e3.zip
Walker: support -a and -o in built-in test
Diffstat (limited to 'scripts')
-rw-r--r--scripts/test_expr.bash2
-rw-r--r--scripts/test_expr.bash.result2
2 files changed, 4 insertions, 0 deletions
diff --git a/scripts/test_expr.bash b/scripts/test_expr.bash
index f1f3093..04b5a62 100644
--- a/scripts/test_expr.bash
+++ b/scripts/test_expr.bash
@@ -50,3 +50,5 @@ i=2
unset i
[[ "setup.py" =~ ^(setup\.py|nosetests|py\.test|trial(\ .*)?)$ ]] && echo true17
[[ "setup.py" =~ ^(setup\.p|nosetests|py\.test|trial(\ .*)?)$ ]] && echo false
+[ abc = bcd -o abc = abc ] && echo true18
+[ abc = bcd -a abc = abc ] || echo true19
diff --git a/scripts/test_expr.bash.result b/scripts/test_expr.bash.result
index 2082757..fb147eb 100644
--- a/scripts/test_expr.bash.result
+++ b/scripts/test_expr.bash.result
@@ -24,3 +24,5 @@ true14
true15
true16
true17
+true18
+true19