aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--src/builtins/tests/unset_tests.cpp50
-rw-r--r--src/builtins/unset_builtin.cpp11
-rw-r--r--src/cppbash_builtin.cpp1
4 files changed, 62 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cc57503..9cb00c9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,6 +107,7 @@ cppunittests_SOURCES = test/run_tests.cpp \
src/builtins/tests/return_tests.cpp \
src/builtins/tests/read_tests.cpp \
src/builtins/tests/set_tests.cpp \
+ src/builtins/tests/unset_tests.cpp \
src/builtins/tests/printf_tests.cpp \
test/test.h \
test/test.cpp \
diff --git a/src/builtins/tests/unset_tests.cpp b/src/builtins/tests/unset_tests.cpp
new file mode 100644
index 0000000..8350507
--- /dev/null
+++ b/src/builtins/tests/unset_tests.cpp
@@ -0,0 +1,50 @@
+/*
+ Please use git log for copyright holder and year information
+
+ This file is part of libbash.
+
+ libbash is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 2 of the License, or
+ (at your option) any later version.
+
+ libbash is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with libbash. If not, see <http://www.gnu.org/licenses/>.
+*/
+///
+/// \file unset_tests.cpp
+/// \brief series of unit tests for unset builtin
+///
+#include <boost/lexical_cast.hpp>
+#include <gtest/gtest.h>
+
+#include "core/interpreter.h"
+#include "cppbash_builtin.h"
+#include "exceptions.h"
+
+TEST(unset_builtin_test, normal)
+{
+ interpreter walker;
+
+ walker.set_value("var", "foo");
+ EXPECT_EQ(0, cppbash_builtin::exec("unset", {"var"}, std::cout, std::cerr, std::cin, walker));
+ EXPECT_STREQ("", walker.resolve<std::string>("var").c_str());
+}
+
+TEST(unset_builtin_test, array)
+{
+ interpreter walker;
+
+ walker.set_value("array", "foo bar", 2);
+ EXPECT_EQ(0, cppbash_builtin::exec("unset", {"array"}, std::cout, std::cerr, std::cin, walker));
+ EXPECT_STREQ("", walker.resolve<std::string>("array", 2).c_str());
+
+ walker.set_value("array", "foo bar", 2);
+ EXPECT_EQ(0, cppbash_builtin::exec("unset", {"array[2]"}, std::cout, std::cerr, std::cin, walker));
+ EXPECT_STREQ("", walker.resolve<std::string>("array", 2).c_str());
+}
diff --git a/src/builtins/unset_builtin.cpp b/src/builtins/unset_builtin.cpp
index d8178f9..2eaafc2 100644
--- a/src/builtins/unset_builtin.cpp
+++ b/src/builtins/unset_builtin.cpp
@@ -26,6 +26,8 @@
#include "core/interpreter.h"
+using namespace boost::xpressive;
+
int unset_builtin::exec(const std::vector<std::string>& bash_args)
{
if(bash_args.empty())
@@ -51,7 +53,14 @@ int unset_builtin::exec(const std::vector<std::string>& bash_args)
* */
for_each(bash_args.front() == "-v" ? bash_args.begin() + 1 : bash_args.begin(),
bash_args.end(),
- [&](const std::string& name) { _walker.unset(name); });
+ [&](const std::string& name) {
+ static const sregex index_pattern = sregex::compile("^(.*)\\[(\\d*)\\]$");
+ smatch match;
+ if(regex_match(name, match, index_pattern))
+ _walker.unset(match[1], boost::lexical_cast<unsigned int>(match[2]));
+ else
+ _walker.unset(name);
+ });
return 0;
}
diff --git a/src/cppbash_builtin.cpp b/src/cppbash_builtin.cpp
index e4a7c29..51cd15c 100644
--- a/src/cppbash_builtin.cpp
+++ b/src/cppbash_builtin.cpp
@@ -46,6 +46,7 @@
#include "builtins/unset_builtin.h"
#include "builtins/read_builtin.h"
#include "builtins/set_builtin.h"
+#include "builtins/unset_builtin.h"
namespace qi = boost::spirit::qi;
namespace karma = boost::spirit::karma;