summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-02-09 19:08:11 -0500
committerMatt Turner <mattst88@gmail.com>2012-02-09 19:09:50 -0500
commit295835ced11febf35e39369792cb2faf1e484b8b (patch)
tree170da1d3c045ac118118d50f7433dae20588a764
parentRemove media-libs/musicbrainz (diff)
downloadloongson-295835ced11febf35e39369792cb2faf1e484b8b.tar.gz
loongson-295835ced11febf35e39369792cb2faf1e484b8b.tar.bz2
loongson-295835ced11febf35e39369792cb2faf1e484b8b.zip
Remove media-libs/mesa
I don't know what kind of DRI driver this patch was supposed to allow to work, but SAREA (and all the DRI 1 drivers) are now dead upstream. Maybe SiS? Signed-off-by: Matt Turner <mattst88@gmail.com>
-rw-r--r--media-libs/mesa/Manifest6
-rw-r--r--media-libs/mesa/files/6.5.2-i965-wine-fix.patch109
-rw-r--r--media-libs/mesa/files/lib/libGL.la32
-rw-r--r--media-libs/mesa/files/lib/libGLU.la32
-rw-r--r--media-libs/mesa/files/mesa-loongson.patch11
-rw-r--r--media-libs/mesa/mesa-7.8.1.ebuild238
6 files changed, 0 insertions, 428 deletions
diff --git a/media-libs/mesa/Manifest b/media-libs/mesa/Manifest
deleted file mode 100644
index 6c1467c..0000000
--- a/media-libs/mesa/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-AUX 6.5.2-i965-wine-fix.patch 2888 RMD160 e899ac128933eb1a65e5c79de97408679beb2a50 SHA1 741221fba69b3891665e16da5baf6e66be62449d SHA256 bc19f4b5ce44a90c6b2aeab2c1148200539791ff9d0c60c5ffc2d4d8fe5fee78
-AUX lib/libGL.la 755 RMD160 a60984e0d56d559c2c15bd4693e01404a7e0a408 SHA1 d6e231ffaccd1b13c3628744031cc761ffaf76d8 SHA256 b32ffd7f3f866da7dbae80ba78b1dc5b4924b33ab133b13397af9cda0a274f91
-AUX lib/libGLU.la 752 RMD160 04de8835526a3472480d7c285dd33d497bcc0bd7 SHA1 12c57ac5e7e8a94d4d41b0f37b0fb3f470791c39 SHA256 e28519d7ae719bc106f7d4239799580474d1b69a2254ede3b2179a5e50655fe5
-AUX mesa-loongson.patch 426 RMD160 00b0f76db3c0fec2768383ad35284905b4793b2d SHA1 0c29f74c34529481aaf165671f90e733ad31feb7 SHA256 8d0a3951b086c18ffdb171b9aea014a69b19d67a9020aa881fcc460ebbd90bf9
-DIST MesaLib-7.8.1.tar.bz2 5137426 RMD160 b7b989342dc80a2a12456c17882e652db7bd86cd SHA1 1c15c62f845ef9b648366aa804410f68f7f79172 SHA256 b0b46e5abfd75db44501e308125fa92bcf1c91d91e97a043a3b1764cfa0907fa
-EBUILD mesa-7.8.1.ebuild 6572 RMD160 88798c02bd41b9f5c22a32352e53db7d72073ebf SHA1 d3a0445fd92c0ce80f6c752c0e390347b36ae2b7 SHA256 8775a7034292678bf6ecf9d52c2eaaa4b5ca1c2879447f6593025d8abfafd6f5
diff --git a/media-libs/mesa/files/6.5.2-i965-wine-fix.patch b/media-libs/mesa/files/6.5.2-i965-wine-fix.patch
deleted file mode 100644
index 63acd15..0000000
--- a/media-libs/mesa/files/6.5.2-i965-wine-fix.patch
+++ /dev/null
@@ -1,109 +0,0 @@
---- a/src/mesa/drivers/dri/i965/brw_context.h
-+++ b/src/mesa/drivers/dri/i965/brw_context.h
-@@ -599,6 +599,7 @@ struct brw_context
-
- struct {
- struct brw_wm_prog_data *prog_data;
-+ struct brw_wm_compile *compile_data;
-
- /* Input sizes, calculated from active vertex program:
- */
-diff --git a/src/mesa/drivers/dri/i965/brw_wm.c b/src/mesa/drivers/dri/i965/brw_wm.c
-index 3e2f2d0..0f842d2 100644
---- a/src/mesa/drivers/dri/i965/brw_wm.c
-+++ b/src/mesa/drivers/dri/i965/brw_wm.c
-@@ -138,64 +138,75 @@ static void do_wm_prog( struct brw_conte
- struct brw_fragment_program *fp,
- struct brw_wm_prog_key *key)
- {
-- struct brw_wm_compile c;
-+ struct brw_wm_compile *c;
- const GLuint *program;
- GLuint program_size;
-
-- memset(&c, 0, sizeof(c));
-- memcpy(&c.key, key, sizeof(*key));
-+ c = brw->wm.compile_data;
-+ if (c == NULL) {
-+ brw->wm.compile_data = calloc(1, sizeof(*brw->wm.compile_data));
-+ c = brw->wm.compile_data;
-+ } else {
-+ memset(c, 0, sizeof(*brw->wm.compile_data));
-+ }
-+ memcpy(&c->key, key, sizeof(*key));
-
-- c.fp = fp;
-- c.env_param = brw->intel.ctx.FragmentProgram.Parameters;
-+ c->fp = fp;
-+ c->env_param = brw->intel.ctx.FragmentProgram.Parameters;
-
-
- /* Augment fragment program. Add instructions for pre- and
- * post-fragment-program tasks such as interpolation and fogging.
- */
-- brw_wm_pass_fp(&c);
-+ brw_wm_pass_fp(c);
-
- /* Translate to intermediate representation. Build register usage
- * chains.
- */
-- brw_wm_pass0(&c);
-+ brw_wm_pass0(c);
-
- /* Dead code removal.
- */
-- brw_wm_pass1(&c);
-+ brw_wm_pass1(c);
-
- /* Hal optimization
- */
-- brw_wm_pass_hal (&c);
-+ brw_wm_pass_hal (c);
-
- /* Register allocation.
- */
-- c.grf_limit = BRW_WM_MAX_GRF/2;
-+ c->grf_limit = BRW_WM_MAX_GRF/2;
-
- /* This is where we start emitting gen4 code:
- */
-- brw_init_compile(&c.func);
-+ brw_init_compile(&c->func);
-
-- brw_wm_pass2(&c);
-+ brw_wm_pass2(c);
-
-- c.prog_data.total_grf = c.max_wm_grf;
-- c.prog_data.total_scratch = c.last_scratch ? c.last_scratch + 0x40 : 0;
-+ c->prog_data.total_grf = c->max_wm_grf;
-+ if (c->last_scratch) {
-+ c->prog_data.total_scratch =
-+ c->last_scratch + 0x40;
-+ } else {
-+ c->prog_data.total_scratch = 0;
-+ }
-
- /* Emit GEN4 code.
- */
-- brw_wm_emit(&c);
-+ brw_wm_emit(c);
-
- /* get the program
- */
-- program = brw_get_program(&c.func, &program_size);
-+ program = brw_get_program(&c->func, &program_size);
-
- /*
- */
- brw->wm.prog_gs_offset = brw_upload_cache( &brw->cache[BRW_WM_PROG],
-- &c.key,
-- sizeof(c.key),
-+ &c->key,
-+ sizeof(c->key),
- program,
- program_size,
-- &c.prog_data,
-+ &c->prog_data,
- &brw->wm.prog_data );
- }
-
diff --git a/media-libs/mesa/files/lib/libGL.la b/media-libs/mesa/files/lib/libGL.la
deleted file mode 100644
index cc2fd24..0000000
--- a/media-libs/mesa/files/lib/libGL.la
+++ /dev/null
@@ -1,32 +0,0 @@
-# libGL.la - a libtool library file
-# Generated by ltmain.sh - GNU libtool 1.4 (1.920 2001/04/24 23:26:18)
-#
-# Please DO NOT delete this file!
-# It is necessary for linking the library.
-
-# The name that we can dlopen(3).
-dlname='libGL.so.1'
-
-# Names of this library.
-library_names='libGL.so.1.2 libGL.so.1 libGL.so'
-
-# The name of the static archive.
-old_library=''
-
-# Libraries that this one depends upon.
-dependency_libs=' -L/usr/${libdir} -lSM -lICE -lXmu -lXt -lXext -lXi -lX11 -ldl -lpthread '
-
-# Version information for libGL.
-current=3
-age=2
-revision=0
-
-# Is this an already installed library?
-installed=yes
-
-# Files to dlopen/dlpreopen
-dlopen=''
-dlpreopen=''
-
-# Directory that this library needs to be installed in:
-libdir='/usr/${libdir}'
diff --git a/media-libs/mesa/files/lib/libGLU.la b/media-libs/mesa/files/lib/libGLU.la
deleted file mode 100644
index cc76b4b..0000000
--- a/media-libs/mesa/files/lib/libGLU.la
+++ /dev/null
@@ -1,32 +0,0 @@
-# libGLU.la - a libtool library file
-# Generated by ltmain.sh - GNU libtool 1.4 (1.920 2001/04/24 23:26:18)
-#
-# Please DO NOT delete this file!
-# It is necessary for linking the library.
-
-# The name that we can dlopen(3).
-dlname='libGLU.so.1'
-
-# Names of this library.
-library_names='libGLU.so.1.3 libGLU.so.1 libGLU.so'
-
-# The name of the static archive.
-old_library=''
-
-# Libraries that this one depends upon.
-dependency_libs=' -L/usr/lib -lGL -lSM -lICE -lXmu -lXt -lXext -lXi -lX11 -ldl -lpthread '
-
-# Version information for libGLU.
-current=4
-age=3
-revision=0
-
-# Is this an already installed library?
-installed=yes
-
-# Files to dlopen/dlpreopen
-dlopen=''
-dlpreopen=''
-
-# Directory that this library needs to be installed in:
-libdir='/usr/lib'
diff --git a/media-libs/mesa/files/mesa-loongson.patch b/media-libs/mesa/files/mesa-loongson.patch
deleted file mode 100644
index fa82abe..0000000
--- a/media-libs/mesa/files/mesa-loongson.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Mesa-6.5.2/include/GL/internal/sarea.h.orig 2007-03-01 05:27:22.000000000 +0800
-+++ Mesa-6.5.2/include/GL/internal/sarea.h 2007-03-01 05:27:49.000000000 +0800
-@@ -44,6 +44,8 @@
- /* SAREA area needs to be at least a page */
- #if defined(__alpha__)
- #define SAREA_MAX 0x2000
-+#elif defined(__mips__)
-+#define SAREA_MAX 0x4000
- #elif defined(__ia64__)
- #define SAREA_MAX 0x10000 /* 64kB */
- #else
diff --git a/media-libs/mesa/mesa-7.8.1.ebuild b/media-libs/mesa/mesa-7.8.1.ebuild
deleted file mode 100644
index ea97c02..0000000
--- a/media-libs/mesa/mesa-7.8.1.ebuild
+++ /dev/null
@@ -1,238 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.8.1.ebuild,v 1.2 2010/05/17 19:37:19 scarabeus Exp $
-
-EAPI=3
-
-EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/mesa"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git"
- EXPERIMENTAL="true"
-fi
-
-inherit autotools multilib flag-o-matic toolchain-funcs ${GIT_ECLASS} portability
-
-OPENGL_DIR="xorg-x11"
-
-MY_PN="${PN/m/M}"
-MY_P="${MY_PN}-${PV/_/-}"
-MY_SRC_P="${MY_PN}Lib-${PV/_/-}"
-DESCRIPTION="OpenGL-like graphic library for Linux"
-HOMEPAGE="http://mesa3d.sourceforge.net/"
-
-#SRC_PATCHES="mirror://gentoo/${P}-gentoo-patches-01.tar.bz2"
-if [[ $PV = 9999* ]]; then
- SRC_URI="${SRC_PATCHES}"
-else
- SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/${PV}/${MY_SRC_P}.tar.bz2
- ${SRC_PATCHES}"
-fi
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-
-VIDEO_CARDS="intel mach64 mga none nouveau r128 radeon radeonhd savage sis svga tdfx via"
-for card in ${VIDEO_CARDS}; do
- IUSE_VIDEO_CARDS+=" video_cards_${card}"
-done
-
-IUSE="${IUSE_VIDEO_CARDS}
- debug +gallium motif +nptl pic selinux +xcb kernel_FreeBSD"
-
-# keep correct libdrm and dri2proto dep
-# keep blocks in rdepend for binpkg
-RDEPEND="
- !<x11-base/xorg-server-1.7
- !<=x11-proto/xf86driproto-2.0.3
- >=app-admin/eselect-opengl-1.1.1-r2
- dev-libs/expat
- >=x11-libs/libdrm-2.4.19
- x11-libs/libICE
- x11-libs/libX11[xcb?]
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86vm
- motif? ( x11-libs/openmotif )
-"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- x11-misc/makedepend
- >=x11-proto/dri2proto-2.2
- >=x11-proto/glproto-1.4.11
- x11-proto/inputproto
- >=x11-proto/xextproto-7.0.99.1
- x11-proto/xf86driproto
- x11-proto/xf86vidmodeproto
-"
-
-S="${WORKDIR}/${MY_P}"
-
-# It is slow without texrels, if someone wants slow
-# mesa without texrels +pic use is worth shot
-QA_EXECSTACK="usr/lib*/opengl/xorg-x11/lib/libGL.so*"
-QA_WX_LOAD="usr/lib*/opengl/xorg-x11/lib/libGL.so*"
-
-# Think about: ggi, svga, fbcon, no-X configs
-
-pkg_setup() {
- # gcc 4.2 has buggy ivopts
- if [[ $(gcc-version) = "4.2" ]]; then
- append-flags -fno-ivopts
- fi
-
- # recommended by upstream
- append-flags -ffast-math
-}
-
-src_unpack() {
- [[ $PV = 9999* ]] && git_src_unpack || unpack ${A}
-}
-
-src_prepare() {
- # apply patches
- if [[ ${PV} != 9999* && -n ${SRC_PATCHES} ]]; then
- EPATCH_FORCE="yes" \
- EPATCH_SOURCE="${WORKDIR}/patches" \
- EPATCH_SUFFIX="patch" \
- epatch
- fi
- # FreeBSD 6.* doesn't have posix_memalign().
- [[ ${CHOST} == *-freebsd6.* ]] && \
- sed -i -e "s/-DHAVE_POSIX_MEMALIGN//" configure.ac
-
- # In order for mesa to complete it's build process we need to use a tool
- # that it compiles. When we cross compile this clearly does not work
- # so we require mesa to be built on the host system first. -solar
- if tc-is-cross-compiler; then
- sed -i -e "s#^GLSL_CL = .*\$#GLSL_CL = glsl-compile#g" \
- "${S}"/src/mesa/shader/slang/library/Makefile || die
- fi
-
- epatch ${FILESDIR}/${PN}-loongson.patch
-
- eautoreconf
-}
-
-src_configure() {
- local myconf r600
-
- # Configurable DRI drivers
- driver_enable swrast
- driver_enable video_cards_intel i810 i915 i965
- driver_enable video_cards_mach64 mach64
- driver_enable video_cards_mga mga
- driver_enable video_cards_r128 r128
- # ATI has two implementations as video_cards
- driver_enable video_cards_radeon radeon r200 r300 r600
- driver_enable video_cards_radeonhd r300 r600
- driver_enable video_cards_savage savage
- driver_enable video_cards_sis sis
- driver_enable video_cards_tdfx tdfx
- driver_enable video_cards_via unichrome
-
- myconf="${myconf} $(use_enable gallium)"
- if use gallium; then
- elog "You have enabled gallium infrastructure."
- elog "This infrastructure currently support these drivers:"
- elog " Intel: works only i915."
- elog " Nouveau: Support for nVidia NV30 and later cards."
- elog " Radeon: Newest implementation of r300-r500 driver."
- elog " Svga: VMWare Virtual GPU driver."
- echo
- myconf="${myconf}
- --with-state-trackers=glx,dri,egl
- $(use_enable video_cards_svga gallium-svga)
- $(use_enable video_cards_nouveau gallium-nouveau)
- $(use_enable video_cards_intel gallium-intel)"
- if use video_cards_radeon || use video_cards_radeonhd; then
- myconf="${myconf} --enable-gallium-radeon"
- else
- myconf="${myconf} --disable-gallium-radeon"
- fi
- else
- if use video_cards_nouveau || use video_cards_svga; then
- elog "SVGA and nouveau drivers are available only via gallium interface."
- elog "Enable gallium useflag if you want to use them."
- fi
- fi
-
- # --with-driver=dri|xlib|osmesa || do we need osmesa?
- econf \
- --disable-option-checking \
- --with-driver=dri \
- --disable-glut \
- --without-demos \
- $(use_enable debug) \
- $(use_enable motif glw) \
- $(use_enable motif) \
- $(use_enable nptl glx-tls) \
- $(use_enable xcb) \
- $(use_enable !pic asm) \
- --with-dri-drivers=${DRI_DRIVERS} \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Save the glsl-compiler for later use
- if ! tc-is-cross-compiler; then
- dodir /usr/bin/
- cp "${S}"/src/glsl/apps/compile "${D}"/usr/bin/glsl-compile \
- || die "failed to copy the glsl compiler."
- fi
- # Remove redundant headers
- # GLUT thing
- rm -f "${D}"/usr/include/GL/glut*.h || die "Removing glut include failed."
- # Glew includes
- rm -f "${D}"/usr/include/GL/{glew,glxew,wglew}.h \
- || die "Removing glew includes failed."
-
- # Move libGL and others from /usr/lib to /usr/lib/opengl/blah/lib
- # because user can eselect desired GL provider.
- ebegin "Moving libGL and friends for dynamic switching"
- dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/{lib,extensions,include}
- local x
- for x in "${D}"/usr/$(get_libdir)/libGL.{la,a,so*}; do
- if [ -f ${x} -o -L ${x} ]; then
- mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/lib \
- || die "Failed to move ${x}"
- fi
- done
- for x in "${D}"/usr/include/GL/{gl.h,glx.h,glext.h,glxext.h}; do
- if [ -f ${x} -o -L ${x} ]; then
- mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include \
- || die "Failed to move ${x}"
- fi
- done
- eend $?
-}
-
-pkg_postinst() {
- # Switch to the xorg implementation.
- echo
- eselect opengl set --use-old ${OPENGL_DIR}
-}
-
-# $1 - VIDEO_CARDS flag
-# other args - names of DRI drivers to enable
-driver_enable() {
- case $# in
- # for enabling unconditionally
- 1)
- DRI_DRIVERS+=",$1"
- ;;
- *)
- if use $1; then
- shift
- for i in $@; do
- DRI_DRIVERS+=",${i}"
- done
- fi
- ;;
- esac
-}