summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhang Le <robert.zhangle@gmail.com>2008-02-18 17:32:30 +0800
committerZhang Le <robert.zhangle@gmail.com>2008-02-18 17:32:30 +0800
commitda89d3e3526bb72ded0cf7f2e5fcc30d8a18c77e (patch)
treef9f024d21c37cca098ddcca7a9e062208dd3a2ee /x11-base/xorg-server/files/1.3.0.0-fix-xephyr-amd64-segfault.patch
parentre-generate binutils' manifest (diff)
downloadloongson-da89d3e3526bb72ded0cf7f2e5fcc30d8a18c77e.tar.gz
loongson-da89d3e3526bb72ded0cf7f2e5fcc30d8a18c77e.tar.bz2
loongson-da89d3e3526bb72ded0cf7f2e5fcc30d8a18c77e.zip
added xorg-server-1.3.0.0-r5.ebuild
Signed-off-by: Zhang Le <robert.zhangle@gmail.com>
Diffstat (limited to 'x11-base/xorg-server/files/1.3.0.0-fix-xephyr-amd64-segfault.patch')
-rw-r--r--x11-base/xorg-server/files/1.3.0.0-fix-xephyr-amd64-segfault.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-base/xorg-server/files/1.3.0.0-fix-xephyr-amd64-segfault.patch b/x11-base/xorg-server/files/1.3.0.0-fix-xephyr-amd64-segfault.patch
new file mode 100644
index 0000000..c8fdfed
--- /dev/null
+++ b/x11-base/xorg-server/files/1.3.0.0-fix-xephyr-amd64-segfault.patch
@@ -0,0 +1,45 @@
+Title : x11-base/xorg-server-1.3.0.0 Xephyr segfaults on startup on amd64
+Assignee : x11@gentoo.org
+Reported : 2007-09-20 17:22 0000
+Updated : 2007-09-20 17:52:21 0000
+Status : NEW
+URL : https://bugs.freedesktop.org/show_bug.cgi?id=11582
+Severity : normal
+Priority : P2
+Reporter : chithanh@cs.tu-berlin.de
+Product : Gentoo Linux
+Component : Server
+Keywords : Inclusion
+Comments : 2
+Attachments : 1
+URL : http://bugs.gentoo.org/show_bug.cgi?id=193207
+
+commit dcc3de91d2b80be98e4488df29ec6b551c7ff6d1
+Author: Alan Coopersmith <alan.coopersmith@sun.com>
+Date: Sat Aug 18 11:50:33 2007 +0200
+
+ Xephyr: fix immediat segfault on amd64
+
+ This closes bug https://bugs.freedesktop.org/show_bug.cgi?id=11582
+
+diff --git a/hw/kdrive/ephyr/hostx.c b/hw/kdrive/ephyr/hostx.c
+index d0a2f2f..12118da 100644
+--- a/hw/kdrive/ephyr/hostx.c
++++ b/hw/kdrive/ephyr/hostx.c
+@@ -40,6 +40,7 @@
+ #include <X11/Xatom.h>
+ #include <X11/keysym.h>
+ #include <X11/extensions/XShm.h>
++#include <X11/Xmd.h>
+
+ /*
+ * All xlib calls go here, which gets built as its own .a .
+@@ -79,7 +80,7 @@ static int HostXWantDamageDebug = 0;
+
+ extern KeySym EphyrKeymap[];
+
+-extern KeySym kdKeymap[];
++extern CARD32 kdKeymap[];
+ extern int kdMinScanCode;
+ extern int kdMaxScanCode;
+ extern int kdMinKeyCode;