summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/ltsp-docs/ltsp-docs-20111210.ebuild')
-rw-r--r--app-doc/ltsp-docs/ltsp-docs-20111210.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-doc/ltsp-docs/ltsp-docs-20111210.ebuild b/app-doc/ltsp-docs/ltsp-docs-20111210.ebuild
new file mode 100644
index 0000000..9392098
--- /dev/null
+++ b/app-doc/ltsp-docs/ltsp-docs-20111210.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# building the manual depends on dblatex, which is not stable as of yet
+# only the lts.conf man page is generated
+# the ebuild version date coincides with the latest bzr revision of lts.conf.xml
+
+EAPI="2"
+
+EBZR_REVISION="129"
+EBZR_REPO_URI="http://bazaar.launchpad.net/~ltsp-docwriters/ltsp/ltsp-docs-trunk"
+
+inherit autotools bzr
+
+DESCRIPTION="LTSP documentation, only lts.conf manpage for now."
+HOMEPAGE="http://www.ltsp.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+
+DEPEND="app-text/xmlto
+ app-text/docbook-xml-dtd:4.5"
+RDEPEND=""
+
+
+src_unpack() {
+ bzr_src_unpack
+}
+
+src_prepare() {
+ # removing dblatex check error
+ epatch "${FILESDIR}/configure.patch"
+ # removing manual build target
+ epatch "${FILESDIR}/makefile.in.patch"
+}
+
+src_install() {
+ doman lts.conf.5
+}