summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/ltspfs/ltspfs-0.6.ebuild')
-rw-r--r--sys-fs/ltspfs/ltspfs-0.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/ltspfs/ltspfs-0.6.ebuild b/sys-fs/ltspfs/ltspfs-0.6.ebuild
new file mode 100644
index 0000000..5550ce0
--- /dev/null
+++ b/sys-fs/ltspfs/ltspfs-0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+EBZR_REVISION="142"
+EBZR_REPO_URI="http://bazaar.launchpad.net/~ltsp-upstream/${PN}/ltspfs-trunk"
+
+inherit bzr autotools
+
+DESCRIPTION="LTSP file system"
+HOMEPAGE="http://www.ltsp.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+DEPEND=">=dev-libs/glib-2.6"
+RDEPEND="${DEPEND} >=sys-fs/fuse-2.7.2
+ x11-libs/libX11"
+
+src_unpack() {
+ bzr_src_unpack
+ # FIXME: do we want to use bzr to generate a ChangeLog?
+ # Create empty ChangeLog to please autoreconf
+ touch ChangeLog
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+
+ dodoc AUTHORS
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*
+ fi
+}