summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/lua/files/lua-5.3-make.patch')
-rw-r--r--dev-lang/lua/files/lua-5.3-make.patch23
1 files changed, 11 insertions, 12 deletions
diff --git a/dev-lang/lua/files/lua-5.3-make.patch b/dev-lang/lua/files/lua-5.3-make.patch
index f84176d..ed22597 100644
--- a/dev-lang/lua/files/lua-5.3-make.patch
+++ b/dev-lang/lua/files/lua-5.3-make.patch
@@ -1,16 +1,16 @@
--- lua-5.1.1.orig/Makefile 2006-06-02 12:53:38.000000000 +0200
+++ lua-5.1.1/Makefile 2006-11-16 02:16:53.000000000 +0100
-@@ -11,7 +11,7 @@
- # so take care if INSTALL_TOP is not an absolute path.
+@@ -12,7 +12,7 @@
+ # LUA_ROOT, LUA_LDIR, and LUA_CDIR in luaconf.h.
INSTALL_TOP= /usr/local
INSTALL_BIN= $(INSTALL_TOP)/bin
-INSTALL_INC= $(INSTALL_TOP)/include
+INSTALL_INC= $(INSTALL_TOP)/include/lua$V
INSTALL_LIB= $(INSTALL_TOP)/lib
INSTALL_MAN= $(INSTALL_TOP)/man/man1
- #
-@@ -127,3 +127,18 @@
- .PHONY: all $(PLATS) clean install local none dummy echo pecho lecho newer
+ INSTALL_LMOD= $(INSTALL_TOP)/share/lua/$V
+@@ -112,3 +112,18 @@
+ .PHONY: all $(PLATS) clean test install local none dummy echo pecho lecho
# (end of Makefile)
+
@@ -36,15 +36,16 @@
@@ -42,1 +42,1 @@
-LUAC_T= luac
+LUAC_T= luac$V
-@@ -54,1 +54,1 @@
+@@ -62,1 +62,1 @@
-$(LUA_T): $(LUA_O) $(LUA_A)
+origin$(LUA_T): $(LUA_O) $(LUA_A)
-@@ -57,1 +57,1 @@
+@@ -65,1 +65,1 @@
-$(LUAC_T): $(LUAC_O) $(LUA_A)
+origin$(LUAC_T): $(LUAC_O) $(LUA_A)
-@@ -185,3 +185,30 @@
- lzio.o: lzio.c lprefix.h lua.h luaconf.h llimits.h lmem.h lstate.h \
- lobject.h ltm.h lzio.h
+@@ -195,3 +195,30 @@
+ lobject.h ltm.h lzio.h
+
+ # (end of Makefile)
+
+export LIBTOOL = $(EROOT)usr/bin/libtool --quiet --tag=CC
+export LIB_VERSION = 6:1:1
@@ -72,5 +73,3 @@
+ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua$V luac$V
+
+gentoo_all: $(LIB_NAME) $(LUA_T) $(LUAC_T)
-
- # (end of Makefile)