summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/resty-xxhash/resty-xxhash-9999.ebuild')
-rw-r--r--dev-lua/resty-xxhash/resty-xxhash-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lua/resty-xxhash/resty-xxhash-9999.ebuild b/dev-lua/resty-xxhash/resty-xxhash-9999.ebuild
new file mode 100644
index 0000000..78b7c60
--- /dev/null
+++ b/dev-lua/resty-xxhash/resty-xxhash-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT="luajit2"
+VCS="git"
+GITHUB_A="sjnam"
+GITHUB_PN="luajit-${PN##resty-}"
+
+inherit lua
+
+DESCRIPTION="LuaJIT bindings for dev-libs/xxhash"
+HOMEPAGE="https://github.com/sjnam/luajit-xxhash"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-libs/xxhash"
+DEPEND="${RDEPEND}"
+
+DOCS=(README.md)
+
+each_lua_install() {
+ dolua_jit lib/resty
+}