summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-10-06 13:15:18 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-10-06 13:15:18 -0400
commit31d3ae8bbdb30450b1658dbf864c194d0ffcf2de (patch)
tree4c0ea1e03ca6f5b18d7179b8ee49d04e0f266d8e
parentmail-client/thunderbird: initial version bump to 52.4 for testing (diff)
downloadmozilla-31d3ae8bbdb30450b1658dbf864c194d0ffcf2de.tar.gz
mozilla-31d3ae8bbdb30450b1658dbf864c194d0ffcf2de.tar.bz2
mozilla-31d3ae8bbdb30450b1658dbf864c194d0ffcf2de.zip
scripts/generate_langpacks.sh: kill script of mercurial is not found
-rwxr-xr-xscripts/generate_langpacks.sh5
1 files changed, 5 insertions, 0 deletions
diff --git a/scripts/generate_langpacks.sh b/scripts/generate_langpacks.sh
index ad9f7cf4..c80a326b 100755
--- a/scripts/generate_langpacks.sh
+++ b/scripts/generate_langpacks.sh
@@ -21,6 +21,11 @@ fi
ebuild=${1}
+if ! hg --version &>/dev/null; then
+ echo "$0 needs mercurial -- aborting"
+ exit 1
+fi
+
if [[ ${ebuild/.ebuild/} == ${ebuild} ]] || [[ ! -e ${ebuild} ]]; then
echo "Must specify the full path to the ebuild as arg.1"
fi