summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xscripts/generate_langpacks.sh5
1 files changed, 5 insertions, 0 deletions
diff --git a/scripts/generate_langpacks.sh b/scripts/generate_langpacks.sh
index ad9f7cf4..c80a326b 100755
--- a/scripts/generate_langpacks.sh
+++ b/scripts/generate_langpacks.sh
@@ -21,6 +21,11 @@ fi
ebuild=${1}
+if ! hg --version &>/dev/null; then
+ echo "$0 needs mercurial -- aborting"
+ exit 1
+fi
+
if [[ ${ebuild/.ebuild/} == ${ebuild} ]] || [[ ! -e ${ebuild} ]]; then
echo "Must specify the full path to the ebuild as arg.1"
fi