summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven J Newbury <steve@snewbury.org.uk>2009-03-30 12:53:57 +0100
committerSteven J Newbury <steve@snewbury.org.uk>2009-03-30 12:53:57 +0100
commit1619ad41a7f8679f28cf8ad837c226c678461bd3 (patch)
tree8cc4934fab1f71632a1e60f0a5c51fccada9f50f
parentNew ebuild dev-db/unixODBC, needs updating to EAPI=2 (diff)
downloadmultilib-portage-1619ad41a7f8679f28cf8ad837c226c678461bd3.tar.gz
multilib-portage-1619ad41a7f8679f28cf8ad837c226c678461bd3.tar.bz2
multilib-portage-1619ad41a7f8679f28cf8ad837c226c678461bd3.zip
Update ~amd64 unixODBC version to EAPI=2 since it needs lib32 gnomeui etc
-rw-r--r--dev-db/unixODBC/Manifest2
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.12.ebuild21
2 files changed, 16 insertions, 7 deletions
diff --git a/dev-db/unixODBC/Manifest b/dev-db/unixODBC/Manifest
index 20b8081cc..e4d701319 100644
--- a/dev-db/unixODBC/Manifest
+++ b/dev-db/unixODBC/Manifest
@@ -7,6 +7,6 @@ DIST unixODBC-2.2.11.tar.gz 2406740 RMD160 533a2733aa9f49bf9e3fd062b6d0ebfdff4df
DIST unixODBC-2.2.12-r0-patches.tar.bz2 6968 RMD160 5d53a41f4645cd366e18405d23acbf3f87dc9eda SHA1 1aa13bf8a6d031583fae844a7d0d503405607f28 SHA256 da58a4c4a08ccef6416af4cac17bd0d6e89f1c513aecab21d9092bcbae0faefd
DIST unixODBC-2.2.12.tar.gz 2798077 RMD160 13c9ec87c3fff4a1fceb45ff7a552a0fa8666b16 SHA1 d1cb286fb538c664549153165e2b9183b58a627b SHA256 d8b425e9cd8bf55ac21653d27e017045013a155a6149ca2930e257a146f9fe40
EBUILD unixODBC-2.2.11-r1.ebuild 1558 RMD160 e150b26ada1669b586af6d6d499d2ecd3bcb6ae1 SHA1 5e2878b1a7136a863d60957780b1151c9f09a43d SHA256 ec864f2ed9ce406fe018e98cdaccb46049e64b74276c5a49207c2b34cdf70371
-EBUILD unixODBC-2.2.12.ebuild 2453 RMD160 7dde206eba683a42c3ca62a45d5dc4ce13a9bc93 SHA1 2229f64818a825c4741c4c81015877fd4f31f2a2 SHA256 848916ff39eb06314278a9c397d5cbf179b81cb3f1629848701a7b76644cfecb
+EBUILD unixODBC-2.2.12.ebuild 2588 RMD160 b5090268e94fc572e43557775050815b5584990c SHA1 5fa313a676392d08069872ef68f298bc2804d5a1 SHA256 35bdbec1880097f23d859b8b01f97947993aa2ec656b6905c609dfe16dfff0db
MISC ChangeLog 10734 RMD160 36a8b9d76e6788220d3ef9abda9bdba2fc0127a9 SHA1 156c77d0d8b7bbc5bc9fbc9b62d96406b1517d1d SHA256 d6c8baff3dddc9447842888c33c754d759ab9f471e459387057cd0d212190852
MISC metadata.xml 157 RMD160 a98db3a086fae3c09a903dadbc05f60443ec4b1a SHA1 ddaa23cc35eb917bf8962b652442bebb1ce0f440 SHA256 54f8878ca0228e380abbaa4b529806b5533a6b9b51b3b16c0909e906586a91a1
diff --git a/dev-db/unixODBC/unixODBC-2.2.12.ebuild b/dev-db/unixODBC/unixODBC-2.2.12.ebuild
index 3cf15a6e5..b22f539ab 100644
--- a/dev-db/unixODBC/unixODBC-2.2.12.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.12.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.12.ebuild,v 1.15 2008/06/15 17:33:57 hoffie Exp $
+EAPI=2
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
PATCH_VERSION="2.2.12-r0"
@@ -19,10 +20,10 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="qt3 gnome lib32"
-RDEPEND=">=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2
- qt3? ( =x11-libs/qt-3* )
- gnome? ( gnome-base/libgnomeui )
+RDEPEND=">=sys-libs/readline-4.1[lib32?]
+ >=sys-libs/ncurses-5.2[lib32?]
+ qt3? ( =x11-libs/qt-3*[lib32?] )
+ gnome? ( gnome-base/libgnomeui[lib32?] )
sys-devel/libtool"
DEPEND="${RDEPEND}
gnome? ( dev-util/cvs )" # see Bug 173256
@@ -49,7 +50,7 @@ src_unpack() {
fi
}
-multilib-native_src_compile_internal() {
+multilib-native_src_configure_internal() {
local myconf
if use qt3 && ! use mips ; then
@@ -66,7 +67,6 @@ multilib-native_src_compile_internal() {
--enable-fdb \
--enable-ltdllib \
${myconf} || die "econf failed"
- emake -j1 || die "emake failed"
if use gnome; then
# Symlink for configure
@@ -83,6 +83,15 @@ multilib-native_src_compile_internal() {
ln -s ../depcomp .
ln -s ../libtool .
+ cd ..
+ fi
+}
+
+multilib-native_src_compile_internal() {
+ emake -j1 || die "emake failed"
+
+ if use gnome; then
+ cd gODBCConfig
emake || die "emake gODBCConfig failed"
cd ..
fi