summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2018-01-07 11:02:28 +0100
committerThomas Sachau <tommy@gentoo.org>2018-01-07 11:02:28 +0100
commitebc98ead590136bf28ac5bcac5e7360dcfb4e731 (patch)
treeab2525beb1a72505f93f9bcd83bb7736a295375e
parentSync portage (diff)
downloadmultilib-portage-ebc98ead590136bf28ac5bcac5e7360dcfb4e731.tar.gz
multilib-portage-ebc98ead590136bf28ac5bcac5e7360dcfb4e731.tar.bz2
multilib-portage-ebc98ead590136bf28ac5bcac5e7360dcfb4e731.zip
Sync portage
-rw-r--r--sys-apps/portage/Manifest2
-rw-r--r--sys-apps/portage/portage-2.3.0-r1.ebuild (renamed from sys-apps/portage/portage-2.2.28-r1.ebuild)134
2 files changed, 24 insertions, 112 deletions
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index 7255ea5e9..7d4974dae 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -1,2 +1,2 @@
-EBUILD portage-2.2.28-r1.ebuild 11932 SHA256 bc5de279f2606bcb9db4bc72346fc8a2abaddd6c9be53de87ddadec2791802a4 SHA512 f650fa58e95502f87006e76b1fc9039dd597c909659f47208c297931e91a52d3f67780091cc36f458023d553651e303e4e8aab8458251e84e081171ad8a90f04 WHIRLPOOL dfc4e3a427f6e848f5e633fc7d89b434f3223c71d5640ba8bfceedee143da127bd1e45ea52bb60f964636b559a49f21c7cb2538cd9bff68a7c3b283d40b0b44c
+EBUILD portage-2.3.0-r1.ebuild 8865 SHA256 c1965aa547240336897094cd5e656a75cd5354238211693b6c8cf5523780e16c SHA512 13a003d6db7991542058553871d440f843de9fda563fb97a23e7baca640a7e8361f7aa646a6fe3f37b255e71966f3e9934514e104160d57ea491def19098d4ab WHIRLPOOL a619a7687811e6c4b08ce64edf3b8be18de2e811b39ca43dc5d77213f81bc3e78e2118422352e8cb43c9426ea11ea1e558c3f2faa012ec92789ae03c0a69a343
MISC metadata.xml 365 SHA256 475a792c24a7db2ae5fab7fb108bf39af08c272d03d87ef942883b297de95d6a SHA512 45a78cd446f546ca81c6d6623e0f7215e13ed81d58d6dfcf7a2614b2ad8250a7af4c9ed8b3d1c301a103f3f17b2f5d8eb16caa82267b7565798fb00383957fb6 WHIRLPOOL 1f744a508a6d6d9225087850a85e47b8effadeff6eb0600daca677f761f22c8ddcc08a972bf4b4c2d6545518710365b560f54dd43d283f19eebdb3b2a0972630
diff --git a/sys-apps/portage/portage-2.2.28-r1.ebuild b/sys-apps/portage/portage-2.3.0-r1.ebuild
index 8aca693f8..553b01f45 100644
--- a/sys-apps/portage/portage-2.2.28-r1.ebuild
+++ b/sys-apps/portage/portage-2.3.0-r1.ebuild
@@ -1,28 +1,27 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=5
PYTHON_COMPAT=(
pypy
- python3_3 python3_4 python3_5
+ python3_4 python3_5 python3_6
python2_7
)
-PYTHON_REQ_USE='bzip2(+)'
+PYTHON_REQ_USE='bzip2(+),threads(+)'
inherit distutils-r1 git-2 multilib
EGIT_REPO_URI="git://anongit.gentoo.org/proj/portage.git"
EGIT_BRANCH="multilib"
-EGIT_COMMIT="f89c3c5cd8d1da1e40d9a94a016b3002df237237"
+EGIT_COMMIT="e69902fbc9c41f0470461561258f596535d9f5c7"
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
SLOT="0"
-IUSE="build doc epydoc +ipc linguas_ru selinux xattr"
+IUSE="build doc epydoc +ipc linguas_ru +native-extensions selinux xattr"
DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
>=app-arch/tar-1.27
@@ -48,6 +47,7 @@ RDEPEND="
)
elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
elibc_glibc? ( >=sys-apps/sandbox-2.2 )
+ elibc_musl? ( >=sys-apps/sandbox-2.2 )
elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
>=app-misc/pax-utils-0.1.17
selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
@@ -75,6 +75,11 @@ pkg_setup() {
python_prepare_all() {
distutils-r1_python_prepare_all
+ if use native-extensions; then
+ printf "[build_ext]\nportage-ext-modules=true\n" >> \
+ setup.cfg || die
+ fi
+
if ! use ipc ; then
einfo "Disabling ipc..."
sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
@@ -117,7 +122,7 @@ python_prepare_all() {
sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
-e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
-e "s|^\(location = \)\(/usr/portage\)|\\1${EPREFIX}\\2|" \
- -e "s|^\(sync-uri = \).*|\\1rsync://prefix.gentooexperimental.org/gentoo-portage-prefix|" \
+ -e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \
-i cnf/repos.conf || die "sed failed"
einfo "Adding FEATURES=force-prefix to make.globals ..."
@@ -209,21 +214,11 @@ pkg_preinst() {
chmod g+s,ug+rwx "${ED}"var/log/portage{,/elog}
fi
- if has_version "<${CATEGORY}/${PN}-2.1.13" || \
- {
- has_version ">=${CATEGORY}/${PN}-2.2_rc0" && \
- has_version "<${CATEGORY}/${PN}-2.2.0_alpha189"
- } ; then
- USERPRIV_UPGRADE=true
- USERSYNC_UPGRADE=true
- REPOS_CONF_UPGRADE=true
- REPOS_CONF_SYNC=
- type -P portageq >/dev/null 2>&1 && \
- REPOS_CONF_SYNC=$("$(type -P portageq)" envvar SYNC)
+ if has_version ">=${CATEGORY}/${PN}-2.3.1" && \
+ has_version "<${CATEGORY}/${PN}-2.3.3"; then
+ SYNC_DEPTH_UPGRADE=true
else
- USERPRIV_UPGRADE=false
- USERSYNC_UPGRADE=false
- REPOS_CONF_UPGRADE=false
+ SYNC_DEPTH_UPGRADE=false
fi
}
@@ -258,78 +253,10 @@ new_config_protect() {
}
pkg_postinst() {
-
- if ${REPOS_CONF_UPGRADE} ; then
- einfo "Generating repos.conf"
- local repo_name=
- [[ -f ${PORTDIR}/profiles/repo_name ]] && \
- repo_name=$(< "${PORTDIR}/profiles/repo_name")
- if [[ -z ${REPOS_CONF_SYNC} ]] ; then
- REPOS_CONF_SYNC=$(grep "^sync-uri =" "${EROOT:-${ROOT}}usr/share/portage/config/repos.conf")
- REPOS_CONF_SYNC=${REPOS_CONF_SYNC##* }
- fi
- local sync_type=
- [[ ${REPOS_CONF_SYNC} == git://* ]] && sync_type=git
-
- if [[ ${REPOS_CONF_SYNC} == cvs://* ]]; then
- sync_type=cvs
- REPOS_CONF_SYNC=${REPOS_CONF_SYNC#cvs://}
- fi
-
- cat <<-EOF > "${T}/repos.conf"
- [DEFAULT]
- main-repo = ${repo_name:-gentoo}
-
- [${repo_name:-gentoo}]
- location = ${PORTDIR:-${EPREFIX}/usr/portage}
- sync-type = ${sync_type:-rsync}
- sync-uri = ${REPOS_CONF_SYNC}
- EOF
-
- [[ ${sync_type} == cvs ]] && echo "sync-cvs-repo = $(<"${PORTDIR}/CVS/Repository")" >> "${T}/repos.conf"
-
- local dest=${EROOT:-${ROOT}}etc/portage/repos.conf
- if [[ ! -f ${dest} ]] && mkdir -p "${dest}" 2>/dev/null ; then
- dest=${EROOT:-${ROOT}}etc/portage/repos.conf/${repo_name:-gentoo}.conf
- fi
- # Don't install the config update if the desired repos.conf directory
- # and config file exist, since users may accept it blindly and break
- # their config (bug #478726).
- [[ -e ${EROOT:-${ROOT}}etc/portage/repos.conf/${repo_name:-gentoo}.conf ]] || \
- mv "${T}/repos.conf" "$(new_config_protect "${dest}")"
-
- if [[ ${PORTDIR} == ${EPREFIX}/usr/portage ]] ; then
- einfo "Generating make.conf PORTDIR setting for backward compatibility"
- for dest in "${EROOT:-${ROOT}}etc/make.conf" "${EROOT:-${ROOT}}etc/portage/make.conf" ; do
- [[ -e ${dest} ]] && break
- done
- [[ -d ${dest} ]] && dest=${dest}/portdir.conf
- rm -rf "${T}/make.conf"
- [[ -f ${dest} ]] && cat "${dest}" > "${T}/make.conf"
- cat <<-EOF >> "${T}/make.conf"
-
- # Set PORTDIR for backward compatibility with various tools:
- # gentoo-bashcomp - bug #478444
- # euse - bug #474574
- # euses and ufed - bug #478318
- PORTDIR="${EPREFIX}/usr/portage"
- EOF
- mkdir -p "${dest%/*}"
- mv "${T}/make.conf" "$(new_config_protect "${dest}")"
- fi
- fi
-
- local distdir=${PORTAGE_ACTUAL_DISTDIR-${DISTDIR}}
-
- if ${USERSYNC_UPGRADE} && \
- [[ -d ${PORTDIR} && -w ${PORTDIR} ]] ; then
- local ownership=$(get_ownership "${PORTDIR}")
- if [[ -n ${ownership} ]] ; then
- einfo "Adjusting PORTDIR permissions for usersync"
- find "${PORTDIR}" -path "${distdir%/}" -prune -o \
- ! \( -user "${ownership%:*}" -a -group "${ownership#*:}" \) \
- -exec chown "${ownership}" {} +
- fi
+ if ${SYNC_DEPTH_UPGRADE}; then
+ ewarn "Please note that this release no longer respects sync-depth for"
+ ewarn "git repositories. There have been too many problems and"
+ ewarn "performance issues. See bugs 552814, 559008"
fi
einfo
@@ -339,25 +266,10 @@ pkg_postinst() {
elog "The bin/ dir of the overlay has some scripts to switch from lib32"
elog "to MULTILIB_ABI or to add the default MULTILIB_ABI flags"
- # Do this last, since it could take a long time if there
- # are lots of live sources, and the user may be tempted
- # to kill emerge while it is running.
- if ${USERPRIV_UPGRADE} && \
- [[ -d ${distdir} && -w ${distdir} ]] ; then
- local ownership=$(get_ownership "${distdir}")
- if [[ ${ownership#*:} == portage ]] ; then
- einfo "Adjusting DISTDIR permissions for userpriv"
- find "${distdir}" -mindepth 1 -maxdepth 1 -type d -uid 0 \
- -exec chown -R portage:portage {} +
- fi
- fi
-
einfo ""
- einfo "This release of portage contains the new repoman code base"
- einfo "This code base is still being developed. So its API's are"
- einfo "not to be considered stable and are subject to change."
- einfo "The code released has been tested and considered ready for use."
- einfo "This however does not guarantee it to be completely bug free."
+ einfo "This release of portage NO LONGER contains the repoman code base."
+ einfo "Repoman has its own ebuild and release package."
+ einfo "For repoman functionality please emerge app-portage/repoman"
einfo "Please report any bugs you may encounter."
einfo ""
}