summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorFlorian Fischer <vlooe@web.de>2009-05-31 19:58:44 +0200
committerFlorian Fischer <vlooe@web.de>2009-05-31 19:58:44 +0200
commit93e617c3f905e4dab02cd1ae70c08945bd916b5c (patch)
treefee33cb8a27cbd7679c3312fbb967f0df59e1f0c /bin
parentMerge branch 'master' of git@github.com:sjnewbury/multilib-overlay (diff)
downloadmultilib-portage-93e617c3f905e4dab02cd1ae70c08945bd916b5c.tar.gz
multilib-portage-93e617c3f905e4dab02cd1ae70c08945bd916b5c.tar.bz2
multilib-portage-93e617c3f905e4dab02cd1ae70c08945bd916b5c.zip
added a ignore list to bin/show_outdated_ebuilds
Diffstat (limited to 'bin')
-rwxr-xr-xbin/show_outdated_ebuilds15
1 files changed, 13 insertions, 2 deletions
diff --git a/bin/show_outdated_ebuilds b/bin/show_outdated_ebuilds
index e33146b20..e98d3e8bc 100755
--- a/bin/show_outdated_ebuilds
+++ b/bin/show_outdated_ebuilds
@@ -1,12 +1,21 @@
#!/bin/bash
SOURCE_DIR=$1
+IGNORE_LIST=$2
if [[ ! -d ${SOURCE_DIR} ]]; then
SOURCE_DIR=/usr/portage
+ IGNORE_LIST=$1
fi
-echo SOURCE_DIR=${SOURCE_DIR}
+if [[ ! -f ${IGNORE_LIST} ]]; then
+ IGNORE_LIST=doc/ignore_lists/portage
+fi
+
+echo ebuild listed in ${IGNORE_LIST} are ignored
+echo the following ebuild are not in ${SOURCE_DIR}
+
+IGNORED_EBUILD="$(cat ${IGNORE_LIST})"
for EBUILD in $(find . -name "*.ebuild" -a -not -path "./main_tree*"); do
if [[ ! -f ${SOURCE_DIR}/${EBUILD} ]]; then
@@ -14,8 +23,10 @@ for EBUILD in $(find . -name "*.ebuild" -a -not -path "./main_tree*"); do
fi
done
+for EBUILD in ${IGNORED_EBUILD}; do
+ EBUILDS_NOT_IN_SOURCE="${EBUILDS_NOT_IN_SOURCE/"${EBUILD}"/}"
+done
EBUILDS_NOT_IN_SOURCE="$(tr ' ' '\n' <<< "${EBUILDS_NOT_IN_SOURCE}" | sort -u)"
-echo the following ebuild are not in ${SOURCE_DIR}
echo -e "${EBUILDS_NOT_IN_SOURCE}"