summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Fischer <vlooe@web.de>2009-03-27 00:22:25 +0100
committerFlorian Fischer <vlooe@web.de>2009-03-27 00:22:25 +0100
commitd0fd6fb29a3632ec39a042bb5c3bf685d092a5fb (patch)
tree507ad96fe7695b333325a16ec787153666622b01 /dev-lang/python/python-2.5.2-r7.ebuild
parentsynced app-crypt/mit-krb5-1.6.3-r5 with portage tree (diff)
downloadmultilib-portage-d0fd6fb29a3632ec39a042bb5c3bf685d092a5fb.tar.gz
multilib-portage-d0fd6fb29a3632ec39a042bb5c3bf685d092a5fb.tar.bz2
multilib-portage-d0fd6fb29a3632ec39a042bb5c3bf685d092a5fb.zip
synced dev-lang/python with portage tree
Diffstat (limited to 'dev-lang/python/python-2.5.2-r7.ebuild')
-rw-r--r--dev-lang/python/python-2.5.2-r7.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-lang/python/python-2.5.2-r7.ebuild b/dev-lang/python/python-2.5.2-r7.ebuild
index 55ab9ee1d..0a94c45ef 100644
--- a/dev-lang/python/python-2.5.2-r7.ebuild
+++ b/dev-lang/python/python-2.5.2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.2-r7.ebuild,v 1.14 2009/02/26 05:55:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.2-r7.ebuild,v 1.15 2009/03/26 05:10:31 zmedico Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -313,8 +313,9 @@ src_test() {
mv "${S}"/Lib/test/test_${test}.py "${T}"
done
+ # Redirect stdin from /dev/tty as a workaround for bug #248081.
# rerun failed tests in verbose mode (regrtest -w)
- EXTRATESTOPTS="-w" make test || die "make test failed"
+ EXTRATESTOPTS="-w" make test < /dev/tty || die "make test failed"
for test in ${skip_tests} ; do
mv "${T}"/test_${test}.py "${S}"/Lib/test/test_${test}.py