summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kuther <gimpel@sonnenkinder.org>2009-03-26 10:44:23 +0100
committerThomas Kuther <gimpel@sonnenkinder.org>2009-03-26 10:44:23 +0100
commitdd3630d771fef7ebeba270505701c981348302b4 (patch)
tree5a6599a6b2fb81ee703b65e3fba11872d63815a1 /dev-lang
parentfix libXt (add patch, how did that happen?) (diff)
downloadmultilib-portage-dd3630d771fef7ebeba270505701c981348302b4.tar.gz
multilib-portage-dd3630d771fef7ebeba270505701c981348302b4.tar.bz2
multilib-portage-dd3630d771fef7ebeba270505701c981348302b4.zip
add python-2.6
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/Manifest3
-rw-r--r--dev-lang/python/python-2.6.1-r1.ebuild276
2 files changed, 279 insertions, 0 deletions
diff --git a/dev-lang/python/Manifest b/dev-lang/python/Manifest
index 3e3d2b952..2b506e329 100644
--- a/dev-lang/python/Manifest
+++ b/dev-lang/python/Manifest
@@ -15,7 +15,10 @@ AUX python-updater 8777 RMD160 f177c5ae1f1d5dabffd9c52da10704999284af0c SHA1 917
AUX python-updater-r1 8785 RMD160 a395283fc17565fc9bc68e59928c74aafe3f19e5 SHA1 6d6f2d44bf20a528693d017b99f45541ae535bf5 SHA256 850bce6c25b33fbc05da98387bf7bd8652d4d6af4c8a7c11b4956e26a84a86b6
DIST Python-2.5.2.tar.bz2 9807597 RMD160 b23b02739833e6730799c5866e2b77aae884b63f SHA1 4755d212f50af704c20224a6966e23acc5aea60f SHA256 f2f80e2a62a039e9a1ffa0fdf58707b2d12b3ff33c56472b46bb6d53f45e083e
DIST Python-2.5.4.tar.bz2 9821313 RMD160 3a76c83464c3b1c38a60351ab054e33ac7195663 SHA1 0f2e819d6381f72f26c734e00a6780b3933ea404 SHA256 bc8d896a2bfe5523ba93b8d89b71017b74e8e6cb21dc676a0ccff668c8780110
+DIST Python-2.6.1.tar.bz2 10960385 RMD160 497dafaca9c150fca611b0175eeb13c2fc4d3e2d SHA1 419f0cb29e9713ea861dde8c43d107c51329e57b SHA256 cf153f10ba6312a8303ceb01bed834a2786d28aa89c7d73dba64714f691628f6
DIST python-gentoo-patches-2.5.2-r7.tar.bz2 28160 RMD160 c2a8c71f464f1cf0cd8e3d142a3f3454de46bc55 SHA1 b64fc90f331e42ea2c364fd61d13b515300fdcbf SHA256 8afff4ed12c3c5ca4418da657617317a8c646a69ae341a3d494747659825355f
DIST python-gentoo-patches-2.5.4.tar.bz2 19474 RMD160 00bb0918414db251b11b7f19a9f8a112c9e49fbd SHA1 fd4955f7da3049abecc4df0e203e783a90390cf8 SHA256 6e050dd8e8a90655bf935af99ad1ae6456bc072f075ddb9bcd532201bbb37274
+DIST python-gentoo-patches-2.6-r5.tar.bz2 7431 RMD160 dbfc0715773446614843b45818d4152ca133140a SHA1 495cbfbf333052faf6860cf2d682f249a787557c SHA256 ef81eac97d933c77afcfd2434f44132717cd0a1550d1092e388e3c2f3dd5f3cf
EBUILD python-2.5.2-r7.ebuild 10765 RMD160 bd829cc1088c4f71637d03973b2789294f573d28 SHA1 4caaf98aa148067bc84f58fd4d323a7fe4fa05d1 SHA256 b38b5a7e0b7bf77f3193e94a64004c6ba3b36fb416ce974efd33fdde9a42d163
EBUILD python-2.5.4-r2.ebuild 10827 RMD160 cf7c1f68395da214c02c894b92d26c4fc59ef39f SHA1 88a20f961b10740dd41f671de11dcd63f5902196 SHA256 ab1a143c0d7b94d8417b3abe697f58c1c159adfe708a4d5beeacd7294d688c27
+EBUILD python-2.6.1-r1.ebuild 8957 RMD160 6241bbc2591d67baeaef0145a1cc4b1b80ac1ed1 SHA1 371af08ce2c4f14acd2bf04d97acdda80a235532 SHA256 93855ee967551f0ec3ad906cf8b9f93e955bc35629c6b70ff0ffee2b6218b4a6
diff --git a/dev-lang/python/python-2.6.1-r1.ebuild b/dev-lang/python/python-2.6.1-r1.ebuild
new file mode 100644
index 000000000..ae2be9411
--- /dev/null
+++ b/dev-lang/python/python-2.6.1-r1.ebuild
@@ -0,0 +1,276 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.1-r1.ebuild,v 1.1 2009/03/21 23:26:28 neurogeek Exp $
+
+# NOTE about python-portage interactions :
+# - Do not add a pkg_setup() check for a certain version of portage
+# in dev-lang/python. It _WILL_ stop people installing from
+# Gentoo 1.4 images.
+
+EAPI=2
+
+inherit eutils autotools flag-o-matic python versionator toolchain-funcs libtool multilib-native
+
+# we need this so that we don't depends on python.eclass
+PYVER_MAJOR=$(get_major_version)
+PYVER_MINOR=$(get_version_component_range 2)
+PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
+
+MY_P="Python-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Python is an interpreted, interactive, object-oriented programming language."
+HOMEPAGE="http://www.python.org/"
+SRC_URI="http://www.python.org/ftp/python/2.6.1/${MY_P}.tar.bz2
+ mirror://gentoo/python-gentoo-patches-2.6-r5.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="berkdb build doc elibc_uclibc examples gdbm ipv6 ncurses readline sqlite ssl +threads tk ucs2 wininst +xml"
+
+# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes,cjkcodecs}
+# do not conflict with the ones in python proper. - liquidx
+
+DEPEND=">=app-admin/eselect-python-20080925
+ >=sys-libs/zlib-1.1.3[lib32?]
+ !build? (
+ sqlite? ( >=dev-db/sqlite-3[lib32?] )
+ tk? ( >=dev-lang/tk-8.0 )
+ ncurses? ( >=sys-libs/ncurses-5.2[lib32?]
+ readline? ( >=sys-libs/readline-4.1[lib32?] ) )
+ berkdb? ( >=sys-libs/db-3.1[lib32?] )
+ gdbm? ( sys-libs/gdbm[lib32?] )
+ ssl? ( dev-libs/openssl[lib32?] )
+ doc? ( dev-python/python-docs:2.6 )
+ xml? ( dev-libs/expat[lib32?] )
+ )"
+
+# NOTE: changed RDEPEND to PDEPEND to resolve bug 88777. - kloeri
+# NOTE: added blocker to enforce correct merge order for bug 88777. - zmedico
+
+PDEPEND="${DEPEND} app-admin/python-updater"
+PROVIDE="virtual/python"
+
+multilib-native_src_prepare_internal() {
+ default
+
+ if tc-is-cross-compiler ; then
+ [[ $(python -V 2>&1) != "Python ${PV}" ]] && \
+ die "Crosscompiling requires the same host and build versions."
+ epatch "${FILESDIR}"/python-2.6-test-cross.patch
+ else
+ rm "${WORKDIR}/${PYVER}"/*_all_crosscompile.patch
+ fi
+
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/${PYVER}"
+
+ epatch "${FILESDIR}/${PN}-${PYVER}_turkish.patch"
+
+ sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
+ Lib/distutils/command/install.py \
+ Lib/distutils/sysconfig.py \
+ Lib/site.py \
+ Makefile.pre.in \
+ Modules/Setup.dist \
+ Modules/getpath.c \
+ setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
+
+ # fix os.utime() on hppa. utimes it not supported but unfortunately reported as working - gmsoft (22 May 04)
+ # PLEASE LEAVE THIS FIX FOR NEXT VERSIONS AS IT'S A CRITICAL FIX !!!
+ [ "${ARCH}" = "hppa" ] && sed -e 's/utimes //' -i "${S}"/configure
+
+ if ! use wininst; then
+ # remove microsoft windows executables
+ rm Lib/distutils/command/wininst-*.exe
+ fi
+
+ eautoreconf
+}
+
+multilib-native_src_configure_internal() {
+ # disable extraneous modules with extra dependencies
+ if use build; then
+ export PYTHON_DISABLE_MODULES="readline pyexpat dbm gdbm bsddb _curses _curses_panel _tkinter _sqlite3"
+ export PYTHON_DISABLE_SSL=1
+ else
+ # dbm module can link to berkdb or gdbm
+ # defaults to gdbm when both are enabled, #204343
+ local disable
+ use berkdb || use gdbm || disable="${disable} dbm"
+ use berkdb || disable="${disable} bsddb"
+ use xml || disable="${disable} pyexpat"
+ use gdbm || disable="${disable} gdbm"
+ use ncurses || disable="${disable} _curses _curses_panel"
+ use readline || disable="${disable} readline"
+ use sqlite || disable="${disable} _sqlite3"
+ use ssl || export PYTHON_DISABLE_SSL=1
+ use tk || disable="${disable} _tkinter"
+ export PYTHON_DISABLE_MODULES="${disable}"
+ fi
+
+ if use !xml; then
+ ewarn "You have configured Python without XML support."
+ ewarn "This is NOT a recommended configuration as you"
+ ewarn "may face problems parsing any XML documents."
+ fi
+
+ einfo "Disabled modules: $PYTHON_DISABLE_MODULES"
+
+ export OPT="${CFLAGS}"
+
+ local myconf
+
+ # super-secret switch. don't use this unless you know what you're
+ # doing. enabling UCS2 support will break your existing python
+ # modules
+ use ucs2 \
+ && myconf="${myconf} --enable-unicode=ucs2" \
+ || myconf="${myconf} --enable-unicode=ucs4"
+
+ filter-flags -malign-double
+
+ # Seems to no longer be necessary
+ #[ "${ARCH}" = "amd64" ] && append-flags -fPIC
+ [ "${ARCH}" = "alpha" ] && append-flags -fPIC
+
+ # http://bugs.gentoo.org/show_bug.cgi?id=50309
+ if is-flag -O3; then
+ is-flag -fstack-protector-all && replace-flags -O3 -O2
+ use hardened && replace-flags -O3 -O2
+ fi
+
+ if tc-is-cross-compiler ; then
+ OPT="-O1" CFLAGS="" LDFLAGS="" CC="" \
+ ./configure || die "cross-configure failed"
+ emake python Parser/pgen || die "cross-make failed"
+ mv python hostpython
+ mv Parser/pgen Parser/hostpgen
+ make distclean
+ sed -i \
+ -e '/^HOSTPYTHON/s:=.*:=./hostpython:' \
+ -e '/^HOSTPGEN/s:=.*:=./Parser/hostpgen:' \
+ Makefile.pre.in || die "sed failed"
+ fi
+
+ # export CXX so it ends up in /usr/lib/python2.x/config/Makefile
+ tc-export CXX
+
+ # set LDFLAGS so we link modules with -lpython2.5 correctly.
+ # Needed on FreeBSD unless python2.5 is already installed.
+ # Please query BSD team before removing this!
+ append-ldflags "-L."
+
+ econf \
+ --with-fpectl \
+ --enable-shared \
+ $(use_enable ipv6) \
+ $(use_with threads) \
+ --infodir='${prefix}'/share/info \
+ --mandir='${prefix}'/share/man \
+ --with-libc='' \
+ ${myconf}
+}
+
+multilib-native_src_install_internal() {
+ dodir /usr
+ emake DESTDIR="${D}" altinstall maninstall || die
+
+ mv "${D}"/usr/bin/python${PYVER}-config "${D}"/usr/bin/python-config-${PYVER}
+
+ # Fix slotted collisions
+ mv "${D}"/usr/bin/2to3 "${D}"/usr/bin/2to3-${PYVER}
+ mv "${D}"/usr/bin/pydoc "${D}"/usr/bin/pydoc${PYVER}
+ mv "${D}"/usr/bin/idle "${D}"/usr/bin/idle${PYVER}
+ mv "${D}"/usr/share/man/man1/python.1 \
+ "${D}"/usr/share/man/man1/python${PYVER}.1
+ rm -f "${D}"/usr/bin/smtpd.py
+
+ # While we're working on the config stuff... Let's fix the OPT var
+ # so that it doesn't have any opts listed in it. Prevents the problem
+ # with compiling things with conflicting opts later.
+ dosed -e 's:^OPT=.*:OPT=-DNDEBUG:' \
+ /usr/$(get_libdir)/python${PYVER}/config/Makefile
+
+ if use build ; then
+ rm -rf "${D}"/usr/$(get_libdir)/python${PYVER}/{test,encodings,email,lib-tk,bsddb/test}
+ else
+ use elibc_uclibc && rm -rf "${D}"/usr/$(get_libdir)/python${PYVER}/{test,bsddb/test}
+ use berkdb || rm -rf "${D}"/usr/$(get_libdir)/python${PYVER}/bsddb
+ use tk || rm -rf "${D}"/usr/$(get_libdir)/python${PYVER}/lib-tk
+ fi
+
+ prep_ml_includes usr/include/python${PYVER}
+
+ # The stuff below this line extends from 2.1, and should be deprecated
+ # in 2.3, or possibly can wait till 2.4
+
+ # seems like the build do not install Makefile.pre.in anymore
+ # it probably shouldn't - use DistUtils, people!
+ insinto /usr/$(get_libdir)/python${PYVER}/config
+ doins "${S}"/Makefile.pre.in
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${S}"/Tools || die "doins failed"
+ fi
+
+ newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT}
+ newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT}
+
+ # Installs empty directory.
+ rmdir "${D}"/usr/$(get_libdir)/${PN}${PV}/lib-old
+}
+
+multilib-native_pkg_postrm_internal() {
+ eselect python update --ignore 3.0
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}
+}
+
+multilib-native_pkg_postinst_internal() {
+ eselect python update --ignore 3.0
+ python_version
+
+ python_mod_optimize -x "(site-packages|test)" \
+ /usr/$(get_libdir)/python${PYVER}
+}
+
+src_test() {
+ # Tests won't work when cross compiling
+ if tc-is-cross-compiler ; then
+ elog "Disabling tests due to crosscompiling."
+ return
+ fi
+
+ # Byte compiling should be enabled here.
+ # Otherwise test_import fails.
+ python_enable_pyc
+
+ #skip all tests that fail during emerge but pass without emerge:
+ #(See bug# 67970)
+ local skip_tests="distutils global httpservers mimetools minidom mmap posix pyexpat sax strptime subprocess syntax tcl time urllib urllib2 webbrowser xml_etree"
+
+ # test_pow fails on alpha.
+ # http://bugs.python.org/issue756093
+ [[ ${ARCH} == "alpha" ]] && skip_tests="${skip_tests} pow"
+
+ for test in ${skip_tests} ; do
+ mv "${S}"/Lib/test/test_${test}.py "${T}"
+ done
+
+ # rerun failed tests in verbose mode (regrtest -w)
+ EXTRATESTOPTS="-w" make test || die "make test failed"
+
+ for test in ${skip_tests} ; do
+ mv "${T}"/test_${test}.py "${S}"/Lib/test/test_${test}.py
+ done
+
+ elog "Portage skipped the following tests which aren't able to run from emerge:"
+ for test in ${skip_tests} ; do
+ elog "test_${test}.py"
+ done
+
+ elog "If you'd like to run them, you may:"
+ elog "cd /usr/lib/python${PYVER}/test"
+ elog "and run the tests separately."
+}