summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven J Newbury <steve@snewbury.org.uk>2009-03-30 08:23:09 +0100
committerSteven J Newbury <steve@snewbury.org.uk>2009-03-30 08:23:09 +0100
commitb2e5f35e280dee1bf4a1b1a823421743bada7e4a (patch)
tree73299d5b65dc178c8e19f554d39d51f96520c424 /dev-libs/libusb
parentlibdrm live ebuild needs EGIT_SRC_URI (diff)
downloadmultilib-portage-b2e5f35e280dee1bf4a1b1a823421743bada7e4a.tar.gz
multilib-portage-b2e5f35e280dee1bf4a1b1a823421743bada7e4a.tar.bz2
multilib-portage-b2e5f35e280dee1bf4a1b1a823421743bada7e4a.zip
Purge libusb-0.1.12-r5.ebuild since it fails to build and isn't in portage.
Diffstat (limited to 'dev-libs/libusb')
-rw-r--r--dev-libs/libusb/libusb-0.1.12-r5.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-libs/libusb/libusb-0.1.12-r5.ebuild b/dev-libs/libusb/libusb-0.1.12-r5.ebuild
deleted file mode 100644
index d347df420..000000000
--- a/dev-libs/libusb/libusb-0.1.12-r5.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/libusb-0.1.12-r5.ebuild,v 1.2 2009/03/28 11:30:42 vapier Exp $
-
-inherit eutils libtool autotools toolchain-funcs multilib-native
-
-DESCRIPTION="Userspace access to USB devices"
-HOMEPAGE="http://libusb.sourceforge.net/"
-SRC_URI="mirror://sourceforge/libusb/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc nocxx"
-RESTRICT="test"
-
-RDEPEND=""
-DEPEND="doc? ( app-text/openjade
- app-text/docbook-dsssl-stylesheets
- app-text/docbook-sgml-utils
- ~app-text/docbook-sgml-dtd-4.2 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e 's:-Werror::' Makefile.am
- sed -i 's:AC_LANG_CPLUSPLUS:AC_PROG_CXX:' configure.in #213800
- epatch "${FILESDIR}"/${PV}-fbsd.patch
- use nocxx && epatch "${FILESDIR}"/${PN}-0.1.12-nocpp.patch
- epatch "${FILESDIR}"/${PN}-0.1.12-no-infinite-bulk.patch
- eautoreconf
- elibtoolize
-
- # Ensure that the documentation actually finds the DTD it needs
- docbookdtd="/usr/share/sgml/docbook/sgml-dtd-4.2/docbook.dtd"
- sysid='"-//OASIS//DTD DocBook V4.2//EN"'
- sed -r -i -e \
- "s,(${sysid}) \[\$,\1 \"${docbookdtd}\" \[,g" \
- "${S}"/doc/manual.sgml
-}
-
-multilib-native_src_compile_internal() {
- econf \
- $(use_enable debug debug all) \
- $(use_enable doc build-docs)
- emake || die "emake failed"
-}
-
-multilib-native_src_install_internal() {
- emake -j1 DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS NEWS README
- use doc && dohtml doc/html/*.html
-
- gen_usr_ldscript -a usb
- use nocxx && rm -f "${D}"/usr/include/usbpp.h
-}