summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kuther <gimpel@sonnenkinder.org>2009-03-19 10:27:28 +0100
committerThomas Kuther <gimpel@sonnenkinder.org>2009-03-19 10:27:28 +0100
commite536e9d4b96f7eef3537d942ddb13520eac1df04 (patch)
tree13a835a6bb193e7a3583d9ff1283eb99a7fc6f1b /dev-libs/libxml2
parentadd dbus-glib (diff)
downloadmultilib-portage-e536e9d4b96f7eef3537d942ddb13520eac1df04.tar.gz
multilib-portage-e536e9d4b96f7eef3537d942ddb13520eac1df04.tar.bz2
multilib-portage-e536e9d4b96f7eef3537d942ddb13520eac1df04.zip
baselibs: add ncurses, readline, libxml2 (be carefull with ncurses!! quickpkg! WFM™)
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/Manifest4
-rw-r--r--dev-libs/libxml2/libxml2-2.7.3.ebuild133
2 files changed, 137 insertions, 0 deletions
diff --git a/dev-libs/libxml2/Manifest b/dev-libs/libxml2/Manifest
new file mode 100644
index 000000000..608c7f1db
--- /dev/null
+++ b/dev-libs/libxml2/Manifest
@@ -0,0 +1,4 @@
+DIST libxml2-2.7.3.tar.gz 4789450 RMD160 14018347531fd135366cee9fd9d760a1988546e2 SHA1 fd4e427fb55c977876bc74c0e552ef7d3d794a07 SHA256 432464d8c9bd8060d9c1fdef1cfa75803c1a363ceac20b21f8c7e34e056e5a98
+DIST xsts-2002-01-16.tar.gz 6894439 RMD160 e8905fe1451a1c367b0104af24edca73bad1db08 SHA1 ca6344e6c47f8c28231f5b213d0c8deb0311a409 SHA256 55e5c08db29946a91ea8e70e8f2418d3fd30d8b6777941dfba7f54726ffd9914
+DIST xsts-2004-01-14.tar.gz 2761085 RMD160 faff2d7826e47ae9968564bc83dab1b54c5e4bf6 SHA1 5896c2aa2cda464246306c5cf0577ed506eefaab SHA256 09bdf9f81f381ebf9bc158a9472e498e896f7a02eb7461146e9abe1b9493ca17
+EBUILD libxml2-2.7.3.ebuild 4007 RMD160 18f150cd5f8bbdcafe165e22b7d67dfc7c2b1332 SHA1 890deb78b41b965dfc518543252c6edfa25e47f8 SHA256 407faed38510ba8b9b25911e7353b3de04bee373529f2726613200d0fad899b6
diff --git a/dev-libs/libxml2/libxml2-2.7.3.ebuild b/dev-libs/libxml2/libxml2-2.7.3.ebuild
new file mode 100644
index 000000000..db8a4c1cd
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.7.3.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.3.ebuild,v 1.8 2009/03/17 19:16:15 armin76 Exp $
+
+EAPI="2"
+
+inherit libtool flag-o-matic eutils python multilib-xlibs
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="alpha amd64 arm ~hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="debug doc examples ipv6 python readline test"
+
+XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
+XSTS_NAME_1="xmlschema2002-01-16"
+XSTS_NAME_2="xmlschema2004-01-14"
+XSTS_TARBALL_1="xsts-2002-01-16.tar.gz"
+XSTS_TARBALL_2="xsts-2004-01-14.tar.gz"
+
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz
+ test? (
+ ${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
+ ${XSTS_HOME}/${XSTS_NAME_2}/${XSTS_TARBALL_2} )"
+
+RDEPEND="sys-libs/zlib
+ python? ( dev-lang/python[lib32?] )
+ readline? ( sys-libs/readline[lib32?] )"
+
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+
+src_unpack() {
+ # ${A} isn't used to avoid unpacking of test tarballs into $WORKDIR,
+ # as they are needed as tarballs in ${S}/xstc instead and not unpacked
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ if use test; then
+ cp "${DISTDIR}/${XSTS_TARBALL_1}" \
+ "${DISTDIR}/${XSTS_TARBALL_2}" \
+ "${S}"/xstc/ \
+ || die "Failed to install test tarballs"
+ fi
+
+ epunt_cxx
+}
+
+multilib-xlibs_src_configure_internal() {
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ # The meaning of the 'debug' USE flag does not apply to the --with-debug
+ # switch (enabling the libxml2 debug module). See bug #100898.
+
+ # --with-mem-debug causes unusual segmentation faults (bug #105120).
+
+ local myconf="--with-zlib \
+ $(use_with debug run-debug) \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with readline history) \
+ $(use_enable ipv6)"
+
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ econf $myconf || die "Configuration failed"
+
+ # Patching the Makefiles to respect get_libdir
+ # Fixes BUG #86766, please keep this.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ for x in $(find "${S}" -name "Makefile") ; do
+ sed \
+ -e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
+ -i ${x} \
+ || die "sed failed"
+ done
+}
+
+multilib-xlibs_src_install_internal() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog Copyright NEWS README* TODO*
+
+ if ! use doc; then
+ rm -rf "${D}"/usr/share/gtk-doc
+ rm -rf "${D}"/usr/share/doc/${P}/html
+ fi
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${P}/examples"
+ rm -rf "${D}/usr/share/doc/${PN}-python-${PV}/examples"
+ fi
+}
+
+multilib-xlibs_pkg_postinst_internal() {
+ if use python; then
+ python_version
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+ fi
+
+ # We don't want to do the xmlcatalog during stage1, as xmlcatalog will not
+ # be in / and stage1 builds to ROOT=/tmp/stage1root. This fixes bug #208887.
+ if [[ "${ROOT}" != "/" ]]
+ then
+ elog "Skipping XML catalog creation for stage building (bug #208887)."
+ else
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG="${ROOT}etc/xml/catalog"
+
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d "${ROOT}etc/xml" ] || mkdir -p "${ROOT}etc/xml"
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+ fi
+}
+
+multilib-xlibs_pkg_postrm_internal() {
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages
+}