summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kuther <gimpel@sonnenkinder.org>2009-03-21 17:46:45 +0100
committerThomas Kuther <gimpel@sonnenkinder.org>2009-03-21 17:46:45 +0100
commitdbfa948d90ba40a80eb177005631d6fb2dd873f7 (patch)
treecfd773b51d542ca597efd3b3379331925a92f840 /net-misc
parenthal, udev, more gnome stuff (diff)
downloadmultilib-portage-dbfa948d90ba40a80eb177005631d6fb2dd873f7.tar.gz
multilib-portage-dbfa948d90ba40a80eb177005631d6fb2dd873f7.tar.bz2
multilib-portage-dbfa948d90ba40a80eb177005631d6fb2dd873f7.zip
more gnomelibs, curl, zattoo-bin
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/curl/Manifest3
-rw-r--r--net-misc/curl/curl-7.19.4.ebuild109
-rw-r--r--net-misc/curl/files/curl-7.17.0-strip-ldflags.patch24
3 files changed, 136 insertions, 0 deletions
diff --git a/net-misc/curl/Manifest b/net-misc/curl/Manifest
new file mode 100644
index 000000000..6d37ff111
--- /dev/null
+++ b/net-misc/curl/Manifest
@@ -0,0 +1,3 @@
+AUX curl-7.17.0-strip-ldflags.patch 796 RMD160 1bcb5af41c63b0afb7758e3c4c8f9bea5e52c29c SHA1 c63330a3505adb684dd2f1cfa89eae5159cb9cc6 SHA256 f3892c3d2a16f96319fd11cb516f66b5df0ece18ca8271cf3b9c1f286e9b5d73
+DIST curl-7.19.4.tar.bz2 2296879 RMD160 91f46c421e0f23f268640d39f45a74621e951245 SHA1 6b8cb206990cd68d8653cea16a47bd0febd5c50d SHA256 fb3436280dedbc8f8141d3841a5964c4491dd6457bc5b7123854aed0b794be86
+EBUILD curl-7.19.4.ebuild 3345 RMD160 ca6a76b97fa730fe3cea4c84b11484db311a681c SHA1 df419893794e78225736120e74ec71feac7ca124 SHA256 d8d8aef8458a14f0e1517bdf80db9b9ee5e74dc3a9e334dcac7da40ef2e90df4
diff --git a/net-misc/curl/curl-7.19.4.ebuild b/net-misc/curl/curl-7.19.4.ebuild
new file mode 100644
index 000000000..5ebb22178
--- /dev/null
+++ b/net-misc/curl/curl-7.19.4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.19.4.ebuild,v 1.5 2009/03/04 20:00:22 dertobi123 Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+EAPI="2"
+
+inherit eutils multilib-xlibs
+
+#MY_P=${P/_pre/-}
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
+#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
+#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT X11"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+#IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
+IUSE="ssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
+
+# TODO - change to openssl USE flag in the not too distant future
+# https://bugs.gentoo.org/show_bug.cgi?id=207653#c3 (April 2008)
+
+RDEPEND="gnutls? ( net-libs/gnutls[lib32?] app-misc/ca-certificates )
+ nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
+ ssl? ( !gnutls? ( !nss? ( dev-libs/openssl[lib32?] app-misc/ca-certificates ) ) )
+ ldap? ( net-nds/openldap )
+ idn? ( net-dns/libidn )
+ ares? ( >=net-dns/c-ares-1.4.0 )
+ kerberos? ( virtual/krb5 )
+ libssh2? ( >=net-libs/libssh2-0.16 )"
+
+# fbopenssl (not in gentoo) --with-spnego
+# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
+
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+# used - but can do without in self test: net-misc/stunnel
+#S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/curl-7.17.0-strip-ldflags.patch
+}
+
+multilib-xlibs_src_configure_internal() {
+
+ myconf="$(use_enable ldap)
+ $(use_enable ldap ldaps)
+ $(use_with idn libidn)
+ $(use_with kerberos gssapi /usr)
+ $(use_with libssh2)
+ $(use_enable ipv6)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-nonblocking
+ --enable-largefile
+ --enable-maintainer-mode
+ --disable-sspi
+ --without-krb4
+ --without-spnego"
+
+ if use ipv6 && use ares; then
+ elog "c-ares support disabled because it is incompatible with ipv6."
+ myconf="${myconf} --disable-ares"
+ else
+ myconf="${myconf} $(use_enable ares)"
+ fi
+
+ if use gnutls; then
+ myconf="${myconf} --without-ssl --with-gnutls --without-nss"
+ myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ elif use nss; then
+ myconf="${myconf} --without-ssl --without-gnutls --with-nss"
+ myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
+ elif use ssl; then
+ myconf="${myconf} --without-gnutls --without-nss --with-ssl"
+ myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
+ else
+ myconf="${myconf} --without-gnutls --without-nss --without-ssl"
+ fi
+
+ econf ${myconf} || die 'configure failed'
+}
+
+multilib-xlibs_src_install_internal() {
+ emake DESTDIR="${D}" install || die "installed failed for current version"
+ rm -rf "${D}"/etc/
+
+ # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INTERNALS
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-misc/curl/files/curl-7.17.0-strip-ldflags.patch b/net-misc/curl/files/curl-7.17.0-strip-ldflags.patch
new file mode 100644
index 000000000..ac11500a5
--- /dev/null
+++ b/net-misc/curl/files/curl-7.17.0-strip-ldflags.patch
@@ -0,0 +1,24 @@
+--- libcurl.pc.in.orig 2007-09-14 07:36:31.000000000 +1000
++++ libcurl.pc.in 2007-09-14 07:36:49.000000000 +1000
+@@ -33,6 +33,6 @@
+ URL: http://curl.haxx.se/
+ Description: Library to transfer files with ftp, http, etc.
+ Version: @VERSION@
+-Libs: -L${libdir} -lcurl @LDFLAGS@ @LIBS@
++Libs: -L${libdir} -lcurl @LIBS@
+ Libs.private: @LIBCURL_LIBS@ @LIBS@
+ Cflags: -I${includedir}
+--- curl-config.in.orig 2007-09-14 07:36:18.000000000 +1000
++++ curl-config.in 2007-09-14 07:37:14.000000000 +1000
+@@ -187,9 +187,9 @@
+ CURLLIBDIR=""
+ fi
+ if test "X@REQUIRE_LIB_DEPS@" = "Xyes"; then
+- echo ${CURLLIBDIR}-lcurl @LDFLAGS@ @LIBCURL_LIBS@ @LIBS@
++ echo ${CURLLIBDIR}-lcurl @LIBCURL_LIBS@ @LIBS@
+ else
+- echo ${CURLLIBDIR}-lcurl @LDFLAGS@ @LIBS@
++ echo ${CURLLIBDIR}-lcurl @LIBS@
+ fi
+ ;;
+