summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Fischer <vlooe@web.de>2009-06-20 19:48:59 +0200
committerFlorian Fischer <vlooe@web.de>2009-06-20 19:48:59 +0200
commit18460c3b77a3a5004de72a3c2423f1963440ddc1 (patch)
tree3fa1b8e0606863d3b76f6fbfc3c4f47f5afbf4de /sys-apps
parentfixed DEPEND of x11-libs/qt-webkit-4.5.1 (diff)
downloadmultilib-portage-18460c3b77a3a5004de72a3c2423f1963440ddc1.tar.gz
multilib-portage-18460c3b77a3a5004de72a3c2423f1963440ddc1.tar.bz2
multilib-portage-18460c3b77a3a5004de72a3c2423f1963440ddc1.zip
added the abi-wrapper and its neccessary changes
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/abi-wrapper/Manifest2
-rw-r--r--sys-apps/abi-wrapper/abi-wrapper-1.0.ebuild39
2 files changed, 40 insertions, 1 deletions
diff --git a/sys-apps/abi-wrapper/Manifest b/sys-apps/abi-wrapper/Manifest
index ccee91cf9..51e228d62 100644
--- a/sys-apps/abi-wrapper/Manifest
+++ b/sys-apps/abi-wrapper/Manifest
@@ -1,2 +1,2 @@
AUX abi-wrapper 644 RMD160 17fde92ac21ec8fcec35f09162890073673711ad SHA1 407f493c424dc2047d4a0b611b9f9d4b9d81aae4 SHA256 a1705379c45570fc2175e32eddac1343391db64988c7479a1338fed653193dad
-EBUILD abi-wrapper-1.0.ebuild 353 RMD160 e8406096a605fc5f884b574b4c24502ea2f81471 SHA1 e700ea91e43fd6207c07cc274559fc71191a65e6 SHA256 09a78dea2ae7bdb4360a51c7d9ccef33b1fa237790b83f596e73e2f8213940a3
+EBUILD abi-wrapper-1.0.ebuild 1366 RMD160 7def32d87e2f4e9c0b3857dd8e6d38a973beb4f9 SHA1 76b7171bba2dbb4a767920e6ceab75997e4f1636 SHA256 272055f28235f0cae750e6a8021ecc5bbf0fe14b704521c1fbbdb8d5ac057beb
diff --git a/sys-apps/abi-wrapper/abi-wrapper-1.0.ebuild b/sys-apps/abi-wrapper/abi-wrapper-1.0.ebuild
index 0756454c1..b4c018532 100644
--- a/sys-apps/abi-wrapper/abi-wrapper-1.0.ebuild
+++ b/sys-apps/abi-wrapper/abi-wrapper-1.0.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+inherit multilib
+
DESCRIPTION="Wraps binarys that behave abi dependand"
HOMEPAGE="www.gentoo.org"
SRC_URI=""
@@ -19,3 +21,40 @@ src_install()
exeinto /usr/bin
doexe ${FILESDIR}/abi-wrapper
}
+
+pkg_postinst() {
+
+ local MY_ABI=""
+ local QFILE="qfile"
+ local MY_FILES=""
+
+ for MY_ABI in $(get_all_abis); do
+ if [[ ${MY_ABI} != ${DEFAULT_ABI} ]]; then
+ # take the binaries listet in doc/prep_ml_binaries and append the
+ # abi. Tthen ls those files. After that remove the appended abi and
+ # ls the remaining ones again. Then grep out the ones already
+ # pointing to the abi-wrapper and generate a list of binaries
+ MY_FILES="${MY_FILES}\
+ $(cat ${PORTDIR_OVERLAY}/doc/prep_ml_binaries\
+ | cut -d " " -f 3-\
+ | tr " " "\n"\
+ | tr -s "\n"\
+ | sed "s@.*@&-${MY_ABI}@"\
+ | xargs -r ls 2> /dev/null\
+ | sed "s@-${MY_ABI}@@"\
+ | xargs -r ls -l\
+ | grep -v abi-wrapper\
+ | tr -s " "\
+ | cut -d " " -f 9)"
+ fi
+ done
+
+ MY_FILES=$(echo "${MY_FILES}" | tr -s "[:blank:]" )
+
+ if [[ ${#MY_FILES} -gt 1 ]]; then
+ ewarn you have to rebuild the following ebuilds
+ echo ${MY_FILES} | tr " " "\n" | sort -u | xargs -n 1 -r ${QFILE}
+ else
+ einfo nothing to rebuild
+ fi
+}