summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-11-16 20:53:22 +0100
committerThomas Sachau <tommy@gentoo.org>2009-11-16 22:19:15 +0100
commitae74ec08b48426081630117edcbad4aa58007046 (patch)
tree4b72bef6a6d12b78f6a1531e4bd5174c76110813 /sys-apps
parentSync portage, use abi-wrapper for perl (diff)
downloadmultilib-portage-ae74ec08b48426081630117edcbad4aa58007046.tar.gz
multilib-portage-ae74ec08b48426081630117edcbad4aa58007046.tar.bz2
multilib-portage-ae74ec08b48426081630117edcbad4aa58007046.zip
Sync abi-wrapper with master
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/abi-wrapper/Manifest4
-rw-r--r--sys-apps/abi-wrapper/abi-wrapper-1.0-r2.ebuild11
-rw-r--r--sys-apps/abi-wrapper/files/abi-wrapper28
3 files changed, 20 insertions, 23 deletions
diff --git a/sys-apps/abi-wrapper/Manifest b/sys-apps/abi-wrapper/Manifest
index ad15bc83c..23240beb8 100644
--- a/sys-apps/abi-wrapper/Manifest
+++ b/sys-apps/abi-wrapper/Manifest
@@ -1,2 +1,2 @@
-AUX abi-wrapper 566 RMD160 a02dbf08b926569e194d76015149d11c056b9215 SHA1 bf5d5eeb2706a01b584987bc4d63ffe5ec998a7d SHA256 d632aee568b4357e9777ceef440ef9b088dec33001090bbe0e56fd678bbd2ded
-EBUILD abi-wrapper-1.0-r2.ebuild 579 RMD160 102b06a3baecd8dbccac49237a9b4eab1515c3a3 SHA1 ceed5f5d8497a0b79528b02703452b09c2a7ec14 SHA256 c1e00975f56bf2947ca849c0686d52eff29c8b1cde8c9248ccf2a45d7ae63263
+AUX abi-wrapper 768 RMD160 34932db7aa836d12c4ba8f9926fe9370fca49881 SHA1 e333b8c33e044a98c9f799793755dbaacf26f0b6 SHA256 92c65179c9df87c8dec10b05d19aea1d2b1afd7b6599e40abfbac628a3392e48
+EBUILD abi-wrapper-1.0-r2.ebuild 488 RMD160 d0250acbc1aa0878964b1617824e409cb94119c2 SHA1 477828dd67bbb1f21064be9c19600e32f7509847 SHA256 a6c0a2c7ff12987772b85da633a5218bd7da20c757cf7c7eca21766d88550ced
diff --git a/sys-apps/abi-wrapper/abi-wrapper-1.0-r2.ebuild b/sys-apps/abi-wrapper/abi-wrapper-1.0-r2.ebuild
index d578f37be..746d505d3 100644
--- a/sys-apps/abi-wrapper/abi-wrapper-1.0-r2.ebuild
+++ b/sys-apps/abi-wrapper/abi-wrapper-1.0-r2.ebuild
@@ -2,8 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
-
DESCRIPTION="Wraps binarys that behave abi dependand"
HOMEPAGE="www.gentoo.org"
SRC_URI=""
@@ -13,13 +11,10 @@ SLOT="0"
KEYWORDS="amd64"
IUSE=""
-src_prepare() {
- cp "${FILESDIR}"/abi-wrapper "${T}"/abi-wrapper
- echo cp "${FILESDIR}"/abi-wrapper "${T}"/abi-wrapper
+src_unpack() {
local abis="${DEFAULT_ABI} ${MULTILIB_ABIS/${DEFAULT_ABI}}"
- sed -i "s/PLACEHOLDER_FOR_HARDCODED_ABIS/${abis}/" "${T}"/abi-wrapper
+ sed "s/PLACEHOLDER_FOR_HARDCODED_ABIS/${abis}/" "${FILESDIR}"/abi-wrapper > "${WORKDIR}"/abi-wrapper
}
-
src_install() {
- dobin "${T}"/abi-wrapper || die
+ dobin abi-wrapper || die
}
diff --git a/sys-apps/abi-wrapper/files/abi-wrapper b/sys-apps/abi-wrapper/files/abi-wrapper
index 873c830e5..b0903eaec 100644
--- a/sys-apps/abi-wrapper/files/abi-wrapper
+++ b/sys-apps/abi-wrapper/files/abi-wrapper
@@ -1,24 +1,26 @@
-#!/bin/bash
-
-if [[ -n ${ABI} ]]; then
+#!/bin/sh
+
+# Please be careful to keep this file sh compatible
+
+if [ "${ABI}" ]; then
abi=${ABI}
-elif [[ -n ${DEFAULT_ABI} ]]; then
+elif [ "${DEFAULT_ABI}" ]; then
abi=${DEFAULT_ABI}
-else
+else
# we're called from outside portage, so use the hardcoded abi list
hardcoded_abis="PLACEHOLDER_FOR_HARDCODED_ABIS"
for abi in ${hardcoded_abis}; do
- [[ -f ${0}-${abi} ]] && break
- unset abi
+ [ -f "${0}-${abi}" ] && break
+ abi=
done
fi
-
-if [[ -f ${0}-${abi} ]]; then
- exec ${0}-${abi} "${@}"
+
+if [ -f "${0}-${abi}" ]; then
+ exec "${0}-${abi}" ${1+"$@"}
else
- if [[ -L ${0} ]]; then
- LINK_TARGET="$(readlink ${0})"
- exec ${LINK_TARGET} "${@}"
+ if [ -L "${0}" ]; then
+ LINK_TARGET="$(readlink "${0}")"
+ exec "${LINK_TARGET}" ${1+"$@"}
else
echo "${0}: abi-wrapper couldn't find an executable for current abi ${abi}" >&2
exit 1