summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Fischer <vlooe@web.de>2009-07-04 18:47:37 +0200
committerFlorian Fischer <vlooe@web.de>2009-07-04 18:47:37 +0200
commitf36ec9a4245143bb7ec7ab3f37b1d58f9c8ee479 (patch)
treee97c05cbdfee68572bf592c9bc91cce25a9b5f42 /x11-libs
parentsynced net-libs/xulrunner with portage tree (diff)
downloadmultilib-portage-f36ec9a4245143bb7ec7ab3f37b1d58f9c8ee479.tar.gz
multilib-portage-f36ec9a4245143bb7ec7ab3f37b1d58f9c8ee479.tar.bz2
multilib-portage-f36ec9a4245143bb7ec7ab3f37b1d58f9c8ee479.zip
added stable x11-libs/libxcb
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxcb/libxcb-1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-libs/libxcb/libxcb-1.1.ebuild b/x11-libs/libxcb/libxcb-1.1.ebuild
new file mode 100644
index 000000000..0b2242950
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.ebuild,v 1.11 2009/05/04 17:06:59 ssuominen Exp $
+
+# Must be before x-modular eclass is inherited
+SNAPSHOT="yes"
+
+EAPI="2"
+
+inherit x-modular multilib-native
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+LICENSE="X11"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="doc"
+RDEPEND="x11-libs/libXau[lib32?]
+ x11-libs/libXdmcp[lib32?]
+ dev-libs/libpthread-stubs"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-libs/libxslt
+ ~x11-proto/xcb-proto-${PV}"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable doc build-docs)"
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ elog "libxcb-1.1 adds the LIBXCB_ALLOW_SLOPPY_LOCK variable to allow"
+ elog "broken applications to keep running instead of being aborted."
+ elog "Set this variable if you need to use broken packages such as Java"
+ elog "(for example, add LIBXCB_ALLOW_SLOPPY_LOCK=1 to /etc/env.d/00local"
+ elog "and run env-update)."
+}