summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--metadata/cache/x11-libs/qt-sql-4.5.12
-rw-r--r--x11-libs/qt-sql/Manifest2
-rw-r--r--x11-libs/qt-sql/qt-sql-4.5.1.ebuild7
3 files changed, 7 insertions, 4 deletions
diff --git a/metadata/cache/x11-libs/qt-sql-4.5.1 b/metadata/cache/x11-libs/qt-sql-4.5.1
index e085b5565..4e46168a0 100644
--- a/metadata/cache/x11-libs/qt-sql-4.5.1
+++ b/metadata/cache/x11-libs/qt-sql-4.5.1
@@ -6,7 +6,7 @@ http://download.qtsoftware.com/qt/source/qt-x11-opensource-src-4.5.1.tar.bz2
http://www.qtsoftware.com/
|| ( LGPL-2.1 GPL-3 )
The SQL module for the Qt toolkit
-alpha ~amd64 arm ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc ~x86 ~x86-fbsd
+alpha amd64 arm hppa ~ia64 ~mips ppc ~ppc64 ~sparc x86 ~x86-fbsd
base eutils flag-o-matic multilib multilib-native portability qt4-build toolchain-funcs versionator
firebird +iconv mysql odbc postgres +qt3support +sqlite custom-cxxflags debug pch lib32
diff --git a/x11-libs/qt-sql/Manifest b/x11-libs/qt-sql/Manifest
index 4d26f518c..7e8bac12a 100644
--- a/x11-libs/qt-sql/Manifest
+++ b/x11-libs/qt-sql/Manifest
@@ -4,4 +4,4 @@ DIST qt-x11-opensource-src-4.4.2.tar.bz2 102816706 RMD160 5719ab5800ca181417e0df
DIST qt-x11-opensource-src-4.5.1.tar.bz2 114667436 RMD160 702d7c6bb9787cd5602dcb8afce52bdfcfd52179 SHA1 50ba9b6d2eb7056e47dc53775be509c4ff6ec015 SHA256 b994c40e41386c9d82f025dd9198e1161717021216680adef97da3f1b8947c75
EBUILD qt-sql-4.4.2-r1.ebuild 2550 RMD160 0a71324784308580dab75041aa86947360472d08 SHA1 6dfeca61265ee4caaff52b628e9fdf42d702bb14 SHA256 f4ba254922f3a41a4fdade38e0468bf08bd3ac0a9e0f90565c81ff2d0491c91d
EBUILD qt-sql-4.4.2.ebuild 2436 RMD160 e7283cc97f1a429c7b02450890e03aaaeb9bfb72 SHA1 7fce1164e25bca1b7bcab4f9dda661fb9acff9a1 SHA256 62a4c8b994cf568c2a9642898b152669075f8c2f92afd2ce295a98d04200f652
-EBUILD qt-sql-4.5.1.ebuild 2316 RMD160 98a044947a22b9bd2fc2aaaec04e2294a047f55b SHA1 74c8b285323f86e616a164f2fc0e85ecd25e8a6c SHA256 1ef22050d08672ff525a3389385140de99501ce1ef2bd5ec9af90f2175e46eff
+EBUILD qt-sql-4.5.1.ebuild 2351 RMD160 d04dc90277d670c3743c58b1e76b365e82bcdefc SHA1 702a23f8257cc485ecd516992100c95e9be6a974 SHA256 eb05ed7a6b1625bda66bf3c1470e1693db84bb120252d1263645942a05ef4d98
diff --git a/x11-libs/qt-sql/qt-sql-4.5.1.ebuild b/x11-libs/qt-sql/qt-sql-4.5.1.ebuild
index f64ba23ff..f52e51178 100644
--- a/x11-libs/qt-sql/qt-sql-4.5.1.ebuild
+++ b/x11-libs/qt-sql/qt-sql-4.5.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.5.1.ebuild,v 1.5 2009/05/28 12:06:16 dagger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.5.1.ebuild,v 1.8 2009/06/08 22:31:53 jer Exp $
EAPI="2"
inherit qt4-build multilib-native
DESCRIPTION="The SQL module for the Qt toolkit"
SLOT="4"
-KEYWORDS="alpha ~amd64 arm ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ppc ~ppc64 ~sparc x86 ~x86-fbsd"
IUSE="firebird +iconv mysql odbc postgres +qt3support +sqlite"
DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support=,lib32?]
@@ -43,7 +43,10 @@ pkg_setup() {
src_unpack() {
qt4-build_src_unpack
+}
+src_prepare() {
+ qt4-build_src_prepare
sed -e '/pg_config --libs/d' -i "${S}"/configure \
|| die 'Sed to fix postgresql usage in ./configure failed.'
}