summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysql/mysql-4.1.22-r1.ebuild')
-rw-r--r--dev-db/mysql/mysql-4.1.22-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-db/mysql/mysql-4.1.22-r1.ebuild b/dev-db/mysql/mysql-4.1.22-r1.ebuild
new file mode 100644
index 000000000..f45476b82
--- /dev/null
+++ b/dev-db/mysql/mysql-4.1.22-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.22-r1.ebuild,v 1.7 2009/02/28 22:42:10 robbat2 Exp $
+
+MY_EXTRAS_VER="20090228-2228Z"
+SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz"
+
+inherit mysql multilib-native
+# only to make repoman happy. it is really set in the eclass
+IUSE="$IUSE"
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+
+src_test() {
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus
+ local testopts="--force"
+
+ # sandbox makes ndbd zombie
+ hasq "sandbox" ${FEATURES} && testopts="${testopts} --skip-ndb"
+
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ cd mysql-test
+ sed -i -e "s|3306|3307|g" mysql-test-run.pl
+
+ # from Makefile.am:
+ retstatus=1
+ ./mysql-test-run.pl ${testopts} \
+ && ./mysql-test-run.pl ${testopts} --ps-protocol \
+ && retstatus=0
+
+ # Just to be sure ;)
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus -eq 0 ]] || die "test failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}