summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/amrnb/amrnb-7.0.0.2.ebuild')
-rw-r--r--media-libs/amrnb/amrnb-7.0.0.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/amrnb/amrnb-7.0.0.2.ebuild b/media-libs/amrnb/amrnb-7.0.0.2.ebuild
new file mode 100644
index 000000000..671a9ea52
--- /dev/null
+++ b/media-libs/amrnb/amrnb-7.0.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/amrnb/amrnb-7.0.0.2.ebuild,v 1.3 2009/03/01 14:06:28 loki_val Exp $
+
+inherit multilib-native
+
+SPEC_VER="26104-700"
+
+DESCRIPTION="Wrapper library for 3GPP Adaptive Multi-Rate Floating-point Speech Codec"
+HOMEPAGE="http://www.penguin.cz/~utx/amr"
+SRC_URI="http://ftp.penguin.cz/pub/users/utx/amr/${P}.tar.bz2
+ http://www.3gpp.org/ftp/Specs/archive/26_series/26.104/${SPEC_VER}.zip"
+
+LICENSE="LGPL-2 as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RESTRICT="mirror"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+#Bug 232636
+export LC_ALL=C
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+ cp "${DISTDIR}"/${SPEC_VER}.zip .
+}
+
+multilib-native_src_install_internal() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}