summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/db/db-4.6.21_p3-r1.ebuild')
-rw-r--r--sys-libs/db/db-4.6.21_p3-r1.ebuild169
1 files changed, 0 insertions, 169 deletions
diff --git a/sys-libs/db/db-4.6.21_p3-r1.ebuild b/sys-libs/db/db-4.6.21_p3-r1.ebuild
deleted file mode 100644
index 6311fb47a..000000000
--- a/sys-libs/db/db-4.6.21_p3-r1.ebuild
+++ /dev/null
@@ -1,169 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.6.21_p3-r1.ebuild,v 1.6 2009/02/24 16:16:43 kumba Exp $
-
-EAPI="2"
-
-inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool multilib-native
-
-#Number of official patches
-#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
-PATCHNO=${PV/*.*.*_p}
-if [[ ${PATCHNO} == "${PV}" ]] ; then
- MY_PV=${PV}
- MY_P=${P}
- PATCHNO=0
-else
- MY_PV=${PV/_p${PATCHNO}}
- MY_P=${PN}-${MY_PV}
-fi
-
-S="${WORKDIR}/${MY_P}"
-DESCRIPTION="Oracle Berkeley DB"
-HOMEPAGE="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
-SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
-for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
- export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
-done
-
-LICENSE="OracleDB"
-SLOT="4.6"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="tcl java doc nocxx"
-
-DEPEND="tcl? ( >=dev-lang/tcl-8.4[lib32?] )
- java? ( >=virtual/jdk-1.4 )
- >=sys-devel/binutils-2.16.1"
-RDEPEND="tcl? ( dev-lang/tcl[lib32?] )
- java? ( >=virtual/jre-1.4 )"
-
-src_unpack() {
- unpack "${MY_P}".tar.gz
- cd "${S}"
- for (( i=1 ; i<=${PATCHNO} ; i++ ))
- do
- epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
- done
- epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-libtool.patch
-
- # use the includes from the prefix
- epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-jni-check-prefix-first.patch
- epatch "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
-
- # Include the SLOT for Java JAR files
- # This supersedes the unused jarlocation patches.
- sed -r -i \
- -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- "${S}"/dist/Makefile.in
-
- cd "${S}"/dist
- rm -f aclocal/libtool.m4
- sed -i \
- -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
- configure.ac
- sed -i \
- -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
- aclocal/programs.m4
- AT_M4DIR="aclocal aclocal_java" eautoreconf
- # Upstream sucks - they do autoconf and THEN replace the version variables.
- . ./RELEASE
- sed -i \
- -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \
- -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \
- -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \
- -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \
- -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \
- -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure
-}
-
-src_configure() { :; }
-
-multilib-native_src_compile_internal() {
- # compilation with -O0 fails on amd64, see bug #171231
- if use amd64 && [ ${ABI} = "amd64" ]; then
- replace-flags -O0 -O2
- is-flagq -O[s123] || append-flags -O2
- fi
-
- local myconf=""
-
- use amd64 && [ ${ABI} = "amd64" ] && myconf="${myconf} --with-mutex=x86/gcc-assembly"
-
- myconf="${myconf} $(use_enable !nocxx cxx)"
-
- use tcl \
- && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
- || myconf="${myconf} --disable-tcl"
-
- myconf="${myconf} $(use_enable java)"
- if use java; then
- myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
- # Can't get this working any other way, since it returns spaces, and
- # bash doesn't seem to want to pass correctly in any way i try
- local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
- fi
-
- [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
-
- # the entire testsuite needs the TCL functionality
- if use tcl && has test $FEATURES ; then
- myconf="${myconf} --enable-test"
- else
- myconf="${myconf} --disable-test"
- fi
-
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU; then
- append-ldflags -Wl,--default-symver
- fi
-
- cd "${S}/build_unix" && ECONF_SOURCE="${S}"/dist econf \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --libdir=/usr/"$(get_libdir)" \
- --enable-compat185 \
- --enable-o_direct \
- --without-uniquename \
- --enable-rpc \
- --host="${CHOST}" \
- ${myconf} "${javaconf}" || die "configure failed"
-
- sed -e "s,\(^STRIP *=\).*,\1\"none\"," Makefile > Makefile.cpy \
- && mv Makefile.cpy Makefile
-
- emake || die "make failed"
-}
-
-multilib-native_src_install_internal() {
- cd build_unix && einstall libdir="${D}/usr/$(get_libdir)" STRIP="none" || die
-
- db_src_install_usrbinslot
-
- db_src_install_headerslot
-
- db_src_install_doc
-
- db_src_install_usrlibcleanup
-
- dodir /usr/sbin
- mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
-
- if use java; then
- java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
- rm -f "${D}"/usr/"$(get_libdir)"/*.jar
- fi
-}
-
-pkg_postinst() {
- db_fix_so
-}
-
-pkg_postrm() {
- db_fix_so
-}