summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-03-10 16:42:50 -0400
committerBrian Evans <grknight@gentoo.org>2015-03-10 16:43:17 -0400
commit5f9a1f024556d0b98739e37e27c07c7fb5db7f0a (patch)
tree834c065fbcf4e6ab44d2b5db38c69df25d378d29
parentUpdate index for new 10.1 beta including a patch (diff)
downloadmysql-extras-5f9a1f024556d0b98739e37e27c07c7fb5db7f0a.tar.gz
mysql-extras-5f9a1f024556d0b98739e37e27c07c7fb5db7f0a.tar.bz2
mysql-extras-5f9a1f024556d0b98739e37e27c07c7fb5db7f0a.zip
Respin 2 patches for mysql-5.7.6_alpha
-rw-r--r--00000_index.txt16
-rw-r--r--20008_all_mysql-tzinfo-symlink-5.7.6.patch101
-rw-r--r--20009_all_mysql_myodbc_symbol_fix-5.7.6.patch12
3 files changed, 127 insertions, 2 deletions
diff --git a/00000_index.txt b/00000_index.txt
index 3e1287d..1f4e3a1 100644
--- a/00000_index.txt
+++ b/00000_index.txt
@@ -1788,7 +1788,13 @@
@@ Remove -Werror from USE="debug" builds
@patch 20008_all_mysql-tzinfo-symlink.patch
-@ver 5.05.36.00 to 5.99.99.99
+@ver 5.05.36.00 to 5.06.99.99
+@pn mysql
+@pn percona-server
+@@ Backport tzinfo symlink fix from MariaDB bug 491176
+
+@patch 20008_all_mysql-tzinfo-symlink-5.7.6.patch
+@ver 5.07.00.00 to 5.99.99.99
@pn mysql
@pn percona-server
@@ Backport tzinfo symlink fix from MariaDB bug 491176
@@ -1817,7 +1823,13 @@
@@ Export missing symbols
@patch 20009_all_mysql_myodbc_symbol_fix-5.6.patch
-@ver 5.06.00.00 to 5.07.99.99
+@ver 5.06.00.00 to 5.06.99.99
+@pn mysql
+@pn percona-server
+@@ Export missing symbols
+
+@patch 20009_all_mysql_myodbc_symbol_fix-5.7.6.patch
+@ver 5.07.00.00 to 5.99.99.99
@pn mysql
@pn percona-server
@@ Export missing symbols
diff --git a/20008_all_mysql-tzinfo-symlink-5.7.6.patch b/20008_all_mysql-tzinfo-symlink-5.7.6.patch
new file mode 100644
index 0000000..1c1ce35
--- /dev/null
+++ b/20008_all_mysql-tzinfo-symlink-5.7.6.patch
@@ -0,0 +1,101 @@
+--- a/sql/tztime.cc 2015-02-26 09:51:45.000000000 -0500
++++ b/sql/tztime.cc 2015-03-10 11:15:19.434545224 -0400
+@@ -2504,7 +2504,7 @@
+
+ */
+ my_bool
+-scan_tz_dir(char * name_end)
++scan_tz_dir(char * name_end, uint symlink_recursion_level)
+ {
+ MY_DIR *cur_dir;
+ char *name_end_tmp;
+@@ -2524,7 +2524,32 @@
+
+ if (MY_S_ISDIR(cur_dir->dir_entry[i].mystat->st_mode))
+ {
+- if (scan_tz_dir(name_end_tmp))
++ my_bool is_symlink;
++ if ((is_symlink= my_is_symlink(fullname)) &&
++ symlink_recursion_level > 0)
++ {
++ /*
++ The timezone definition data in some Linux distributions
++ (e.g. the "timezone-data-2013f" package in Gentoo)
++ may have synlimks like:
++ /usr/share/zoneinfo/posix/ -> /usr/share/zoneinfo/,
++ so the same timezone files are available under two names
++ (e.g. "CET" and "posix/CET").
++
++ We allow one level of symlink recursion for backward
++ compatibility with earlier timezone data packages that have
++ duplicate copies of the same timezone files inside the root
++ directory and the "posix" subdirectory (instead of symlinking).
++ This makes "posix/CET" still available, but helps to avoid
++ following such symlinks infinitely:
++ /usr/share/zoneinfo/posix/posix/posix/.../posix/
++ */
++ fflush(stdout);
++ fprintf(stderr, "Warning: Skipping directory '%s': "
++ "to avoid infinite symlink recursion.\n", fullname);
++ continue;
++ }
++ if (scan_tz_dir(name_end_tmp, symlink_recursion_level + is_symlink))
+ {
+ my_dirend(cur_dir);
+ return 1;
+@@ -2536,14 +2561,20 @@
+ if (!tz_load(fullname, &tz_info, &tz_storage))
+ print_tz_as_sql(root_name_end + 1, &tz_info);
+ else
++ {
++ fflush(stdout);
+ fprintf(stderr,
+ "Warning: Unable to load '%s' as time zone. Skipping it.\n",
+ fullname);
++ }
+ free_root(&tz_storage, MYF(0));
+ }
+ else
++ {
++ fflush(stdout);
+ fprintf(stderr, "Warning: '%s' is not regular file or directory\n",
+ fullname);
++ }
+ }
+ }
+
+@@ -2577,8 +2608,9 @@
+ printf("TRUNCATE TABLE time_zone_transition_type;\n");
+
+ printf("START TRANSACTION;\n");
+- if (scan_tz_dir(root_name_end))
++ if (scan_tz_dir(root_name_end, 0))
+ {
++ fflush(stdout);
+ fprintf(stderr, "There were fatal errors during processing "
+ "of zoneinfo directory\n");
+ return 1;
+@@ -2593,6 +2625,7 @@
+ {
+ if (tz_load(argv[2], &tz_info, &tz_storage))
+ {
++ fflush(stdout);
+ fprintf(stderr, "Problems with zoneinfo file '%s'\n", argv[2]);
+ return 1;
+ }
+@@ -2602,6 +2635,7 @@
+ {
+ if (tz_load(argv[1], &tz_info, &tz_storage))
+ {
++ fflush(stdout);
+ fprintf(stderr, "Problems with zoneinfo file '%s'\n", argv[2]);
+ return 1;
+ }
+@@ -2613,6 +2647,7 @@
+ free_root(&tz_storage, MYF(0));
+ }
+
++ my_end(0);
+ return 0;
+ }
+
diff --git a/20009_all_mysql_myodbc_symbol_fix-5.7.6.patch b/20009_all_mysql_myodbc_symbol_fix-5.7.6.patch
new file mode 100644
index 0000000..a4a5f45
--- /dev/null
+++ b/20009_all_mysql_myodbc_symbol_fix-5.7.6.patch
@@ -0,0 +1,12 @@
+diff -aurN a/libmysql/CMakeLists.txt b/libmysql/CMakeLists.txt
+--- a/libmysql/CMakeLists.txt 2015-02-26 09:51:43.000000000 -0500
++++ b/libmysql/CMakeLists.txt 2015-03-10 10:47:52.759629219 -0400
+@@ -155,6 +155,8 @@
+ # will have a FR to replace this for decent name/functionality and document it.
+ my_load_defaults
+ handle_options
++dynstr_append_os_quoted
++strfill
+
+ CACHE INTERNAL "Undocumented Functions exported by client API"
+