summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-03-09 09:01:50 -0500
committerBrian Evans <grknight@gentoo.org>2018-03-09 09:01:50 -0500
commitffe03fdc0db87c6022545d785e1cce0548cee361 (patch)
tree480b4bf0372000f52cbc87249eaa960c87c2b088
parentAdd new upstream patches (diff)
downloadmysql-extras-ffe03fdc0db87c6022545d785e1cce0548cee361.tar.gz
mysql-extras-ffe03fdc0db87c6022545d785e1cce0548cee361.tar.bz2
mysql-extras-ffe03fdc0db87c6022545d785e1cce0548cee361.zip
client-libs: Adjust patch correctly for perror and my_print_defaults
-rw-r--r--20018_all_mariadb-10.2.9-without-clientlibs-tools.patch11
1 files changed, 7 insertions, 4 deletions
diff --git a/20018_all_mariadb-10.2.9-without-clientlibs-tools.patch b/20018_all_mariadb-10.2.9-without-clientlibs-tools.patch
index db72584..36dff10 100644
--- a/20018_all_mariadb-10.2.9-without-clientlibs-tools.patch
+++ b/20018_all_mariadb-10.2.9-without-clientlibs-tools.patch
@@ -56,16 +56,19 @@ diff -aurN a/CMakeLists.txt b/CMakeLists.txt
diff -aurN a/extra/CMakeLists.txt b/extra/CMakeLists.txt
--- a/extra/CMakeLists.txt 2018-02-27 16:45:56.470183732 -0500
+++ b/extra/CMakeLists.txt 2018-02-27 16:53:11.095621060 -0500
-@@ -46,12 +46,12 @@
+@@ -46,12 +46,17 @@
DEPENDS
${CMAKE_BINARY_DIR}/include/mysqld_error.h.tmp)
-
--MYSQL_ADD_EXECUTABLE(my_print_defaults my_print_defaults.c)
++IF(NOT WITHOUT_CLIENTLIBS)
+ MYSQL_ADD_EXECUTABLE(my_print_defaults my_print_defaults.c)
++MYSQL_ADD_EXECUTABLE(perror perror.c)
++ELSE(NOT WITHOUT_CLIENTLIBS)
+ADD_EXECUTABLE(my_print_defaults my_print_defaults.c)
++ADD_EXECUTABLE(perror perror.c)
++ENDIF(NOT WITHOUT_CLIENTLIBS)
TARGET_LINK_LIBRARIES(my_print_defaults mysys)
-MYSQL_ADD_EXECUTABLE(perror perror.c)
-+ADD_EXECUTABLE(perror perror.c)
ADD_DEPENDENCIES(perror GenError)
TARGET_LINK_LIBRARIES(perror mysys)