summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSascha Lucas <sascha_lucas@web.de>2008-11-16 11:15:53 +0100
committerSascha Lucas <sascha_lucas@web.de>2008-11-16 11:15:53 +0100
commit2d44c50c31ab534dc79386812728677f8d8f5f3e (patch)
treecf00a4a0cfd342f98d0bffedf08529e0c9ed9d5a
parentadded mail-client/topal and alpine/metadata.xml (diff)
downloadnet-mail-2d44c50c31ab534dc79386812728677f8d8f5f3e.tar.gz
net-mail-2d44c50c31ab534dc79386812728677f8d8f5f3e.tar.bz2
net-mail-2d44c50c31ab534dc79386812728677f8d8f5f3e.zip
fixed the alpine ebuild as suggested by tove
-rw-r--r--mail-client/alpine/Manifest5
-rw-r--r--mail-client/alpine/alpine-2.00.ebuild114
2 files changed, 59 insertions, 60 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index fc2e7c7..831b1a8 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -1,3 +1,4 @@
-DIST all.patch.gz 175441 RMD160 61a305811c9d12596eacd66d21aee8edccec469d SHA1 701be50ee37cc1e35ae1df49f9228244197cb91b SHA256 2c66cf76ad413aefd31e5eb8e00198a2739e3816e9f676fa84f2186bf2ea084d
+DIST alpine-2.00-all.patch.gz 175441 RMD160 61a305811c9d12596eacd66d21aee8edccec469d SHA1 701be50ee37cc1e35ae1df49f9228244197cb91b SHA256 2c66cf76ad413aefd31e5eb8e00198a2739e3816e9f676fa84f2186bf2ea084d
DIST alpine-2.00.tar.bz2 5222673 RMD160 9e67704b23b3973d8b878e65ad9e6f5026c10d13 SHA1 dcbd3c5419954f484ccf706feaba31ce48cdebc4 SHA256 c85db8405af90375ba2440c85b7952d80996154e9916b83acca558dc82e0a2a6
-EBUILD alpine-2.00.ebuild 3772 RMD160 2d82f187d08815c7321e8428409968da310c3973 SHA1 a788dc1dcf2b3a54cdcb108d51f80874001e2b44 SHA256 861ba737f908a7add43f880a82b66a4e4d08f4e5bfc37205d74b8c78b8eeb80c
+EBUILD alpine-2.00.ebuild 3424 RMD160 df2dc80a7e708b5a73084682581f161640c53a95 SHA1 10395b99d3039f8649c739032b7d7bcfad11a97d SHA256 da8151ecf5fdf207a8cdbbbee1dac8936e8206e4ea1ec8dc9e1602d384f4c054
+MISC metadata.xml 640 RMD160 c119e031ce500620da76dfcf67328e05f292c1c6 SHA1 6fc3b455d4cc83a601efd669a8c9f1c2641a6304 SHA256 5b19a81befa59e196971e823b86d26ff711c58240b0bcae0bcf5076a3133a6d2
diff --git a/mail-client/alpine/alpine-2.00.ebuild b/mail-client/alpine/alpine-2.00.ebuild
index 54d143b..8febd53 100644
--- a/mail-client/alpine/alpine-2.00.ebuild
+++ b/mail-client/alpine/alpine-2.00.ebuild
@@ -2,26 +2,28 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
inherit eutils
-DESCRIPTION="alpine is the successor of the famous mail and news reader pine"
+DESCRIPTION="alpine is an easy to use text-based based mail and news client"
HOMEPAGE="http://www.washington.edu/alpine/ http://staff.washington.edu/chappa/alpine/"
SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2
- chappa? ( http://staff.washington.edu/chappa/alpine/patches/${P}/all.patch.gz )"
+ chappa? ( http://staff.washington.edu/chappa/alpine/patches/${P}/all.patch.gz -> ${PF}-all.patch.gz )"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~x86 ~amd64 ~x86-fbsd"
-IUSE="chappa doc ipv6 kerberos ldap nls onlyalpine passfile smime spell ssl threads topal userland_BSD"
+KEYWORDS="~x86 ~amd64"
+IUSE="+chappa doc ipv6 kerberos ldap nls onlyalpine passfile smime spell ssl threads topal"
RESTRICT="nomirror"
DEPEND="virtual/pam
- >=sys-libs/ncurses-5.1
- ssl? ( dev-libs/openssl )
- ldap? ( net-nds/openldap )
- kerberos? ( app-crypt/mit-krb5 )
- spell? ( app-text/aspell )
- topal? ( >=mail-client/topal-62 )"
+ >=sys-libs/ncurses-5.1
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ kerberos? ( app-crypt/mit-krb5 )
+ spell? ( app-text/aspell )
+ topal? ( >=mail-client/topal-64 )"
RDEPEND="${DEPEND}
app-misc/mime-types
!onlyalpine? ( !app-editors/pico )
@@ -29,54 +31,55 @@ RDEPEND="${DEPEND}
!<=net-mail/uw-imap-2004g"
maildir_warn() {
- elog
- elog "This build of ${PN} has Maildir support built in as"
- elog "part of the chappa-all patch."
- elog
- elog "If you have a maildir at ~/Maildir it will be your"
- elog "default INBOX. The path may be changed with the"
- elog "\"maildir-location\" setting in alpine."
- elog
- elog "To use /var/spool/mail INBOX again, set"
- elog "\"disable-these-drivers=md\" in your .pinerc file."
- elog
- elog "Alternately, you might want to read following webpage, which explains how to"
- elog "use multiple mailboxes simultaneously:"
- elog
- elog "http://www.math.washington.edu/~chappa/pine/pine-info/collections/incoming-folders/"
- elog
+ elog
+ elog "This build of ${PN} has Maildir support built in as"
+ elog "part of the chappa-all patch."
+ elog
+ elog "If you have a maildir at ~/Maildir it will be your"
+ elog "default INBOX. The path may be changed with the"
+ elog "\"maildir-location\" setting in alpine."
+ elog
+ elog "To use /var/spool/mail INBOX again, set"
+ elog "\"disable-these-drivers=md\" in your .pinerc file."
+ elog
+ elog "Alternately, you might want to read following webpage, which explains how to"
+ elog "use multiple mailboxes simultaneously:"
+ elog
+ elog "http://www.math.washington.edu/~chappa/pine/pine-info/collections/incoming-folders/"
+ elog
}
src_unpack() {
- unpack ${A}
- use chappa && epatch "${WORKDIR}"/all.patch
- # topal needs updating for alpine 2.00
- #use topal && epatch /usr/share/topal/patches/${P}.patch
- use topal && die "topal needs updating for ${P}. Please disable it for now."
+ unpack ${P}.tar.bz2
}
-src_compile() {
+src_prepare() {
+ use chappa && epatch "${DISTDIR}"/${PF}-all.patch.gz
+ use topal && epatch /usr/share/topal/patches/${P}.patch
+}
+
+src_configure() {
local myconf="--without-tcl
- --with-system-pinerc=/etc/pine.conf
- --with-system-fixed-pinerc=/etc/pine.conf.fixed
- --with-ssl-certs-dir=/etc/ssl/certs"
-
- use ssl || myconf="${myconf} --without-ssl"
- use ldap || myconf="${myconf} --without-ldap"
- use passfile && myconf="${myconf} --with-passfile=.pinepwd"
- use kerberos || myconf="${myconf} --without-krb5"
- use threads || myconf="${myconf} --without-pthread"
- use spell && myconf="${myconf} --with-interactive-spellcheck=/usr/bin/aspell"
- use nls || myconf="${myconf} --disable-nls"
- use ipv6 || myconf="${myconf} --without-ipv6"
- use smime || myconf="${myconf} --without-smime"
-
- # fixme
- # --with-system-mail-directory=DIR?
-
- econf ${myconf} || die "configure problem"
-
- use userland_BSD && make || emake
+ --with-system-pinerc=/etc/pine.conf
+ --with-system-fixed-pinerc=/etc/pine.conf.fixed
+ --with-ssl-certs-dir=/etc/ssl/certs"
+ # fixme
+ # --with-system-mail-directory=DIR?
+ # smime should be off if topal is on
+ econf $(use_with ssl) \
+ $(use_with ldap) \
+ $(use_with passfile passfile .pinepwd) \
+ $(use_with kerberos krb5) \
+ $(use_with threads pthread) \
+ $(use_with spell interactive-spellcheck /usr/bin/aspell) \
+ $(use_enable nls) \
+ $(use_with ipv6) \
+ $(use_with smime) \
+ ${myconf} || die "configure problem"
+}
+
+src_compile() {
+ emake || die "emake failed"
}
src_install() {
@@ -84,12 +87,7 @@ src_install() {
dobin alpine/alpine
doman doc/alpine.1
else
- if use userland_BSD; then
- make DESTDIR="${D}" install
- else
- emake DESTDIR="${D}" install
- fi
-
+ emake DESTDIR="${D}" install
doman doc/rpdump.1 doc/rpload.1
fi