summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/x2goprint/x2goprint-3.0.0.1.ebuild')
-rw-r--r--net-misc/x2goprint/x2goprint-3.0.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/x2goprint/x2goprint-3.0.0.1.ebuild b/net-misc/x2goprint/x2goprint-3.0.0.1.ebuild
new file mode 100644
index 0000000..db9c21d
--- /dev/null
+++ b/net-misc/x2goprint/x2goprint-3.0.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+inherit versionator eutils
+
+MAJOR_PV="$(get_version_component_range 1-3)"
+FULL_PV="${MAJOR_PV}-$(get_version_component_range 4)"
+DESCRIPTION="The X2Go usb mount tool"
+HOMEPAGE="http://x2go.berlios.de"
+SRC_URI="http://x2go.obviously-nice.de/deb/pool-lenny/${PN}/${PN}_${FULL_PV}_all.deb"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${MAJOR_PV}.orig
+
+src_unpack(){
+unpack ${A}
+ cd "${S}"
+
+ tar xozf data.tar.gz || die "failure unpacking data.tar.gz"
+}
+
+src_install(){
+ dobin usr/bin/*
+}