summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/x2goserver/x2goserver-3.0.1.1.ebuild')
-rw-r--r--net-misc/x2goserver/x2goserver-3.0.1.1.ebuild97
1 files changed, 34 insertions, 63 deletions
diff --git a/net-misc/x2goserver/x2goserver-3.0.1.1.ebuild b/net-misc/x2goserver/x2goserver-3.0.1.1.ebuild
index c204483..777d4bd 100644
--- a/net-misc/x2goserver/x2goserver-3.0.1.1.ebuild
+++ b/net-misc/x2goserver/x2goserver-3.0.1.1.ebuild
@@ -1,97 +1,68 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=1
inherit versionator
-MY_P="${PN}_$(replace_version_separator 3 -)"
+MAJOR_PV="$(get_version_component_range 1-3)"
+FULL_PV="${MAJOR_PV}-$(get_version_component_range 4)"
DESCRIPTION="The X2Go server"
HOMEPAGE="http://x2go.berlios.de"
-SRC_URI="http://x2go.obviously-nice.de/deb/pool-lenny/${PN}/${MY_P}.tar.gz"
+SRC_URI="http://x2go.obviously-nice.de/deb/pool-lenny/${PN}/${PN}_${FULL_PV}_all.deb"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+fuse postgres +sqlite"
+IUSE="+fuse kde ldap"
DEPEND=""
RDEPEND="app-admin/sudo
net-misc/nx
+ virtual/postgresql-server
virtual/ssh
fuse? ( sys-fs/sshfs-fuse )
- postgres? ( virtual/postgresql-server )
- sqlite? ( !postgres? ( >=dev-db/sqlite-3 ) )"
+ kde? ( net-misc/x2gokdebindings
+ net-misc/x2gosessionadministration )
+ ldap? ( net-misc/x2goldaptools
+ kde? ( net-misc/x2gogroupadministration
+ net-misc/x2gohostadministration
+ net-misc/x2gosystemadministration
+ net-misc/x2gouseradministration ) )"
-S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
+S=${WORKDIR}
-pkg_setup() {
- if use postgres && use sqlite ; then
- ewarn "You have selected both PostgreSQL and SQLite. This installation of x2goserver"
- ewarn "will default to PostgreSQL. Add USE=-postgres if you prefer SQLite."
- fi
- if use !postgres && use !sqlite ; then
- ewarn "You have selected neither PostgreSQL or SQLite as a database. You will need"
- ewarn "to use a remote PostgreSQL database."
- fi
-}
-
-src_prepare() {
- # Needs testing, is it fully compatible with nxagent?
- sed -i -e 's/x2goagent/nxagent/' x2gostartagent || die "sed failed"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
- sed -i -e 's/sqlite/sqlite3/' x2gosqlite.sh || die "sed failed"
+ tar xozf data.tar.gz || die "failure unpacking data.tar.gz"
- cp "${FILESDIR}"/${PN}.init .
- if use !postgres ; then
- sed -i -e '/need postgresql/d' ${PN}.init || die "sed failed"
- fi
+ # Needs testing, is it fully compatible with nxagent?
+ sed -i -e "s/x2goagent/nxagent/" usr/bin/x2gostartagent || die "sed failed"
}
src_install() {
- exeinto /usr/share/x2go/script
- doexe x2go*.sh
- rm x2go*.sh
+ dobin usr/bin/*
+ dosbin usr/sbin/*
- dosbin x2gocleansessions
- rm x2gocleansessions
-
- dobin x2go*
-
- mkdir -p "${D}/etc/x2go"
- if use postgres ; then
- echo -n local > "${D}/etc/x2go/sql"
- elif use sqlite ; then
- echo -n sqlite > "${D}/etc/x2go/sql"
- else echo -n "Replace this with your remote PostgreSQL server's address" > "${D}/etc/x2go/sql"
- fi
-
- newinitd ${PN}.init ${PN}
+ exeinto /usr/share/x2go/script
+ doexe usr/lib/x2go/script/x2gocreatebase.sh
- dodoc INSTALL debian/changelog
+ insinto /etc/x2go
+ doins etc/x2go/sql
- keepdir /var/db/x2go
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
}
pkg_postinst() {
- if use postgres ; then
- elog "You have selected a PostgreSQL database. If you are installing x2goserver for"
- elog "the first time you need to create the database with the following script:"
- elog "/usr/share/x2go/script/x2gocreatebase.sh"
- elog "If you are changing to PostreSQL from SQLite you need to remove the old"
- elog "database at /var/db/x2go/x2go_sessions and run the above script."
- elif use sqlite ; then
- elog "You have selected an SQLite database. If you are installing x2goserver for"
- elog "the first time you need to create the database with the following script:"
- elog "/usr/share/x2go/script/x2gosqlite.sh"
- elog "If you are changing to SQLite from PostreSQL you need to remove the old"
- elog "database at /var/db/x2go/x2go_sessions and run the above script."
- else
- elog "You have selected a remote database. You will need to specify the address of"
- elog "your remote PostgreSQL server in /etc/x2go/sql."
- fi
+ elog "To work, x2goserver needs a configured postgreSQL database"
+ elog "To use a database on localhost:"
+ elog " echo -n local > /etc/x2go/sql"
+ elog "Sample script to create the database can be found here:"
+ elog " /usr/share/x2go/script/x2gocreatebase.sh"
einfo ""
- elog "You will need to give sudo rights on x2gopgwrapper to your users"
+ elog "You also need to give sudo rights on x2gopgwrapper to your users"
elog "A sudoers example for all members of the group users:"
elog " %users ALL=(ALL) NOPASSWD: /usr/bin/x2gopgwrapper"
elog "To give only a special group access to the x2goserver, "