aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Hajdan, Jr <phajdan.jr@gentoo.org>2012-03-20 19:10:40 +0100
committerPawel Hajdan, Jr <phajdan.jr@gentoo.org>2012-03-20 19:10:47 +0100
commit2b4bd18ae09dbe7d1e0ea07c2ca0a7fe891c621e (patch)
tree6b216b13e159ce50a02dea6da9f9fd55e819e60e
parentImplement support for pam_loginuid as needed for bug #342345 (diff)
downloadpambase-2b4bd18ae09dbe7d1e0ea07c2ca0a7fe891c621e.tar.gz
pambase-2b4bd18ae09dbe7d1e0ea07c2ca0a7fe891c621e.tar.bz2
pambase-2b4bd18ae09dbe7d1e0ea07c2ca0a7fe891c621e.zip
Add pam.d files for login, passwd and su.pambase-20120417
Those should be shared between shadow implementations.
-rw-r--r--.gitignore3
-rw-r--r--Makefile2
-rw-r--r--login.in6
-rw-r--r--passwd.in6
-rw-r--r--su.in12
5 files changed, 28 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 81b97ba..2c63905 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,6 @@
+login
+passwd
+su
system-auth
system-login
system-local-login
diff --git a/Makefile b/Makefile
index 31482e8..7d3e22a 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@
CPP=cpp
# The pam.d file to create
-PAMD=system-auth system-login system-local-login system-remote-login system-services other
+PAMD=login passwd su system-auth system-login system-local-login system-remote-login system-services other
# command for git (the DVCS); set this to "true" to ignore GIT support
# (i.e.: in the ebuild)
diff --git a/login.in b/login.in
new file mode 100644
index 0000000..13abd27
--- /dev/null
+++ b/login.in
@@ -0,0 +1,6 @@
+auth required pam_securetty.so
+auth include system-local-login
+
+account include system-local-login
+password include system-local-login
+session include system-local-login
diff --git a/passwd.in b/passwd.in
new file mode 100644
index 0000000..7eabf3d
--- /dev/null
+++ b/passwd.in
@@ -0,0 +1,6 @@
+auth sufficient pam_rootok.so
+auth include system-auth
+
+account include system-auth
+
+password include system-auth
diff --git a/su.in b/su.in
new file mode 100644
index 0000000..121bb9a
--- /dev/null
+++ b/su.in
@@ -0,0 +1,12 @@
+auth sufficient pam_rootok.so
+auth required pam_wheel.so use_uid
+auth include system-auth
+
+account include system-auth
+
+password include system-auth
+
+session include system-auth
+session required pam_env.so
+session optional pam_xauth.so
+