summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2010-12-24 20:31:23 +0100
committerRaúl Porcel <armin76@gentoo.org>2010-12-24 20:31:23 +0100
commit0b3677b1cb0e03ee9a5d394b8b860d819126f4e8 (patch)
tree469649c3c0664ab41b8a7e466eee15fe1e049b5e /net-wireless/tiwlan-wl1271
parentAdd manifest (diff)
downloadpandaboard-0b3677b1cb0e03ee9a5d394b8b860d819126f4e8.tar.gz
pandaboard-0b3677b1cb0e03ee9a5d394b8b860d819126f4e8.tar.bz2
pandaboard-0b3677b1cb0e03ee9a5d394b8b860d819126f4e8.zip
Reworked wireless driver ebuild, new kernel source
Diffstat (limited to 'net-wireless/tiwlan-wl1271')
-rw-r--r--net-wireless/tiwlan-wl1271/ChangeLog8
-rw-r--r--net-wireless/tiwlan-wl1271/Manifest3
-rw-r--r--net-wireless/tiwlan-wl1271/tiwlan-wl1271-0.24.9.ebuild26
3 files changed, 31 insertions, 6 deletions
diff --git a/net-wireless/tiwlan-wl1271/ChangeLog b/net-wireless/tiwlan-wl1271/ChangeLog
new file mode 100644
index 0000000..625d23e
--- /dev/null
+++ b/net-wireless/tiwlan-wl1271/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-wireless/tiwlan-wl1271
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 24 Dec 2010; Raúl Porcel <armin76@gentoo.org>
+ tiwlan-wl1271-0.24.9.ebuild:
+ Enhanced ebuild
+
diff --git a/net-wireless/tiwlan-wl1271/Manifest b/net-wireless/tiwlan-wl1271/Manifest
index 00d8f3f..1f156f6 100644
--- a/net-wireless/tiwlan-wl1271/Manifest
+++ b/net-wireless/tiwlan-wl1271/Manifest
@@ -1,4 +1,5 @@
DIST tiwlan-wl1271_0.24.9-0ubuntu6.diff.gz 5228 RMD160 3dc0bb430d8e9b4cc12bbef050880b36c3af48af SHA1 72d21447f83b9113aa059c66db351a132c86dcb6 SHA256 bd9c72409a2cd79ff14c05f4e1d258840af68ef359edb8cbb3baf2f8c8d1c12c
DIST tiwlan-wl1271_0.24.9.orig.tar.gz 1251415 RMD160 f10c004a0770de6efd61eb5b6a7d4f20147b15ea SHA1 6fbfd5b8bb382ed68e66116e061e41a41bec5d98 SHA256 60a64c8c3daee9dc897a8918e2f082bcfcb4a3dbd66c013978e331e1c8e6127b
-EBUILD tiwlan-wl1271-0.24.9.ebuild 1176 RMD160 0e63bda94020f38b98755d8012da9b7f504d13b9 SHA1 82fa44ad4b32eba52020b9e6c3e1ba97243bb25a SHA256 e7e3031b2f373ba41a6fcd4448e35cddfc50efe7905fb6c3be633ce5dfae35eb
+EBUILD tiwlan-wl1271-0.24.9.ebuild 1520 RMD160 1a480eb6cb864e704b0eacf932aca587b1c692fa SHA1 52bc6789e61fa3693e4c00012675ded6a51b34fc SHA256 30371da654faa299ae034fbdc14d6da7df6531b12db1eaa97981062b57f186df
+MISC ChangeLog 226 RMD160 865cb82d56f68a03ebadb5952c5c81e31eb42987 SHA1 2db2fe47296b2ef3c65853077ea7b63308384a6c SHA256 60eb2847621f2908efd00cdedcfea3bf52e84d26143facafa0136841d79c7f53
MISC metadata.xml 222 RMD160 3f50aa50f95905f1387e67bc72c80b4c1b63aab4 SHA1 b5ad6eab5a55d57fd25fa68a46d1359cc25759aa SHA256 b8f80af5f2e9d409535bd1e3981b685a013f820ec82b504d82d5c9c077cd9fa6
diff --git a/net-wireless/tiwlan-wl1271/tiwlan-wl1271-0.24.9.ebuild b/net-wireless/tiwlan-wl1271/tiwlan-wl1271-0.24.9.ebuild
index 8251104..2e90a53 100644
--- a/net-wireless/tiwlan-wl1271/tiwlan-wl1271-0.24.9.ebuild
+++ b/net-wireless/tiwlan-wl1271/tiwlan-wl1271-0.24.9.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-wireless/zd1211-firmware/zd1211-firmware-1.4.ebuild,v 1.2 2007/11/03 12:03:19 dsd Exp $
EAPI="2"
-inherit eutils
+inherit eutils linux-mod
MY_P="${PN}_${PV}"
@@ -25,17 +25,30 @@ RDEPEND="net-wireless/tiwlan-wl1271-firmware"
DEPEND="${RDEPEND}"
+pkg_setup() {
+ linux-mod_pkg_setup
+
+}
+
src_prepare() {
cd ${WORKDIR}
epatch ${MY_P}*.diff
cd "${S}"
epatch "${S}"/debian/patches/*.patch
+
+ cd wlan
+ cp wlan/Makefile .
}
src_compile() {
-# cd "${S}"
- make -j1
+ cd wlan
+ # compile modules
+ emake -j1 KERNEL_HEADERS=${KV_DIR} || die
+
+ # compile utils
+ cd CUDK
+ emake -j1 || die
}
src_install() {
@@ -50,5 +63,8 @@ src_install() {
insinto /lib/firmware/tiwlan-wl1271
doins tiwlan.ini tiwlan_dual.ini
-
+ cd "${S}"/wlan
+ insinto /lib/modules/${KV_FULL}/kernel/drivers/net/wireless/tiwlan-wl1271
+ doins sdio.ko tiwlan_drv.ko
+
}