aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-07-25 00:09:46 +0530
committerMike Frysinger <vapier@gentoo.org>2016-11-12 02:10:03 -0500
commit9ae5c22341a0484319c15d12cae1a46835c48379 (patch)
treea4ad7c8f02865184507b8651940e730bf3daae45 /Makefile.am
parentsplit out fs related helper funcs as lib code (diff)
downloadpax-utils-9ae5c22341a0484319c15d12cae1a46835c48379.tar.gz
pax-utils-9ae5c22341a0484319c15d12cae1a46835c48379.tar.bz2
pax-utils-9ae5c22341a0484319c15d12cae1a46835c48379.zip
split out ld.so.cache & ld.so.conf parsing logic
These are getting a bit big & unwieldy for keeping inlined in scanelf. Split them out to a dedicated file instead.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c1945a..a2c02d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,6 +11,7 @@ libpaxutils_la_LDFLAGS = -no-undefined
libpaxutils_la_SOURCES = \
paxelf.c \
paxinc.c \
+ paxldso.c \
paxmacho.c \
security.c \
xfuncs.c
@@ -81,6 +82,8 @@ EXTRA_DIST += \
paxelf.h \
paxinc.c \
paxinc.h \
+ paxldso.c \
+ paxldso.h \
paxmacho.c \
paxmacho.h \
porting.h \