aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-16 18:32:47 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-16 18:32:47 -0500
commit35525e096061c33b9c10cfb2b0312846b4b0b9fe (patch)
tree86dcb5db4756658c7a83652cd31fc1283ed5d9f0 /Makefile
parentenable travis build support (diff)
downloadpax-utils-35525e096061c33b9c10cfb2b0312846b4b0b9fe.tar.gz
pax-utils-35525e096061c33b9c10cfb2b0312846b4b0b9fe.tar.bz2
pax-utils-35525e096061c33b9c10cfb2b0312846b4b0b9fe.zip
use `sed -E -i.tmp` everywhere
POSIX is adding the -E flag to enable ERE behavior, and GNU/sed already supports this, as do various BSD systems (including OS X). While GNU makes the suffix to -i optional, POSIX/etc... do not, so make sure we always specify it.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 26cc9d4..b3782a6 100644
--- a/Makefile
+++ b/Makefile
@@ -163,7 +163,8 @@ GEN_MARK_END = \# @@@ GEN END @@@ \#
EXTRA_DIST = $(shell git ls-files)
autotools-update:
$(MAKE) -C man -j
- sed -i '/^$(GEN_MARK_START)$$/,/^$(GEN_MARK_END)$$/d' Makefile.am
+ sed -i.tmp '/^$(GEN_MARK_START)$$/,/^$(GEN_MARK_END)$$/d' Makefile.am
+ @rm -f Makefile.am.tmp
( \
echo "$(GEN_MARK_START)"; \
printf 'dist_man_MANS +='; \