aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-04-19 22:31:49 +0000
committerNed Ludd <solar@gentoo.org>2008-04-19 22:31:49 +0000
commit6f5a5da287fb5ac2d79c68ae1aca38ea66ff7731 (patch)
treea34ee6bfd7c8c542403e5bda2a5cb470bef8db39 /Makefile
parent- keep username alingment when username exceeds 8 standard chars (diff)
downloadpax-utils-6f5a5da287fb5ac2d79c68ae1aca38ea66ff7731.tar.gz
pax-utils-6f5a5da287fb5ac2d79c68ae1aca38ea66ff7731.tar.bz2
pax-utils-6f5a5da287fb5ac2d79c68ae1aca38ea66ff7731.zip
- add -Z/--size option
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 175fbed..e8af398 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2003-2006 Ned Ludd <solar@linbsd.net>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.66 2008/01/17 06:37:44 solar Exp $
+# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.67 2008/04/19 22:31:49 solar Exp $
####################################################################
check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
@@ -13,6 +13,7 @@ WFLAGS := -Wall -Wunused -Wimplicit -Wshadow -Wformat=2 \
-Wchar-subscripts -Wcast-align -Wno-format-nonliteral \
$(call check_gcc, -Wdeclaration-after-statement) \
$(call check-gcc, -Wsequence-point) \
+ $(call check-gcc, -Wstrict-overflow) \
$(call check-gcc, -Wextra)
CFLAGS ?= -O2 -pipe